نوشته‌ها

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو :همانطور که گفته شد پروتکل های مسیریابی به سه دسته Distance Vector و Link State و Hybrid تقسیم بندی می شوند ، در این نکته قصد داریم پروتکل های مسیریابی یا روتینگ Distance Vector که ساده ترین نوع پروتکل های مسیریابی هستند را برای شما تشریح کنیم. همانطور که از نام اینگونه پروتکل ها نیز پیداست از دو فاکتور Distance یا مسافت و Vector یا جهت برای پیدا کردن مقصد استفاده می کنند. روترهایی که از پروتکل های مسیریابی Distance Vector استفاده می کنند به روترهای همسایه یا Neighbor های خود در خصوص توپولوژی شبکه و تغییراتی که در وهله های زمانی متفاوت انجام می شود اطلاع رسانی می کنند ، این اطلاع رسانی با استفاده از Broadcast انجام می شود و از آدرس IP ای به شکل 255.255.255.255 برای اینکار استفاده می کند.

پروتکل های Distance Vector از الگوریتم Bellman-Ford برای پیدا کردن بهترین مسیر برای رسیدن به مقصد استفاده می کنند.

روترهای مورداستفاده درتوپولوژی های Distance Vector برای اینکه ازاطلاعات موجوددرRouting Tableهای روترهای همسایه خودمطلع شوندبررویInterfaceهای خوددرخواست راBroadcastمیکنند.

همچنین این پروتکل ها برای Share کردن اطلاعات Routing Protocol خود نیز از ساختار Broadcasting استفاده می کنند.

معرفی پروتکل های مسیریابی Distance Vector

الگوریتم های Distance Vector تغییراتی که در Routing Table انجام می شود را بلافاصله برای روترهای همسایه خود در همه جهات ( روی همه Interface ) ارسال می کنند. با هر تبادلی که انجام می شود ، روتر Distance Value مربوط به Route دریافت شده را افزایش می دهد و Distance Value خودش را نیز بر روی Route های جدید قرار می دهد. روتری که این تغییرات یا Update ها را دریافت می کند نیز به همین ترتیب Route های خودشان را بر روی این Table قرار می دهند و برای روترهای باقی مانده ارسال می کنند ، این فرآیند به همین شکل ادامه پیدا می کند.

پروتکل های مسیریابی Distance Vector

پروتکل های Distance Vector به این موضوع توجه نمی کنند که چه کسی به Update هایی که ارسال می شوند گوش می کند ، جالب اینجاست بدانید پروتکل های Distance Vector حتی در صورتیکه هیچ تغییری در Routing Protocol خود نداشته باشند نیز بصورت متناوب Routing Table خود را Broadcast می کنند ، یعنی حتی اگر توپولوژی شبکه شما تغییر هم نکرده باشد Broadcasting انجام می شود.

پروتکل های Distance Vector ساده ترین نوع از پروتکل های مسیریابی یا Dynamic Routing هستند که در مجموعه سه تایی که عنوان شد قرار می گیرند. پیاده سازی و رفع ایراد این نوع از پروتکل ها بسیار ساده است ، همچنین روتر برای انجام فرآیند های پردازشی نیاز به منابع بسیار کمتری دارد. منطق کاری Distance Vector ها ساده است ، آنها Routing Update ها را دریافت می کنند ، مقدار Metric را افزایش می دهند ، نتایج را با مقدادیر موجود در Routing Table خود مقایسه می کنند و در صورت نیاز Routing Table را Update می کنند. پروتکل هایی مثل Routing Information Protocol یا RIP نسخه یک و Interior Gateway Routing Protocol یا IGRP از مهمترین و معروف ترین پروتکل های Dynamic Routing موجود در روترهای امروزی می باشند.

معرفی پروتکل های مسیریابی Link State

در اینجا قصد داریم به شما پروتکل های مسیریابی Link state را معرفی کنیم و تفاوت های آن با پروتکل های Distance Vector را نیز عنوان کنیم. پروتکل های Link State بر خلاف پروتکل های Distance Vector شبکه ها را در قالب Hop Count و تعداد روترهای موجود در آن نمی بینند در عوض یک دیدگاه جامع و کامل در خصوص توپولوژی های مورد استفاده در شبکه ایجاد می کنند که همه جزئیات شبکه های موجود در توپولوژی را در خود دارد ، تمامی روترها با Cost های آنها در این دید جامع و کامل وجود خواهند داشت.

در پروتکل های Link State هر یک از روترهایی که از یکی از پروتکل های Link State استفاده می کند اطلاعات کاملی در خصوص خود روتر ، لینک های مستقیم متصل شده به آن و وضعیت آن لینک ها را در اختیار شبکه قرار می دهد. این اطلاعات توسط پیام های Multicast به همه روترهای موجود در شبکه ارسال می شود دقیقا بر خلاف پروتکل های مسیریابی Distance Vector که اینکار را به وسیله استفاده از فرآیند Broadcast انجام می دادند. فرآیند مسیریابی Link State به گونه ای است که با ایجاد شدن کوچکترین تغییری در توپولوژی شبکه های موجود بلافاصله این تغییر بصورت Incremental برای سایر روترها هم ارسال می شود تا توپولوژی شبکه روی همه روترها همیشه بروز باشد.

هر کدام از روترهای موجود در شبکه های Link State یک کپی از این توپولوژی شبکه را در خود دارند و آن را تغییر نمی دهند ، بعد از اینکه آخرین تغییرات شبکه ها را دریافت کردند هر روتر بصورت کاملا مستقل به محاسبه بهترین مسیرها برای رسیدن به شبکه های مقصد می پردازد.

معرفی پروتکل های مسیریابی Link State

پروتکل های مسیریابی Link State بر اساس الگوریتمی به نام Shortest Path First یا SFP برای پیدا کردن بهترین مسیر برای رسیدن به مقصد پایه ریزی شده اند. نام دیگر این الگوریتم Dijkstra است. در الگوریتم Shortest Path First یا SPF زمانیکه وضعیت یک لینک ارتباطی تغییر می کند ، یک Routing Update که به عنوان Link-State Advertisement یا LSA شناخته می شود ایجاد می شود و بین تمامی روترهای موجود تبادل می شود.

زمانیکه یک روتر LSA Routing Update را دریافت می کند ، الگوریتم Link-State با استفاده از آن کوتاه ترین مسیر را برای رسیدن به مقصد مورد نظر محاسبه می کند. هر روتر برای خود یک نقشه کامل از شبکه ها ایجاد می کند. نمونه ای از پروتکل مسیریابی Link-State پروتکل ای به نام Open Shortest Path First یا OSPF است.

چند واژه مهم در خصوص پروتکل های Link State وجود دارد که بد نیست با آنها آشنا شوید:

Link-State Advertisement یا LSA :

یک Packet کوچک اطلاعاتی است که در آن اطلاعات مربوط به Routing بین روترها رد و بدل می شود

Topological Database :

مجموعه اطلاعاتی که از LSA ها دریافت می شود

الگوریتم SPF یا Dijkstra :

الگوریتمی است که محاسبات بر روی database های موجود در SPF Tree را انجام می دهد

Routing Table :

یک لیست از مسیرها و Interface های شناسایی شده است.

پروتکل های مسیریابی Link State در عین اینکه به مدت زمان کمتری برای Converge شدن نسبت به پروتکل های مسیریابی Distance Vector برخوردارند در مقابل بوجود آمدن Routing Loop هم نسبت به Distance Vector ها مقاوم تر هستند و کمتر موردی پیش می آید که Routing Loop در پروتکل های Link State ایجاد شود. اما از طرفی دیگر الگوریتم های مورد استفاده در پروتکل های Link State به قدرت پردازشی CPU و حافظه RAM به نسبت پروتکل های Distance Vector نیاز دارند. پروتکل های Link State از یک ساختار سلسله مراتبی و موروثی استفاده می کنند که این ساختار باعث کاهش فاصله ها و نیاز کمتر به انتقال LSA ها می شود.

پروتکل های Link State ازمکانیزم Multicast برای اشتراک گذاری اطلاعات مسیریابی استفاده می کنند.

فقط روترهایی که از پروتکل های مسیریابی Link State استفاده می کنند این Routing Update ها را پردازش می کنند.

Link State ها فقط زمانی اطلاعات روتر را ارسال می کنند که در شبکه تغییری ایجاد شده باشد و صرفا همان تغییر را برای سایر روترها ارسال می کنند ، پیاده سازی پروتکل های مسیریابی Link-State پیچیده تر و پر هزینه تر از پیاده سازی پروتکل های Distance Vector می باشد و هزینه نگهداری آنها نیز به نسبت بیشتر است.

 

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

منبع: گیک بوی

 

شاید این موارد نیز مورد علاقه شما باشد:

مفهوم Dynamic Routing در روتر سیسکو

پیاده سازی پروتکل مسیریابی RIP

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش مفاهیم مسیریابی

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش تنظیم IP روتر و سوئیچ سیسکو

پیاده سازی Protected Port در سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو

آموزش SNMP در روتر و سوئیچ های سیسکو

آشنایی با پروتکل RIP

پروتکل OSPF

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

فعال سازی روتیگ در سوئیچ لایه سه سیسکو :روتینگ امکان جالب و هیجان انگیزی برای یک سوئیج است به تعبیری روتینگ حدفاصل بین سوئیچ و روتر را کمتر میکند در واقع محصولات جدید سیسکو را نه میتوان روتر نامید نه سوئیچ چون مثلا سری 6500 امکانات لایه یک تا هفت را در حد عالی به شما ارائه میکند که این باعث میشود تصویر ذهنی کاربران نسبت به این محصولات عوض شود.

روتینگ قابلیتی است که ما منحصرا آن را در اختیار روتر های در محصولات سیسکو می دانستیم اما با ارائه سوئیچ کاتالیست سیسکو 3550 و امکانات فوق العاده لایه 3 آن نظر ها عوض شد. در نگاه یک کارشناس شبکه سوئیچ لایه سه سیسکو ابزاری همه فن حریف است که پاسخگوی گستره وسیعی از نیازهای شبکه است محدودیت تعداد پورت روتر را نداشته و همچنین از فناوری ASIC برای پردازش استفاده میکند که این باعث load کمتر و سرعت بیشتر است البته نباید این نکته را فراموش کرد که سوئیچ ها اساسا سوئیچ هستند.

برای این کار بهینه سازی شده اند برای مثال RAM سوئیچ ها قابل ارتقاء نبوده و از ماژول های WIC و NM و همچنین ارتباطات WAN و تکنولوژی های مربوط به آن پشتیبانی نمیکنند در واقع سوئیچ ها با VLAN ها کاردارند و این امکانات روتینگی لایه سه این مزیت را به سوئیچ های سیسکو میبخشد که بتوانند ترافیک این VLAN ها را هم Route کنند.

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

روتینگ قابلیت بسیار مهمی بود که سیسکو از سری 3550 به سوئیچ های میان رده خود اضافه نمود که پس از آن 3560 با بهبود های فراوان و سپس سوئیچ سیسکو 3750 پادشاه سوئیچ های سیسکو با قابلیت های فراوان و قدرت بالا حلال مشکلات شبکه ها و مطلوب متخصصان شبکه گردید بدین ترتیب که در اکثر پیاده سازی ها حضور سوئیچ سیسکو 3750 به عنوان جزئی بی بدیل از شبکه مشاهده میشود.

البته محدودیت های و تفاوت های زیادی بین یک روتر و یک سوئیچ لایه سه وجود دارد که نمی توان از آن چشم پوشی کرد و همیشه نیاز به یک روتر صرف در شبکه های حتی کوچک هم حس میشود برای مثال امکانات NAT کردن در سوئیچ های لایه سه وجود ندارد ولی با تمام این احوال امکانات dynamic routing و پشتیبانی از پروتکل های روتینگی مهمی مثل EIGRP – OSPF – BGP و همچنین استاتیک روتینگ Policy Based Routing امکانات ACL حرفه ای و QOS و خیل کثیری از امکانات روتر ها در سوئیچ های لایه 3 وجود داشته که با توجه به تعدد پورت ها استفاده از آنها در بسیاری از ماموریت ها راه گشا خواهد بود.

فعال کردن روتینگ در سوئیچ لایه سه:

برای فعال کردن امکانات روتینگ در سوئیچ لایه سه مثل سوئیچ سیسکو 3750 و تبدیل آن به یک روتر کار چندانی لازم نیست که انجام دهید کافیست ابتدا با دستور IP Routing امکانات روتینگ را فعال کرده و پس از آن میتوانید به هر پورت IP اختصاص دهید و یا پورت ها را در لایه 2 قرار داده و به vlan ها IP دهید از دیگر قابلیت ها امکان فعال سازی DHCP برای اختصاص IP به کلاینت ها و همچنین فعال سازی dynamic routing protocol است.

نکته جالب اینکه پس از فعال کردن امکانات روتینگ سوئیچ لایه سه سیسکو خللی در کارکرد لایه دو آن ایجاد نمیشود بلکه میتوانید تنظیمات لایه دو خود را نظیر vlan ها و پورت های trunk و همچنین stp – vtp – etherchannel را نیز داشته باشید.

فعال کردن امکانات روتینگ:

R1(config)#ip routing

اختصاص IP به یک پورت خاص

R1(config)#int gi 1/0/20
R1(config-if)#no switchport
R1(config-if)#ip add 217.218.1.1 255.255.255.0

کانفیگ پورت به صورت لایه 2 و اختصاص IP به vlan مربوطه :

R1(config-if)#switchport
R1(config-if)#switchport mode access
R1(config-if)#sw acce vlan 303

R1(config)#int vlan 303
R1(config-if)#ip add 217.218.1.1 255.255.255.0

فعال کردن eigrp:

R1(config)#router eigrp 1
R1(config-router)#network 217.218.1.0 0.0.0.255
R1(config-router)#redistribute connected
R1(config-router)#no auto-summary

نوشتن یک استاتیک روت:

R1(config)#ip route 8.8.8.8 255.255.255.255 172.16.64.1

نوشتن یک ACL و اختصاص آن:

R1(config)#ip acce e 110
R1(config-ext-nacl)#per ip 217.218.1.0 0.0.0.255 any
R1(config-ext-nacl)#per icmp an any
R1(config-ext-nacl)#per tcp an an eq 80
R1(config-ext-nacl)#deny ip any any

R1(config)#int vlan 301
R1(config-if)#ip access-group 110 in

اینهامثالهایی بودازگوشه ای ازامکانات لایه سه سوئیچ لایه سه سیسکو که بافعال کردن قابلیت روتینگ دری جدیدازامکانات وقابلیتهابه روی شماگشوده خواهدشد.

در کل با تمام کارامدی سوئیچ های لایه سه سیسکو نباید ماموریت ذاتی و اصلی این تجهیزات که همانا سوئیچینگ است را از خاطر برد این سوئیچ ها با بهبود های نرم افزاری صورت گرفته امکانات روتینگ را نیز برای بهبود عملکرد دارا بوده ولی نباید از آنها قابلیت های یک روتر تمام عیار را انتظار داشت همانطور که با اضافه کردن یک ماژول سوئیچ NME-X-23ES-1G به یک روتر ISR نمیتوان قابلیت ها و پرفورمنس کامل یک سوئیچ را از آن انتظار داشت چون یک روتر است !!

ولی درمواردی مثلایکpop siteویادرمقاطعی که نیازبه تعددپورت وهمچنین روتینگ باشدبه جای استفاده ازیک سوئیچ درکنارروتروinter vlan routingمیتوان ازامکانات ویژه یک سوئیچ لایه سه بهره مندگردید.

منبع: گیک بوی

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

شاید این موارد نیز مورد علاقه شما باشد:

آموزش روتینگ سوئیچ لایه سه سیسکو

لایه بندی شبکه فصل اول

لایه بندی شبکه فصل دوم

آموزش سیسکو استفاده از علامت سوال در CLI

آشنایی با پروتکل RIP

تکنولوژی Cisco StackWise چیست

آموزش دستورات Show در روترهای سیسکو

لایه بندی شبکه فصل دوم

مدل های مختلف سیستم عامل سیسکو

مدل های مختلف IOS های سوئیچ های سیسکو

مدل سه لایه ای سیسکو برای طراحی شبکه

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP :پروتکل Rip از نوع Distance Vector می باشد و به طور کلی از الگوریتم مسیر یابی Bellmanford استفاده می کند. این الگوریتم بسیار سبک است و به همین دلیل Load بسیار کمی روی CPU و RAM روتر می اندازد.

مشخصات پروتکل مسیریابی RIP

Administrative Distance (AD) = 120
Metric = Hop Count
در Routing Table با حرف R نشان داده می شود.
Infinite Metric = 16

دو Version نیز دارد که به RIP V1 و RIPv2 معروف است.

در Routing protocol بین روتر ها بسته های update ارسال می شود که شامل اطلاعات مربوط به شبکه هایی است که آن روتر در اختیار دارد.

در RIP V1 بسته های update با خود Subnet mask حمل نمی کنند در نتیجه نسخه اول RIP از subnetting ، supernetting و VLSM پشتیبانی نمی کند و بسته های update به آدرس ۲۵۵.۲۵۵.۲۵۵.۲۵۵ ارسال می شود.

پیاده سازی پروتکل مسیریابی RIP

در RIPv2 بسته های update با خود Subnet mask حمل می کنند پس بر خلاف نسخه اول ، این نسخه از subnetting ، supernetting و VLSM پشتیبانی می کند و بسته های update به آدرس ۲۲۴.۰.۰.۹ که یک آدرس از نوع multicast است ، ارسال می شود.

Update های RIP هر ۳۰ ثانیه یک باربه صورت Full ارسال می شود.

RIP V1 اهراز هویت (Authentication) ندارد.
RIPv2 اهراز هویت ( Authentication ) دارد.
به طور کلی RIP ، Convergence Time بالایی دارد و دید به Topology Table شبکه ندارند در نتیجه مستعد Loop است به همین دلیل این Routing protocol روش هایی برای جلوگیری از Loop در اختیار دارد.

روش های جلوگیری از Loop

Split Horizon بدین معنااست که روتر حق نداردمسیری راکه ازیک روتر دیگرگرفته است دوباره به آن روتر اعلام کند.
Route Poisoning بدین معنا ست که اگر مسیری قطع شده آن مسیر با Infinite Metric=16 نشان داده شود .
Triggered Update بدین معنا است که روتر نباید صبر کند تا زمان Full update ( که هر ۳۰ ثانیه یک بار است) برسد.بلکه هر موقع نیاز به Route Poisoning شد بسته update را در همان لحظه ارسال کند .

Hold down Timer بدین معنا است که هر زمان بسته Update به روتری رسید ۱۸۰ ثانیه صبر کند و سپس تغییرات را در Routing Table خود اعمال کند.
Split Horizon With Poison Reverse بدین معنا است که روتر حق ندارد مسیری را که از یک روتر دیگر گرفته است دوباره به آن روتر اعلام کند مگر اینکه آن مسیر Route Poison شده باشد.
و بدین صورت و بااستفاده ازاین پنج روش RIP قادراست درصورت به وجودآمدن Loopتا حدی ازبروزفاجعه جلوگیری کند.

برای یادگیری دستورات RIP به بررسی یک سناریو می پردازیم.

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

ما می خواهیم با استفاده از روش RIP ارتباط تمامی روتر ها و سوئیچ ها را با یکدیگر برقرار کنیم.در ابتدا باید وارد هر یک از روتر ها شده و اینترفیس های مربوطه را روشن کرده سپس به آن ها IP های مورد نظر را بدهیم و بعد از این config کردن RIP را آغاز می کنیم.

اختصاص IP Address برای اینترفیس های Fast Ethernet و Serial روتر

با استفاده ازدستورات زیردرقسمت CLI روترها بر اساس سناریو آموزش IP های اینترفیس های روتر رواختصاص میدیم:

Router-1:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-2:
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/1
Router(config-if)#ip address 11.11.11.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-3:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 11.11.11.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit

بعد از اختصاص IP ها بر روی اینترفیس روترها حال نوبت به کانفیگ ارتباط این ۲ شبکه و روترها باهم با استفاده از پروتکل RIP هست که برای انجام این کار نیز دستورات زیر را بر روی روترها انجام میدیم:

Router-1
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 172.16.88.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-2
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 11.11.11.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-3
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 192.168.1.0
Router(config-router)#network 11.11.11.0
Router(config-router)#exit

 

پیاده سازی پروتکل مسیریابی RIP

سایر مطالب مرتبط با یان مقاله:

آشنایی با پروتکل RIP

پروتکل OSPF

آموزش مفاهیم مسیریابی

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش پیکربندی پروتکلهای بردار فاصله

آشنایی با پروتکل RIP

آشنایی با پروتکل RIP

آشنایی با پروتکل RIP

آشنایی با پروتکل RIP :پروتکل Routing Information Protocol یا RIP یکی از قدیمی ترین پروتکل های مسیریابی Distance Vector است که از پارامتر Hop Count به عنوان Metric استفاده می کند.

RIP برای اینکه بتواندازبه وجود آمدن Loopدرفرآیندروتینگ جلوگیری کندمحدودیت تعدادHopهای مجازازمبدابه مقصدرابه عنوان مکانیزم جلوگیری ازLoop قرارداده است.

حداکثرتعدادHopهای مجازدرRIPعدد۱۵است.این محدودیت تعدادHopباعث محدودشدن اندازه شبکه هایی میشودکهRIPازآنها پشتیبانی میکند.

یعنی RIP را نمی توان در شبکه هایی که بیش از ۱۵ عدد Hop یا روتر دارند استفاده کرد.

Hop Count مقدار۱۶به معنی فاصله بینهایت برایRIPدرنظرگرفته میشودبه زبانی دیگریعنیRouteموردنظرازنظرRIPغیرقابل دسترسی درنظرگرفته میشود.

RIP با استفاده ازمکانیزمهای Split Horizon،Route Poisoning و HoldDown ازانتشاراطلاعات Routingاشتباه وپخش شدن چنین اطلاعاتی جلوگیری میکند.

در اصل روترهای RIP درهر۳۰ثانیه یکباراطلاعات خودرابروزرسانی میکنندو Routing Table رادرشبکه منتقل میکنند.

پروتکل RIP

در پیاده سازی های اولیه حجم Routing Table ها اینقدر کم بود که ترافیکی که ناشی از انتقال آن در شبکه به وجود می آمد بسیار ناچیز و کم بود اما با گسترش روز به روز شبکه ها از نظر اندازه و ترافیک کم کم ترافیک مربوط به همین انتقال در هر ۳۰ ثانیه به حجم قابل توجهی می رسید مخصوصا اینکه ترافیک بصورت تصادفی و در وهله های زمانی متفاوت انجام می شد.

شاید به نظر برسد که اگر Routing Table ها در وحله های زمانی مختلف در شبکه منتقل شوند از نظر ترافیکی کارایی بهتری ایجاد می شود اما در عمل اینکار واقعا امکانپذیر نبود.

Sally Floyd و Van Jacobson در سال ۱۹۹۴ اثبات کردند که تصادفی سازی انتقاد اطلاعات با استفاده از مکانیزم Timer در طول زمان باعث یکسان شدن زمان ها یا Synchronize شدن زمان ها می شود.

در بیشتر شبکه های امروزی از RIP به دلیل داشتن Convergence Time بالا در مقایسه با پروتکلهای EIGRP ، OSPF و IS-IS استفاده نمی شود ، در ضمن محدودیت تعداد Hop های قابل استفاده باعث کاهش اندازه شبکه هایی شد که در آن قابل استفاده است.

اما به هر حال پیاده سازی RIP در میان سایر پروتکل های مسیریابی به نسبت بسیار ساده تر است ، RIP بر خلاف سایر پروتکل های مسیریابی دیگر نیازی به هیچ پارامتر خاصی بر روی روتر ندارد.

پروتکل RIP

RIP از User Datagram Protocol یا UDP به عنوان پروتکل انتقال استفاده می کند و یک شماره پورت شناخته شده ( Well Known Port ) به شماره ۵۲۰ را به خود اختصاص داده است.

RIP معمولادرشبکه های کوچک ازقبیل LANیامجموعه ای ازLANهای کوچک که تشکیل یکCampus Area Networkراداده انداستفاده میشود.

برای مثال اگر ازشرکت سیستم افزار خاورمیانه یک مجموعه ستادی در استان تهران داشته باشد که چندین ساختمان در سطح شهر تهران داشته باشد می تواند از RIP برای این شبکه استفاده کند.

از RIP به عنوان یک پروتکل Interior Routing یا مسیریابی داخلی یاد می شود.

RIP توانایی تشخیص تغییرات را برای ارسال در هر بار انتقال routing Table ندارد و به همین دلیل در هر بار اشتراک گذاری Routing Table همه اطلاعات به یکباره منتقل می شود و قابلیت Incremental Update برای اینکار وجود ندارد.

هر روتر همسایه اطلاعات را برای روتر همسایه دیگر ارسال می کند و به همین ترتیب اطلاعات در همه شبکه و روترها پخش می شود تا همه روترهای مجموعه Network Convergence را تشکیل دهد.

انواع نسخه های RIP :

Version 1 :
Version 2
RIPng (RIP next generation) :

ویژگی های RIP version 1 :

یک پروتکل Classful است و از VLSM پشتیبانی نمی کند.
دارای امکان Authentication ( احراز هویت) نیست.
Advertisement ها را به صورت Broadcast ارسال می کند.

ویژگی های RIP version 2 :

در سال ۱۹۹۳ ارائه شد.
یک پروتکل Classless است و از VLSM پشتیبانی می کند.
امکان Authentication ( احراز هویت) را دارد
Advertisement ها را به جای Broadcast به صورت multicast به آدرس ۲۲۴.۰.۰.۹ ارسال می کند.

ویژگی های RIPng :

پشتیبانی از IPv6
از پروتکل UDP با شماره پورت ۵۲۱ استفاده می کند.

.

 

آشنایی با پروتکل RIP

منبع :جعفر قنبری شوهانی

 

سایر مطالب مرتبط با یان مقاله:

پروتکل OSPF

آموزش مفاهیم مسیریابی

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش پیکربندی پروتکلهای بردار فاصله