نوشته‌ها

آموزش ساختن Sub Interface در روتر سیسکو

آموزش ساختن Sub Interface در روتر سیسکو

آموزش ساختن Sub Interface در روتر سیسکو :sub interface در واقع همان vlan هائیست که ما بر روی یک پورت روتر سیسکو متصل به ترانک تعریف میکنیم. به بیان دیگر برای دسترسی به vlan های تعریف شده روی یک سوئیچ سیسکو و استفاده از inter vlan Routing توسط روتر میبایست یک اینترفیس روتر به یک پورت ترانک trunk از سوئیچ متصل شده و ساب اینترفیس ها با شماره متناظر vlan ها روی آن تعریف شود.

روتر های سیسکو

روتر های سیسکو برای ارتباطات trunk از 2 پروتکل که یکی مختص تجهیزات سیسکو و دیگری استاندارد جهانی است پشنیبانی میکنند.

اولی ISL یا همان Cisco Inter-Switch Link است که پروپایوتری سیسکو است در واقع پروتکل ‌vlan Encapsulation مختص سیسکو است که فقط توسط دستگاه های خود سیسکو و شاید بعضی دیوایس های دیگر پشتیبانی شود.

البته ISL با اقبال عمومی روبرو نشد و در حال حاضر اکثرا از پروتکل دوم به نام 802.1Q که استاندارد جهانی است استفاده میکنند. اصولا در صنعت کامپیوتر معدود استاندارهای proprietary شرکت های خاص به موفقیت نایل شد از جمله شرکت apple که سرسختانه بر سر مواضع خود ایستاد و توانست یک استاندارد اختصاصی برای خود داشته باشد و هیچ الزامی با سازگاری با دیگر تولید کنندگان نرم افزار و سخت افزار ندارد! و این خود سیاستی است بس خطر ناک برای وابسته کردن مشتری!

برای مثال پروتکل EIGRP – IGRP سیسکو که بسیار قوی تر از OSPF است باز هم به دلیل اینکه فقط توسط خود روتر های و سوئیچ های سیسکو پشتیبانی میشود در اسکیل های بزرگ استفاده نمیشود برای مثال روتینگ داخلی شبکه ایران به دلیل استفاده از دیوایس های مختلف مثلا سیسکو، هواوی، جونیپر و … و یک دست نبودن در حال حاضر بر روی OSPF قرار دارد که به نظر من از EIGRP ضعیف تر عمل میکند! که البته این خود باعث عدم وابستگی به یک سکوی خاص و برند خاص میشود.

آموزش ساختن Sub Interface در روتر سیسکو

خب با توجه به مطالب بالا dot1Q یا همان 802.1q پروتکل رایج برای vlan encapsulation است. برای کانفیگ vlan ها بر روی روتر سیسکو ابتدا یک اینترفیس را به یک پورت ترانک از سوئیچی که میخواهیم از vlan های تعریف شده روی آن استفاده کنیم متصل کرده و بدین ترتیب عمل میکنیم:

router(config)#int gig 0/0
router(config-if)#description Trunk interface
router(config-if)#exit
router(config)#int gig 0/0.10 # 10 is vlan number that determine in switch
router(config-if)#encapsulation dot1Q 10
router(config-if)#ip add 192.168.1.1 255.255.255.0
router(config-if)#exit
router(config)#int gig 0/0.20
router(config-if)#encapsulation dot1Q 20
router(config-if)#ip add 192.168.2.0 255.255.255.0
router-sub-interface
router sub interface

کافیست پورت gig 0/0 روتر به یک پورت ترانک از سوئیچ مربوطه متصل و vlan های 10-20 و .. روی آن تعریف شده باشد، هر کلاینت میباید gateway خود را IP روی اینترفیس روتر ست کند که ترافیک خارج از subnet برای route شدن به سمت روتر ارسال شود.

آموزش ساختن Sub Interface در روتر سیسکو

 

منبع : گیک بوی

 

شاید این موارد نیز مورد علاقه شما باشد:

تعویض پورت پیش فرض تلنت در روتر سیسکو

دسترسی Telnet به روتر سیسکو

مدیریت سوئیچ روتر سیسکو

مراحل بوت شدن روتر سیسکو

آموزش تنظیم IP روتر و سوئیچ سیسکو

آموزش SNMP در روتر و سوئیچ های سیسکو

مراحل Boot کردن روتر های سیسکو

برگرداندن روتر یا سوئیچ سیسکو به تنظیمات کارخانه

اینترفیس های روتر و سوئیچ سیسکو

آموزش دستورات Show در روترهای سیسکو

راه اندازی SSH در سوئیچ ها و روتر های سیسکو

دستورات تنظیمات روتر و سوئیچ سیسکو

آموزش ساختن Sub Interface در روتر سیسکو

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

فعال سازی روتیگ در سوئیچ لایه سه سیسکو :روتینگ امکان جالب و هیجان انگیزی برای یک سوئیج است به تعبیری روتینگ حدفاصل بین سوئیچ و روتر را کمتر میکند در واقع محصولات جدید سیسکو را نه میتوان روتر نامید نه سوئیچ چون مثلا سری 6500 امکانات لایه یک تا هفت را در حد عالی به شما ارائه میکند که این باعث میشود تصویر ذهنی کاربران نسبت به این محصولات عوض شود.

روتینگ قابلیتی است که ما منحصرا آن را در اختیار روتر های در محصولات سیسکو می دانستیم اما با ارائه سوئیچ کاتالیست سیسکو 3550 و امکانات فوق العاده لایه 3 آن نظر ها عوض شد. در نگاه یک کارشناس شبکه سوئیچ لایه سه سیسکو ابزاری همه فن حریف است که پاسخگوی گستره وسیعی از نیازهای شبکه است محدودیت تعداد پورت روتر را نداشته و همچنین از فناوری ASIC برای پردازش استفاده میکند که این باعث load کمتر و سرعت بیشتر است البته نباید این نکته را فراموش کرد که سوئیچ ها اساسا سوئیچ هستند.

برای این کار بهینه سازی شده اند برای مثال RAM سوئیچ ها قابل ارتقاء نبوده و از ماژول های WIC و NM و همچنین ارتباطات WAN و تکنولوژی های مربوط به آن پشتیبانی نمیکنند در واقع سوئیچ ها با VLAN ها کاردارند و این امکانات روتینگی لایه سه این مزیت را به سوئیچ های سیسکو میبخشد که بتوانند ترافیک این VLAN ها را هم Route کنند.

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

روتینگ قابلیت بسیار مهمی بود که سیسکو از سری 3550 به سوئیچ های میان رده خود اضافه نمود که پس از آن 3560 با بهبود های فراوان و سپس سوئیچ سیسکو 3750 پادشاه سوئیچ های سیسکو با قابلیت های فراوان و قدرت بالا حلال مشکلات شبکه ها و مطلوب متخصصان شبکه گردید بدین ترتیب که در اکثر پیاده سازی ها حضور سوئیچ سیسکو 3750 به عنوان جزئی بی بدیل از شبکه مشاهده میشود.

البته محدودیت های و تفاوت های زیادی بین یک روتر و یک سوئیچ لایه سه وجود دارد که نمی توان از آن چشم پوشی کرد و همیشه نیاز به یک روتر صرف در شبکه های حتی کوچک هم حس میشود برای مثال امکانات NAT کردن در سوئیچ های لایه سه وجود ندارد ولی با تمام این احوال امکانات dynamic routing و پشتیبانی از پروتکل های روتینگی مهمی مثل EIGRP – OSPF – BGP و همچنین استاتیک روتینگ Policy Based Routing امکانات ACL حرفه ای و QOS و خیل کثیری از امکانات روتر ها در سوئیچ های لایه 3 وجود داشته که با توجه به تعدد پورت ها استفاده از آنها در بسیاری از ماموریت ها راه گشا خواهد بود.

فعال کردن روتینگ در سوئیچ لایه سه:

برای فعال کردن امکانات روتینگ در سوئیچ لایه سه مثل سوئیچ سیسکو 3750 و تبدیل آن به یک روتر کار چندانی لازم نیست که انجام دهید کافیست ابتدا با دستور IP Routing امکانات روتینگ را فعال کرده و پس از آن میتوانید به هر پورت IP اختصاص دهید و یا پورت ها را در لایه 2 قرار داده و به vlan ها IP دهید از دیگر قابلیت ها امکان فعال سازی DHCP برای اختصاص IP به کلاینت ها و همچنین فعال سازی dynamic routing protocol است.

نکته جالب اینکه پس از فعال کردن امکانات روتینگ سوئیچ لایه سه سیسکو خللی در کارکرد لایه دو آن ایجاد نمیشود بلکه میتوانید تنظیمات لایه دو خود را نظیر vlan ها و پورت های trunk و همچنین stp – vtp – etherchannel را نیز داشته باشید.

فعال کردن امکانات روتینگ:

R1(config)#ip routing

اختصاص IP به یک پورت خاص

R1(config)#int gi 1/0/20
R1(config-if)#no switchport
R1(config-if)#ip add 217.218.1.1 255.255.255.0

کانفیگ پورت به صورت لایه 2 و اختصاص IP به vlan مربوطه :

R1(config-if)#switchport
R1(config-if)#switchport mode access
R1(config-if)#sw acce vlan 303

R1(config)#int vlan 303
R1(config-if)#ip add 217.218.1.1 255.255.255.0

فعال کردن eigrp:

R1(config)#router eigrp 1
R1(config-router)#network 217.218.1.0 0.0.0.255
R1(config-router)#redistribute connected
R1(config-router)#no auto-summary

نوشتن یک استاتیک روت:

R1(config)#ip route 8.8.8.8 255.255.255.255 172.16.64.1

نوشتن یک ACL و اختصاص آن:

R1(config)#ip acce e 110
R1(config-ext-nacl)#per ip 217.218.1.0 0.0.0.255 any
R1(config-ext-nacl)#per icmp an any
R1(config-ext-nacl)#per tcp an an eq 80
R1(config-ext-nacl)#deny ip any any

R1(config)#int vlan 301
R1(config-if)#ip access-group 110 in

اینهامثالهایی بودازگوشه ای ازامکانات لایه سه سوئیچ لایه سه سیسکو که بافعال کردن قابلیت روتینگ دری جدیدازامکانات وقابلیتهابه روی شماگشوده خواهدشد.

در کل با تمام کارامدی سوئیچ های لایه سه سیسکو نباید ماموریت ذاتی و اصلی این تجهیزات که همانا سوئیچینگ است را از خاطر برد این سوئیچ ها با بهبود های نرم افزاری صورت گرفته امکانات روتینگ را نیز برای بهبود عملکرد دارا بوده ولی نباید از آنها قابلیت های یک روتر تمام عیار را انتظار داشت همانطور که با اضافه کردن یک ماژول سوئیچ NME-X-23ES-1G به یک روتر ISR نمیتوان قابلیت ها و پرفورمنس کامل یک سوئیچ را از آن انتظار داشت چون یک روتر است !!

ولی درمواردی مثلایکpop siteویادرمقاطعی که نیازبه تعددپورت وهمچنین روتینگ باشدبه جای استفاده ازیک سوئیچ درکنارروتروinter vlan routingمیتوان ازامکانات ویژه یک سوئیچ لایه سه بهره مندگردید.

منبع: گیک بوی

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

شاید این موارد نیز مورد علاقه شما باشد:

آموزش روتینگ سوئیچ لایه سه سیسکو

لایه بندی شبکه فصل اول

لایه بندی شبکه فصل دوم

آموزش سیسکو استفاده از علامت سوال در CLI

آشنایی با پروتکل RIP

تکنولوژی Cisco StackWise چیست

آموزش دستورات Show در روترهای سیسکو

لایه بندی شبکه فصل دوم

مدل های مختلف سیستم عامل سیسکو

مدل های مختلف IOS های سوئیچ های سیسکو

مدل سه لایه ای سیسکو برای طراحی شبکه

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

آموزش دستورات Show در روترهای سیسکو

آموزش دستورات Show در روترهای سیسکو

آموزش دستورات Show در روترهای سیسکو:

 در این مقاله با اجرای دستور زیر جدول روتینگ را بررسی می‌کنیم.

دستور Show IP Route:

Router#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

* – candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

D 192.168.1.0/24 [90/30720] via 192.168.2.1, 00:04:48, FastEthernet0/0

C 192.168.2.0/24 is directly connected, FastEthernet0/0

D 192.168.3.0/24 [90/30720] via 192.168.2.2, 00:04:47, FastEthernet0/0

C 192.168.4.0/24 is directly connected, FastEthernet0/1

با دستور Show IP Route، جدول روتینگ نمایش داده شده است که اگر به جدول توجه کنید، دو شبکه را دریافت کرده که با حرف D شروع می‌ شوند. حرف D به معنای Eigrp است و نشان‌ دهنده‌ ی این است که از روترهای دیگر این شبکه ها را یاد گرفته، شبکه‌ های پشت روترهای R2 و R3 را یاد گرفته است. در روترهای دیگر هم به همین صورت است.

 

دستور show ip eigrp neighbors:

برای نمایش همسایگی (Neighbors)، باید از دستور زیر در مد Privileged استفاده کنید:

 

Router#show ip eigrp neighbors

IP-EIGRP neighbors for process 200

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

۰ ۱۹۲.۱۶۸.۲.۱ Fa0/0 13 00:44:14 40 1000 0 6

۱ ۱۹۲.۱۶۸.۲.۳ Fa0/0 11 00:39:02 40 1000 0 7

این دستور در روتر R2 وارد شده است و نتیجه ی آن را مشاهده می‌ کنید؛ لیست Ip هایی که با آن‌ ها ارتباط همسایگی دارد را نمایش داده است.

 

دستور Show Ip Eigrp Interface:

این دستور برای نمایش اطلاعات interface هایی است که پروتکل EIGRP روی آن فعال‌ شده است. این دستور را در R2 وارد می‌ کنیم:

 

Router#show ip eigrp interface
IP-EIGRP interfaces for process 200
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0 2 0/0 1236 0/10 0 0
Fa0/1 0 0/0 1236 0/10 0 0

 

به نتیجه ی کار دقت کنید، اگر به Fa0/0 دقت کنید، نوشته است، PEER 2، یعنی اینکه از طریق اینترفیس Fa0/0 توانسته دو تا Neghibors را یاد بگیرد، Neighbors همان اینتر فیس های روترهای همسایه هستند که روی آن‌ ها Eigrp راه‌ اندازی شده است.

 

دستور Show IP eigrp Topology:

این دستور کل اطلاعات جدول توپولوژی را به شما نمایش می‌ دهد و می‌ گوید که شبکه را از کدام مسیر دریافت کرده و …

 

Router#show ip eigrp topology
IP-EIGRP Topology Table for AS 200
Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,r – Reply status
P 192.168.2.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 192.168.3.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/1
P 192.168.4.0/24, 1 successors, FD is 30720
via 192.168.2.3 (30720/28160), FastEthernet0/0
P 192.168.1.0/24, 1 successors, FD is 30720
via 192.168.2.1 (30720/28160), FastEthernet0/0

اگر به گزینه ی اول نگاه کنید، می‌ گوید شبکه ی ۱۹۲.۱۶۸.۲.۰ یک مسیر successor است، یعنی یک مسیر اصلی است و از طریق اینتر فیس FastEthernet 0/0 وارد همین روتر که داخل آن هستیم، شده است. بقیه هم به همین صورت است، پس نتیجه می گیریم که این جدول، کل اینترفیس هایی را به ما نشان می‌ دهد که Eigrp روی آن‌ ها Run شده است.

دستور Show IP eigrp Traffic:

این دستور نشان‌ دهنده ی پکت های دریافتی و ارسالی است، مانند زیر:

 

Router#show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 100
Hellos sent/received: 0/0
Updates sent/received: 0/0
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 0/0
Input queue high water mark 1, 0 drops
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0

مطالب مرتبط 

 

دستورات تنظیمات روتر و سوئیچ سیسکو

دستورات پیکربندی سوئیچ سیسکو

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت سوم

آموزش سیسکو Cisco قسمت چهارم

آموزش سیسکو Cisco قسمت پنجم