نوشته‌ها

رفع آسیب پذیری های جدید سیسکو

رفع آسیب پذیری های جدید سیسکو

رفع آسیب پذیری های جدید سیسکو : سیسکو برای ۱۷ آسیب‌ پذیری جدید در محصولاتش وصله عرضه کرد.

سیسکو اواسط ماه اکتبر ۱۷ آسیب‌ پذیری را اصلاح کرده‌است که یک مورد از این آسیب‌ پذیری‌ها بحرانی و ۸ مورد آن دارای درجه حساسیت بالا است.

سایر آسیب‌ پذیری‌ها دارای درجه حساسیت متوسط هستند.

جزئیات این آسیب‌ پذیری‌ها در جدول زیر ارائه شده‌است:

 

cisco1

cisco1

cisco2

cisco2

cisco3

cisco3

رفع آسیب پذیری های جدید سیسکو

منبع خبر : پایگاه خبری امنیت فناوری اطلاعات

فروشگاه سوئیچ سیسکو

سیسکو درباره آسیب‌پذیری بحرانی در سیستم ها هشدار داد

امنیت VLAN و Trunk در سوئیچ های سیسکو

آموزش روش های ایمن سازی تجهیزات سیسکو

تعویض پورت پیش فرض تلنت در روتر سیسکو

پیشگیری از حملات IKE CRYPTO در سیستم عامل سیسکو

کانفیگ Port Security سوئیچ سیسکو

 

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

فعال سازی روتیگ در سوئیچ لایه سه سیسکو :روتینگ امکان جالب و هیجان انگیزی برای یک سوئیج است به تعبیری روتینگ حدفاصل بین سوئیچ و روتر را کمتر میکند در واقع محصولات جدید سیسکو را نه میتوان روتر نامید نه سوئیچ چون مثلا سری 6500 امکانات لایه یک تا هفت را در حد عالی به شما ارائه میکند که این باعث میشود تصویر ذهنی کاربران نسبت به این محصولات عوض شود.

روتینگ قابلیتی است که ما منحصرا آن را در اختیار روتر های در محصولات سیسکو می دانستیم اما با ارائه سوئیچ کاتالیست سیسکو 3550 و امکانات فوق العاده لایه 3 آن نظر ها عوض شد. در نگاه یک کارشناس شبکه سوئیچ لایه سه سیسکو ابزاری همه فن حریف است که پاسخگوی گستره وسیعی از نیازهای شبکه است محدودیت تعداد پورت روتر را نداشته و همچنین از فناوری ASIC برای پردازش استفاده میکند که این باعث load کمتر و سرعت بیشتر است البته نباید این نکته را فراموش کرد که سوئیچ ها اساسا سوئیچ هستند.

برای این کار بهینه سازی شده اند برای مثال RAM سوئیچ ها قابل ارتقاء نبوده و از ماژول های WIC و NM و همچنین ارتباطات WAN و تکنولوژی های مربوط به آن پشتیبانی نمیکنند در واقع سوئیچ ها با VLAN ها کاردارند و این امکانات روتینگی لایه سه این مزیت را به سوئیچ های سیسکو میبخشد که بتوانند ترافیک این VLAN ها را هم Route کنند.

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

روتینگ قابلیت بسیار مهمی بود که سیسکو از سری 3550 به سوئیچ های میان رده خود اضافه نمود که پس از آن 3560 با بهبود های فراوان و سپس سوئیچ سیسکو 3750 پادشاه سوئیچ های سیسکو با قابلیت های فراوان و قدرت بالا حلال مشکلات شبکه ها و مطلوب متخصصان شبکه گردید بدین ترتیب که در اکثر پیاده سازی ها حضور سوئیچ سیسکو 3750 به عنوان جزئی بی بدیل از شبکه مشاهده میشود.

البته محدودیت های و تفاوت های زیادی بین یک روتر و یک سوئیچ لایه سه وجود دارد که نمی توان از آن چشم پوشی کرد و همیشه نیاز به یک روتر صرف در شبکه های حتی کوچک هم حس میشود برای مثال امکانات NAT کردن در سوئیچ های لایه سه وجود ندارد ولی با تمام این احوال امکانات dynamic routing و پشتیبانی از پروتکل های روتینگی مهمی مثل EIGRP – OSPF – BGP و همچنین استاتیک روتینگ Policy Based Routing امکانات ACL حرفه ای و QOS و خیل کثیری از امکانات روتر ها در سوئیچ های لایه 3 وجود داشته که با توجه به تعدد پورت ها استفاده از آنها در بسیاری از ماموریت ها راه گشا خواهد بود.

فعال کردن روتینگ در سوئیچ لایه سه:

برای فعال کردن امکانات روتینگ در سوئیچ لایه سه مثل سوئیچ سیسکو 3750 و تبدیل آن به یک روتر کار چندانی لازم نیست که انجام دهید کافیست ابتدا با دستور IP Routing امکانات روتینگ را فعال کرده و پس از آن میتوانید به هر پورت IP اختصاص دهید و یا پورت ها را در لایه 2 قرار داده و به vlan ها IP دهید از دیگر قابلیت ها امکان فعال سازی DHCP برای اختصاص IP به کلاینت ها و همچنین فعال سازی dynamic routing protocol است.

نکته جالب اینکه پس از فعال کردن امکانات روتینگ سوئیچ لایه سه سیسکو خللی در کارکرد لایه دو آن ایجاد نمیشود بلکه میتوانید تنظیمات لایه دو خود را نظیر vlan ها و پورت های trunk و همچنین stp – vtp – etherchannel را نیز داشته باشید.

فعال کردن امکانات روتینگ:

R1(config)#ip routing

اختصاص IP به یک پورت خاص

R1(config)#int gi 1/0/20
R1(config-if)#no switchport
R1(config-if)#ip add 217.218.1.1 255.255.255.0

کانفیگ پورت به صورت لایه 2 و اختصاص IP به vlan مربوطه :

R1(config-if)#switchport
R1(config-if)#switchport mode access
R1(config-if)#sw acce vlan 303

R1(config)#int vlan 303
R1(config-if)#ip add 217.218.1.1 255.255.255.0

فعال کردن eigrp:

R1(config)#router eigrp 1
R1(config-router)#network 217.218.1.0 0.0.0.255
R1(config-router)#redistribute connected
R1(config-router)#no auto-summary

نوشتن یک استاتیک روت:

R1(config)#ip route 8.8.8.8 255.255.255.255 172.16.64.1

نوشتن یک ACL و اختصاص آن:

R1(config)#ip acce e 110
R1(config-ext-nacl)#per ip 217.218.1.0 0.0.0.255 any
R1(config-ext-nacl)#per icmp an any
R1(config-ext-nacl)#per tcp an an eq 80
R1(config-ext-nacl)#deny ip any any

R1(config)#int vlan 301
R1(config-if)#ip access-group 110 in

اینهامثالهایی بودازگوشه ای ازامکانات لایه سه سوئیچ لایه سه سیسکو که بافعال کردن قابلیت روتینگ دری جدیدازامکانات وقابلیتهابه روی شماگشوده خواهدشد.

در کل با تمام کارامدی سوئیچ های لایه سه سیسکو نباید ماموریت ذاتی و اصلی این تجهیزات که همانا سوئیچینگ است را از خاطر برد این سوئیچ ها با بهبود های نرم افزاری صورت گرفته امکانات روتینگ را نیز برای بهبود عملکرد دارا بوده ولی نباید از آنها قابلیت های یک روتر تمام عیار را انتظار داشت همانطور که با اضافه کردن یک ماژول سوئیچ NME-X-23ES-1G به یک روتر ISR نمیتوان قابلیت ها و پرفورمنس کامل یک سوئیچ را از آن انتظار داشت چون یک روتر است !!

ولی درمواردی مثلایکpop siteویادرمقاطعی که نیازبه تعددپورت وهمچنین روتینگ باشدبه جای استفاده ازیک سوئیچ درکنارروتروinter vlan routingمیتوان ازامکانات ویژه یک سوئیچ لایه سه بهره مندگردید.

منبع: گیک بوی

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

شاید این موارد نیز مورد علاقه شما باشد:

آموزش روتینگ سوئیچ لایه سه سیسکو

لایه بندی شبکه فصل اول

لایه بندی شبکه فصل دوم

آموزش سیسکو استفاده از علامت سوال در CLI

آشنایی با پروتکل RIP

تکنولوژی Cisco StackWise چیست

آموزش دستورات Show در روترهای سیسکو

لایه بندی شبکه فصل دوم

مدل های مختلف سیستم عامل سیسکو

مدل های مختلف IOS های سوئیچ های سیسکو

مدل سه لایه ای سیسکو برای طراحی شبکه

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو :DHCP یکی از پر کاربرد ترین سرویس های شبکه است که در خفا و پس ضمینه مسئول اختصاص آدرس های IP به کلاینت های شبکه است این سرویس جزء لاینفک شبکه های بزرگ کوچک بوده و از ابتدایی ترین تراکنش های ارتباطی در شبکه های LAN است.

DHCP سرور

DHCP سرور

هنگامی که شما یک کلاینت را به یک شبکه مرتبط میکنید و یا با یک سرور PPP ارتباط برقرار میکنید پس از احراز هویت دریافت آدرس IP از ابتدایی ترین واکنش هاست. استفاده از DHCP علاوه بر افزایش کارایی شبکه به افزایش چشمگیر امنیت در شبکه های مبتنی بر سیسکو می انجامد. بدین ترتیب که به عنوان یک مدیر شبکه امکان مدیریت و رصد مشکلات به سادگی امکان پزیر است و همچنین از مشکلاتی نظیر IP Conflict و دسترسی غیر مجاز به آدرس های IP جلوگیری به عمل می آید. پیاده سازی DHCP بر روی روتر ها و سویئچ های سیسکو به سادگی امکان پذیر بوده و ترافیک و لود چندانی را به دستگاه تحمیل نمینماید.

راه اندازی DHCP بر روی سوئیچ سیسکو

شروع کار:

توصیه میشود ابتدا یک دیتابیس برای نگهداری واگذاری آدرس های IP ایجاد و دسترسی FTP به آن را میسر نمایید:

Router(config)# ip dhcp database ftp://user:password@172.16.1.1/router-dhcp timeout 80

جلوگیری از اعطای آدرس های 100 تا 103:

Router(config)# ip dhcp excluded-address 172.16.1.100 172.16.1.103
Router(config)# ip dhcp pool 1
Router(dhcp-config)# utilization mark high 80 log
Router(dhcp-config)# network 172.16.0.0 /16
Router(dhcp-config)# domain-name rootlan #domain name
Router(dhcp-config)# dns server 217.218.127.127 217.218.155.155 #dci dns servers
Router(dhcp-config)# default-router 172.16.1.100 172.16.1.101 #this is the Gateway address
Router(dhcp-config)# option 19 hex 01 #additional dhcp option code for example tftp address
Router(dhcp-config)# lease 30 # the lease amount

بدین ترتیب امکان استفاده از امکانات DHCP بر روی روتر و سوئیچ های سیسکو میسر میگردد البته امکانات پیشرفته تری نیز وجود داره که در صورت نیاز میتوانید از آنها استفاده کنید لازم به توضیح است استفاده از سرویس DHCP بر روی شبکه های VLAN که دارای Access Switch و Core Switch هستند بر روی سوئیچ های لایه دسترسی توصیه میشود.

اگر به هر دلیلی مایل به استفاده از دیتابیس جهت ثبت واگذاری IP نبودید میتوانید از این کامند استفاده نمایید:

Router(config)# no ip dhcp conflict logging

توسط این دستور میتوانید میزان استفاده از منابع IP را مشاهده کنید:

Router(config)# ip dhcp use class

راه اندازی DHCP بر روی سوئیچ سیسکو

شاید این موارد نیز مورد علاقه شما باشد:

پیاده سازی پروتکل مسیریابی RIP

آسیب‌پذیری پروتکل UPnP در برابر حملات DDOS

پروتکل OSPF

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش پیکربندی پروتکلهای بردار فاصله

پروتکل های مسیریابی Classful vs Classless

پروتکل ISL انحصاری شرکت سیسکو

تغییر firmware تلفن های سیسکو

مفهوم SDN

راه اندازی DHCP بر روی سوئیچ سیسکو

آموزش سیسکو استفاده از علامت سوال در CLI

آموزش سیسکو استفاده از علامت سوال در CLI

آموزش سیسکو استفاده از علامت سوال در CLI

آموزش سیسکو استفاده از علامت سوال در CLI : در IOS دستگاه های سوئیچ و روتر، دستورات و پارامتر های زیادی برای تنظیم وجود دارد. بنابراین حفظ و بخاطر سپردنشان دشواراست. استفاده از قابلیت علامت سوال (?) باعث افزایش جذابیت استفاده از cli و همچنین کمک در هنگام فراموشی دستورات می شود.

لیست همه command هایی که می توان در این مد استفاده کرد را نشان می دهد :

?#Router

لیست همه command هایی که حرف اولشان c است را نشان میدهد :

clear , clock , configure , connect , copy

اگر علامت سوال را با فاصله  از command استفاده کنید لیست subcommand های بعدی که می توانید استفاده کنید را نشان می دهد :

? Router#clock

خروجی : set Set the time and date

وقتی command یا دستور کامل شده است و subcommand دیگری برای تنظیم ندارد :

? Router#clock set 10:30:30 december 18 2017

<cr> : خروجی

کوتاه کردن دستورات و استفاده از کلیدTab :

Router>enable یا Router>en یا Router>enab

Router#configure terminal یا Router#conf t

نوشتن بخشی از command و استفاده از کلید Tab باعث کامل شدن command میشود:

Router>en (Tab کلید)
خروجی : Router>enable

Router#conf t (Tab کلید)
خروجی : Router#conf terminal

آشنایی با چند دستور ساده در Router

تغییر نام Router با دستور ، (hostname) :

Router>enable
Router#conf t
Router(config)# hostname R1
R1(config)#

فعال کردن درخواست رمزعبور هنگام ورود به Privileged Mode :

R1>enable
R1#conf terminal
R1(config)# enable password 123456

بهتراست که از enable secret ) command ) ، بجای (enable password) استفاده کرد. بدلیل اینکه (enable secret) با الگوریتم md5 رمزنگاری (hash) شده است .
البته اگر برای هردو enable secret و enable password پسورد تعیین کرده باشید، اولویت با enable secret است و در هنگام درخواست پسورد ، شما باید پسورد enable secret را وارد کنید.

R1(config)# enable secret 123456

البته با دستور service password-encryption هم میتوان همه پسورد های مورد استفاده در ios را بصورت رمزنگاری درآورد. گرچه این روش رمزنگاری، رمزگشایی شده است ولی بهتر از پسورد قابل شنود (sniff) یا واضح (Clear Text) است.

R1(config)# service password-encryption

بدلیل ارتباط مستقیم console به دستگاه، برای برقراری امنیت دسترسی کابر در هنگام ورود از طریق console به cli بهتر است پسورد گذاشته شود. با دستور line console 0 وارد مد config-line می شویم و با دستور password، پسورد دلخواهی می گذارید و حتما بعد از وارد شدن و تعیین پسورد در console line باید با دستور login تنظیمات مربوط را فعال کنید.

Router(config)# line console 0 [عدد صفر شماره پورت کنسول روی دستگاه ]
Router(config-line)# password 123456
Router(config-line)# login

نحوه ذخیره تنظیمات در حافظ NVRAM :

هنگامی که در حال تنظیم در ios و مشغول command نویسی هستیم، در واقع در محیط running-config یا حافظ RAM که در حال پردازش است، هستیم و با ریست شدن دستگاه، تنظیمات پاک می شود. بنابراین برای ریست نشدن تنظیمات، نیاز به حافظه ای برای ذخیره سازی است.

startup-config :

محل ذخیره دائمی تنظیمات یا همان حافظ NVRAM است.
با دستور زیر، تنظیمات به ترتیب نوشتن از running-config حافظه RAM به startup-config حافظه NVRAM منتقل و ذخیره می شوند.

R1#copy running-config startup-config

و البته میتوان از دستور write که معادل دستور ” copy running-config startup-config” است، هم استفاده کرد.

R1#write

برای بررسی و مشاهده تنظیمات ، عیب یابی و … میتوانید از (show) در Privileged Mode استفاده کنید:

مشاهده تنظیمات در حال اجرا در running-config

R1#show running-config

مشاهده تنظیمات ذخیره شده در startup-config

R1#show startup-config

پاک کردن تنظیمات از startup-config یا NVRAM :

R1#erase startup-config

یا

R1#write erase

بعد از اجرای erase سوالی برای تایید اطمینان از درخواست پاک شدن تنظیمات پرسیده میشود

Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]y[OK]
Erase of nvram: complete

البته هر command یا دستوری که باید در Privileged Mode نوشته شود را می توان با اضافه کردن کلمه (do) به اول هر command ، در Mode Configuration یا (Global) هم نوشت و اجرا کرد.
مثال:

Router(config)# do show running-config
Router(config)# do write

شما میتوانید با دستور reload ، دستگاه Router را بعد از تایید، ریست کنید.

Router#reload
Proceed with reload? [confirm]

مطالب مرتبط با این مقاله:

آموزش دستورات Show در روترهای سیسکو

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت سوم

آموزش سیسکو Cisco قسمت چهارم

آموزش سیسکو Cisco قسمت پنجم

آموزش پیکربندی VLAN سوئیچ سیسکو

آموزش مفاهیم اولیه پل ها سوئیچ های سیسکو

آموزش بکاپ گرفتن از IOS سیسکو و بازیابی آن

آموزش روتینگ سوئیچ لایه سه سیسکو

 

معرفی Cisco IOS image

معرفی Cisco IOS image

IOS، سیستم عامل هوشمند،جذاب و انحصاری انواع دستگاه های کمپانی سیسکو (switch , router,…) می باشد، که توان ارائه سرویس های مدیریتی ، امنیتی ، voip و… را دارد.

سیستم عامل Ios سیسکو مانند همه سیستم عامل های دستگاه های دیگر کامپیوتری مدیریت منابع سخت افزاری دستگاه را بر عهده داشته و رابط بین کاربر و دستگاه ها می باشد.

برای کنترل وتنظیم ios ، سیسکو محیط ترمینال یا خط فرمان ( CLI -command line interface) در اختیار کاربر قرار می دهد که با نوشتن و اجرای command ها بر روی ios میتوان دستگاه های سیسکو مثل سوئیچ سیسکو (switch , router,…) را تنظیم( config) کرد. البته می توان به کمک برخی از نرم افزارها مانند CCP و SDM، دسترسی های گرافیکی به IOS داشت.

اسم یک IOS دارای بخش های به شرح زیر می باشد:

IOS سیسکو

IOS سیسکو

بخش اول:

مدل دستگاهی می باشد که IOS را پشتیبانی می کند. به عنوان مثال روتر ۳۶۴۰ یا ۳۷۲۵

نکته : البته برخی از IOS ها را می توان برای برخی از روترهای مشابه سیسکو استفاده کرد. به عنوان مثال ممکن است یک IOS مدل ۲۸۲۱ با مدل روتر ۲۸۱۱ نیز سازگار باشد.

بخش دوم :

این قسمت برخی از توانمندی های IOS را بیان می کند. به عنوان مثال entbase برگرفته از عبارت Entrerprise base می باشد. در ذیل، برخی از توانمندی ها لیست شده است.

IPBase
IP Services
Advanced IP Services
EnterpriseServices
Advanced Enterprise Services
IPVoice
Advanced Security
SP Services
EnterpriseBase

IPBase :

این IOS دارای قابلیت های اصلی و حداقل قابلیت های یک روتر می باشد.

به عنوان مثال IOS با توانمندی Enterprise Base دارای توانمندی های اصلی و همچنین قابلیت پشتیبانی از پروتکل های IPX و AppleTalk را پشتیبانی خواهد کرد.

IP Services :

این IOS دارای توانمندی های EIGRP/OSPF,BGP,GLBP,QoS,NAT,HA,VRF-lite,Netflow,Advance Multicast می باشد.

Advanced IP Services :

این IOS ها علاوه بر توانمندی های EIGRP/OSPF,BGP,GLBP,QoS,NAT,HA,VRF-lite,Netflow,Advance Multicas دارای توانمندی های دیگری مانند IP v6 و توانمندی های پیشرفته امنیتی می باشند.

Advanced Security :

این IOS دارای توانمندی های IOS Firewall، IDS، IPSec، ۳DES Enc، VPN، SSH می باشند.

SP Services :

این IOS ها دارای توانمندی های از قبیل MPLS, SSH, ATM, VoATM می باشند.

Ipvoice :

این IOS ها دارای توانمندی های از قبیل VoIP, VoFR, IP Telephony می باشد.

Enterprise Services :

این IOS ها دارای توانمندی های IOS های SP Services ، Enterprise Base ، Ipvoice می باشند

Advanced Enterprise Services :

یک IOS کامل با همه توانمندی ها می باشد.

بخش سوم:

در نام گذاری IOS سیسکو، c3725-entbase-mz.123-2.T.bin مربوط به عبارتی مانند mz می باشد.

حرف اول بخش سوم یعنی m، محل قرارگیری IOS سیسکو را مشخص می کند و بخش z نوع فشرده سازی را مشخص می کند.

برای محل قرارگیری IOS از کدهای زیر استفاده می شود:

M: در حافظه RAM
r: در حافظه ROM
f: در حافظه Flash
l: محل قرارگیری IOS در هنگام بوت و اجرای دستورات عوض می شود
برای تعیین نوع فشرده سازی از کدهای زیر استفاده می شود :

z: فشرده سازی zip
x: فشرده سازی mzip
w: فشرده سازی با الگوریتم STAC

بخش چهارم:

مربوط به نگارش IOS می باشد c3725-entbase-mz.123-2.T.bin به عنوان مثال نگارش این IOS نگارش ۱۲.۳ می باشد.

بخش پنجم:

که به صورت ۲ یا ممکن است در داخل پرانتز باشد مانند c3725-entbase-mz.123(2).T.bin می باشد نگارش مربوط به اینIOS را تعیین می کند به عنوان مثال در نام IOS بالا عدد ۲ بیانگر نگارش دوم این IOS می باشد.

بخش ششم:

که در این مثال c3725-entbase-mz.123-2.T.bin حرف T می باشد برخی ویژگی ها و خصوصیات IOS را عنوان خواهد کرد برای این بخش از کدهای زیر استفاده می شود.

T: بیانگر اضافه شدن یکسری ویژگی های جدید می باشد.
S: برخی ویژگی های امنیتی اضافه شده یا برخی نواقص امنیتی برطرف شده است.
E: بیانگر طراحی IOS برای سازمان های بزرگ و Enterprise می باشد
مراحل راه اندازی (Switch , Router) و بوت شدن IOS:
بعد از روش شدن (powered on) دستگاه ، بلافاصله

مراحله اول :

ابتدا Switch , Router با استفاده از عملیات ( post _Power On Self-Test) سلامت سخت افزار دستگاه را بررسی و چک می کند

مرحله دوم :

برنامه bootstrap یا (boothelper) از حافظه ROM اجرا و IOS را بصورت پیش فرض از حافظه Flash پیدا و برای اجرا به حافظ Ram انتقال می دهد .
( البته برنامه bootstrap به کدهای Configuration register برای پیدا کردن محل ذخیره ios توجه می کند که بصورت پیش فرض register کد به حافظه Flash اشاره میکند چون ممکن است ios درمحل دیگری یا کلا در حافظه Flash نباشد و یا موارد دیگرکه در ادامه توضیح میدهیم )

مرحله سوم :

وقتی IOS به حافظه Ram انتقال میابد ازحالت فشرده خارج میشود و اجرا میشود

مرحله چهارم:

در این مرحله IOS تلاش میکند تنظیمات خود را ازحافظه NVRAM بهRam انتقال و اجرا کند درصورتی که تنظیماتی در حافظه NVRAM از قبل ذخیره نشده باشد IOS سعی میکند دیگر حافظه ها مانند (TFTP) که احتمال ذخیره تنظیمات را دارند بررسی کند درنهایت اگه تنظیماتی را پیدا نکرد به حالت یا مد( Setup Mode – Initial Configuration Mode) می رود.

Cisco IOS image

Cisco IOS image

 

مطالب مرتبط:

مدل های مختلف IOS های سوئیچ های سیسکو

مدل ها و ورژن های مختلف IOS های سیسکو

آپدیت IOS سوییچ سیسکو

آموزش بکاپ گرفتن از IOS سیسکو و بازیابی آن

آموزش مفاهیم اولیه پل ها سوئیچ های سیسکو

آموزش مفاهیم اولیه پل ها سوئیچ های سیسکو

آموزش مفاهیم اولیه پل ها سوئیچ های سیسکو

پل و سوئیچ هر دو دستگاه هایی هستند که در لایه دو عمل میکنند. پل ها و سوئیچ ها از لحاظ کاری شبیه به هم عمل میکنند و به نحوی میتوان گفت که هردو اهداف یکسان دارند اما از لحاظ معماری سخت افزاری با یکدیگر تفاوت های اساسی دارند.

در این مقاله مباحثی مانند عملکردهای پل ها و سوئیچ ها، مفاهیم STF و چند دستور ساده در سوئیچ 2960 را مورد بررسی قرار خواهیم داد.

لینک دانلود:آموزش مفاهیم اولیه پل ها و سوئیچ های سیسکو

فرمت: PDF

حجم: 12.6 MB

فصل اول آشنایی با سوئیچ سیسکو

فصل دوم مدیریت سوئیچ و روتر سیسکو

 فصل چهارم آموزش پیکربندی VLAN سوئیچ سیسکو

فصل پنجم آموزش مفاهیم مسیریابی

فصل ششم آموزش پیکربندی پروتکلهای بردار فاصله

فصل هفتم آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش سیسکو Cisco قسمت پنجم

آموزش سیسکو Cisco قسمت پنجم

آموزش سیسکو Cisco قسمت پنجم

در جلسه قبل به طور کامل با rip اشنا شدیم، در این جلسه پیاده سازی آن را انجام میدهیم . از همان شکل سناریو ip static استفاده میکنیم.

آموزش سیسکو

مرحله اول تنظیمات روتر 1 و 2

اینترفیس fast ethernet 0/0 روتر 1
router1# config t
router1(config)#interface fast 0/0
router1(config-if)# ip address 192.168.14.1 255.255.255.0
router1 (config-if)# no shutdown
اینترفیس serial0/1/0 روتر 1
router1# config t
router1(config)#interface serial 0/1/0
router1(config-if)# ip address 192.168.15.1 255.255.255.0
router1 (config-if)# no shutdown

روتر دوم هم به همین صورت تنطیم میکنم . با توجه به ip address هایی که در شکل است . با دستورات بالا ما به اینترفیس ها ای پی دادیم.

پیکربندی rip
برای وارد کردن دستورات rip باید ابتدا به مد configuration روتر برویم و با دستور router rip وارد مد rip شده و شبکه ایی که مستقیم به اینترفیس های روتر 1 متصل هستند یا به عبارت دیگه شبکه هایی که در داخل جدول مسیر یابی روتر به عنوان شبکه های connected شناسایی و تشخیص داده میشوند را در مقابل دستور network وارد کنیم . شکل دستورات به صورت زیر است:

پیکربندی روتر 1

router1 # config t
router1 (config)# router rip

این دستور باعث فعال شدن پروتکل rip بر روی router میشود.

router1 ( config-router)# network 192.168.14.0

این دستور باعث میشود که شبکه 192.168.14.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل rip به روتر های همسایه اعلام بشود.

router1 ( config-router)# network 192.168.15.0

 

این دستور باعث میشود که شبکه 192.168.15.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل rip به روتر های همسایه اعلام بشود.

router1#copy running- config startup-config

این دستور باعث میشود اطلاعات ما ذخیره شود.

پیکربندی روتر 2

router2 # config t
router2(config)# router rip

این دستور باعث فعال شدن پروتکل rip بر روی router میشود.

router2 ( config-router)# network 192.168.16.0

این دستور باعث میشود که شبکه 192.168.16.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل rip به روتر های همسایه اعلام بشود.

router2 ( config-router)# network 192.168.15.0

این دستور باعث میشود که شبکه 192.168.15.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکلrip به روتر های همسایه اعلام بشود.

router2#copy running- config startup-config

این دستور باعث میشود اطلاعات ما ذخیره شود.
بعد از انجام کار های بالا rip بر روی هر دو روتر پیکر بندی شد . برای مشاهده جدول مسیر یابی روتر ها از دستور زیر استفاده میشود:

 rourer1# show ip route

بعد از اینکه با rip اشنا شدیم حالا میرسیم به محبوب ترین پروتکل مسیر یابی در سیسکو:

eigrp:مخفف

enhance interior gateway routing protcol
پروتکل eigrp پروتکل اختصاصی سیسکو است . شرکت سیسکو همه توانمندی های محبوب پروتکل های linkstate و distance vector را در این پروتکل قرار داده و آن را به صورت یک پروتکل اختصاصی ارائه داده .
این پروتکل قادر به فعالیت در شبکه های بزرگ و گسترده است و یکی از محبوب های این پروتکل پیکربندی و مدیریت ساده آن است.
این پروتکل یک پروتکل classless است و قادر به پشتیبانی از توانمندی vlsm است و از پیامهای multicast برای update جدول مسیریابی استفاده میکند.
این پروتکل برای محاسبه metric و انتخاب بهترین مسیر از پارامتر های bandwigth و delay استفاده میکند.
در eigrp نیاز به تعریف یک شماره به نام as یا autonomous system میباشد که این شماره بابد در کل روتر های یک شبکه که پروتکل eigrp بر روی آنها تعریف میشود یکسان باشد.
بعداز توضیحات مختصر در مورد eigrp پیکربندی را با توجه به شکل زیر آغاز میکنیم

آموزش سیسکو

مرحله اول تنظیمات روتر 1 و 2
اینترفیس fast ethernet 0/0 روتر 1

router1# config t
router1(config)#interface fast 0/0
router1(config-if)# ip address 192.168.2.1 255.255.255.0
router1 (config-if)# no shutdown
اینترفیس serial0/0/0 روتر 1
router1# config t
router1(config)#interface serial 0/0/0
router1(config-if)# ip address 192.168.0.1 255.255.255.0
router1 (config-if)# no shutdown

روتر 2

اینترفیس fast ethernet 0/0 روتر 2
router2# config t
router2(config)#interface fast 0/0
router2(config-if)# ip address 192.168.3.1 255.255.255.0
router2 (config-if)# no shutdown
اینترفیس serial0/0/0 روتر 2
router2# config t
router2(config)#interface serial 0/0/0
router2(config-if)# ip address 192.168.0.2 255.255.255.0
router1 (config-if)# no shutdown

اینترفیس0/1/serial0 روتر 2

router2# config t

router2(config)#interface serial0/0/1

router2(config-if)# ip address 192.168.1.1 255.255.255.0

router2 (config-if)# no shutdown

همانطور که در شکل میبینید روتر دو دارای سه اینترفیس هست پس هر 3 اینترفیس باید ip address بگیرند.

روتر3

اینترفیس fast ethernet 0/0 روتر 3
router3# config t
router1(config)#interface fast 0/0
router3(config-if)# ip address 192.168.4.1 255.255.255.0
router1 (config-if)# no shutdown
اینترفیس1/serial0/0 روتر 3
router1# config t
router1(config)#interface serial 0/0/1
router1(config-if)# ip address 192.168.1.2 255.255.255.0
router1 (config-if)# no shutdown

در تنظیمات eigrp شما باید شبکه هایی که مستقیما به اینترفیس روتر 1 متصل می باشند یا به عبارتی شبکه هایی که در داخل جدول مسیریابی روتر 1 به عنوان شبکه connected شناسایی و تشخیص داده میشوند در routing mode در مقابل network نوشته میشوند تنظیمات در دستورات زیر نشان داده شده:
تنظیم eigrp در روتر 1

 router1#config t
router1 (config)# router eigrp 100

فعال کردن پروتکل eigrp روی روتر و تعیین شماره به عنوان as

 router1 (config-router)# network 192.168.0.0

این دستور باعث میشود شبکه 192.168.0.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیع شود.

router1 (config-router)# network 192.168.2.0

این دستور باعث میشود شبکه 192.168.2.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیغ شود.

تنظیم eigrp در روتر 2

 router2#config t

router2 (config)# router eigrp 100

فعال کردن پروتکل eigrp روی روتر و تعیین شماره به عنوان as

 router2 (config-router)# network 192.168.1.0

این دستور باعث میشود شبکه 192.168.1.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیع شود.

router2 (config-router)# network 192.168.3.0

این دستور باعث میشود شبکه 192.168.3.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیغ شود.

تنظیم eigrp در روتر 3

 router3#config t

router3(config)# router eigrp 100

فعال کردن پروتکل eigrp روی روتر و تعیین شماره به عنوان as

 router3(config-router)# network 192.168.1.0

این دستور باعث میشود شبکه 192.168.1.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیع شود.

router3 (config-router)# network 192.168.4.0

این دستور باعث میشود شبکه 192.168.4.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیغ شود.
همانطور که در تنظیمات مشاهده میکنید مقدار as برای روتر1 . روتر 2 . روتر 3 شماره 100 است که در هر سه روتر این عدد مشترک است.

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت سوم

آموزش سیسکو Cisco قسمت چهارم

آموزش سیسکو Cisco قسمت پنجم

منبع : ilikephp

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت دوم

در قسمت اول از آموزش سوئیچ سیسکو با محیط های موجود user mode . peivilage mode و configure mode اشنا شدیم .

تمام دستوراتی که برای تنظیم کردن سویوچ و روتر های سیسکو لازم است در محیط configure mode انجام میشود که به صورت زیر وارد آن میشویم:

ابتدا که دستگاه روشن میشود و بعد از انجام کارهای post وارد محیط user mode میشه که به صورت زیر نمایش داده میشود.

<  router router > enable

حالا وارد محیط privilage شده ایم.

router # 

در این محیط دستور config t را تایپ میکنیم.

router # config t

در زیر محیط config به این شکل نمایش داده میشود.

(router ( config #

حالا شروع میکنیم با استفاده از دستورات دستگاه را تنظیم کردن ابتدا از تغییر نام پیش فرض روتر های سیسکو.

برای این کار در محیط کانفیگ از دستور hostnameاستفاده میکنیم به صورت زیر:

router (config) # hostname اسم مورد نظر

من در اینجا اسم ccna را انتخاب میکنم.

router (config) # hostname ccna

بعد از اجرای دستور

(ccna (config#

دستور تنظیم کردن پسورد بر روی دستگاه

تجهیزات سیسکو از 5 نوع پسورد به صورت زیر پشتیبانی میکند:

conso password

telnet (vty) password

auxilary password

enable password

enable secret password

 

مختصر توضیحات در مورد پسورد ها

consol pasword , telnet password ,  auxilary password

از این سه پسورد برای رمز گذاری بر روی مد user modeاستفاده میشود.

enable password و enable secret

از این دو پسورد برای رمز گذاری در مدprivilage استفاده میشود.

میتونیم برای اینکه از دسترسی افراد به محیط تنظیم دستگاه جلوگیری کنیم برای این مد ها پسورد بگذاریم مثل محیط ویندوز

پسورد برای user mode

برای این کار به ترتیب کارهای زیر را انجام میدهیم:

 router > enable router #  config t router (config)# line consol 0

 

دستور خط اخر برای ورود به مد consol 0 میباشد.

router (config-line)# password ccna

دستور بالا کلمه ccna را به عنوان پسورد انتخاب میکند.

router (config-line)# login

دستور بالا کلمه عبور را در زمان ورود بهuser mode فعال میکند.

دستور show

با استفاده از این دستور میتوان نتیجه اجرای دستورات را مشاهده کرد که در مد privilage اجرا میشود.

به عنوان مثال:

router # show clock

این دستور باعث نمایش ساعت تنطیم شده میشود:

router# show interface

نمایش کلیه اینترفیس های دستگاه:

router #  show host

این دستور باعث نمایش اسم ثبت شده دستگاه خواهد شد:

نمایش اطلاعات آی او اس router # show version

 

و خیلی از دستورات دیگر شما میتوانید با زدن علامت ؟ بعد از دستور showکلیه دستورات را مشاهده کنید.

? router#show

در اینجا لازم است که یک مقدار در مورد اینترفیس های سریال توضیح بدهم چون در آموزش زیاد با این اینترفیس کار داریم این اینترفیس برای اتصال به شبکه های wan و استفاده از خطوط مخابراتی مثل leased line مخابرات مورد استفاده قرار میگیرد.

نمایی از اینترفیس سریال روتر

روتر

 

برای پیکر بندی اینتر فیس سریال که شامل ip دادن و دیگر دستورات میشود به روش زیر:

ابتدا وارد مد privilage میشیم.

router > enable

بعد وارد مد کانفیگ.

router # config t

بعد از ورود مد ما به صورت زیر نمایش داده میشود:

(router (config#

در اینجا باید برای انجام تنطیمات وارد اینترفیس شویم که به صورت زیر است:

router (config) # interface serial در اینجا شماره سریال اینترفیس را وارد میکنیم

نکته: برای مشاهده اینکه شماره اینترفیس چند است از دستور showبه صورت زیر استفاده میکنیم:

router #show ip interface brif

ادامه . بعد از ورود به اینترفیس که در چند خط قبل گفته شد برای دادن ipآدرس از دستور زیر استفاده میشود:

router (config_t )# ip address 192.168.1.1 255.255.255.0

دستور description برای اینتر فیس :

میتوانیم برای اینترفیس های سریال و هم اینترفیس های ethernet توضیحات مشخص کنیم.

description

دستوری است که به وسیله آن میشود توضیحات را برای اینترفیس نوشت . توضیحات برای شناسایی اینترفیس استفاده میشود که با نگاه کردن به آن می تونایم به یاد بیاوریم که این اینتر فیس به چه دستگاهی متصل است.

برای تعیین توضیحات ابتدا وارد مد تنظیم اینتر فیس میشویم:

router (config)# interface serial 2/0 در اینجا پیغام مورد نظر router (config)# description

 

ذخیره دستورات بر روی حافظه

 

برای ذخیره دائمی دستورات روتر و سوئیچ باید محتویات ram یعنی running-config به حافظه nvram یعنی فایل startup-config کپی شود. برای اینکار از دستور زیر استفاده میکنیم:

router # copy running- config startup-config

این دستور باعث ذخیره شدن اطلاعات در حافظه دائمی میشود. با دستور show میتوانیم همه محتویات موجود در حافظه را مشاهده کنیم:

router# show startup-config

تا اینجا با تعدادی از دستورات و همچنین مد های مختلف اشنا شدیم . ممکن است محیط دستگاه های سیسکو کمی فرق داشته باشد با سایر دستگا ها اما با کمی تمرین در نرم افزار packet tracer کامل با محیط آن اشنا میشوید . در جلسات بعدی دستورات کاربردی تری اموزش داده میشود.

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت سوم

آموزش سیسکو Cisco قسمت چهارم

آموزش سیسکو Cisco قسمت پنجم

منبع : ilikephp

 

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت اول

اولین مدرک ورود به سیسکو ccna میباشد. در اصل میشه گفت یک فرد دارای مدرک سیسکو دارای توانایی است

1- عیب یابی های شبکه

2- افزایش کارایی و مدیریت شبکه

3- افزایش امنیت شبکه

این یه مقدمه کوتاه از این مدرک

در این سری آموزش ها سعی میکنم در مورد همه روترها و سوئیچ ها و کابل ها و ماجول ها ی سیسکو تا حد امکان ساده توضیح بدهم.

( آشنایی با اجزای مهم سخت افزاری و نرم افزاری روتر)

ram :

حافظه دسترسی تصادفی است که کارهای زیر را در روتر انجام میدهد.

1- نگهداری از جدول routing table

2- نگهداری از arp cache

3- نگهداری از running-config یا فایلهای پیکربندی

Nvram :

یک حافظه قابل خواندن و نوشتن است که وظیفه نگهداری از فایل startup_config است.

flash :

یک حافظه قابل خواندن و نوشتن پایدار است که وظیفه نگهداری از سیستم عامل که به نام ios را بر عهده دارد.

Rom:

یک حافظه فقط خواندنی است که وظیفه راه اندازی اولیه نگهداری از برنامه و همچنین نگهداری از نسخه اولیه سیستم عامل را بر عهده دارد.

Interface:

اینترفیس یا رابط برای اتصال روتر به شبکه مورد استفاده قرار میگیرد. این اینتر فیس ها یا بر روی برد اصلی متصل میباشند یا به صورت ماژولار به دستگاه اضافه میشوند.

Consol:

پورت کنسول برای اتصال روتر یا سوییچ به کامپیوتر به وسیله کابل کنسول برای پیکر بندی دستگاه استفاده میشود.

(اتصالات روتر و سوییچ به کامپیوتر)

برای تنظیم کردن روتر و سوئیچ سیسکو با استفاده از consol port و متصل کردن به کامپیوتر میشود برای بار اول این دستگاه ها را تنظیم کرد. پشت روتر ها محل قرار گیری پورت کنسول است که این پورت با con 0 نمایش داده میشود.

همانطور که گفتم برای اتصال دستگاه های سیسکو به کامپیوتر از کابل کنسول استفاده میشود که یک طرف این کابل به صورت سریال و طرف دیگر به صورت rj 45 میباشد. که قسمت سریال پشت سیستم کامپیوتر متصل میشود.

(تنظیمات سوییچ و روتر)

در صورتی که تنطیمات از قبل انجام نشده باشد در زمان boot روتر یا سوییچ به دلیل پیدا نشدن فایل تنظیمات درون حافظه nvram روتر تشخیص میدهد که تنظیمات از قبل انجام نشده است و برای ورود به مد تنطیمات با سوال و جواب که معروف به setup mode است . سوال پرسیده میشود که آیا میخواهید وارد پروسه تنظیمات setup شوید یا میخواهید وارد محیط استفاده از دستورات cli شوید که در این محیط تنطیمات باید به صورت دستی وارد شود.

مرحله اول

کابل کنسول را از طرف سریال به پورت سریال کامپیوتر و از طرف rj 45 به پورت کنسول پشت سوییچ یا روتر وصل میکنیم.

مرحله دوم

برای اتصال به دستگاه از برنامه hyper terminal ویا putty با نرم افزار های دیگر استفاده میکنیم . در این مرحله شما باید یک اسم برای اتصال خود انتخاب کنید. در مرحله بعدی از شما خواسته میشود که پورت سریال pc را که به دستگاه متصل است را مشخص کنید.

پس از روشن کردن دستگاه در اولین مرحله برنامه معروف به post اجرا میشود. برنامه در حافطه rom ذخیره شده که تمام عناصر سخت افزاری روتر را بررسی میکند.

در صورتی که دستگاه از قبل تنظیم نشده باشد با پیغام زیر روبرو میشوید.

(continue with configuration dialog (yes.no

اگر گزینه no را انتخاب کنید شما وارد مد دستوری cli میشوید.

کار با دستورات در محیط cli

سیسکو برای دسترسی به تجهیزات خود سه مد را در نظر گرفته است:

1 . user mode

2. privilege mode

3. global configuration mode

وقتی که وارد محیط دستورات سیسکو معروف به cli میشوید در مد user mode هستید در این مد توانایی استفاده از بعضی دستورات اولیه نمایشی و دستوراتی مانندpingوtelnet را داریم.

درمد privilage mod شما اختیارات بیشتری دارید برای ورود به این مد بعد از ورود به مد user mod شما از دستور enableاستفاده میکنید.

router > user

router > user

router # privilage

شما بعد از ورود به مد privilage mod میتوانید با تایپ دستور configure terminal یا به صورت خلاصه config t وارد میکنیم.

وارد محیط global configuration mod بشین که بیشتر دستورات پیکر بندی سوییچ و روتر های سیسکو در این مد انجام میشود.

router # config t
router (config)# config

اتصال روتر به شبکه lan از طریق اینترفیس های ether net و fast ether net و gigabitether net  با توجه به مدل دستگاه ممکن است interface های ether net یا fast ethernet را در دستگاه مشاهده کنیم که میتوانیم از این اینترفیس ها برای اتصال به شبکه داخلی یا lan استفاده کنیم.

برای اتصال روتر به سویئچ از کابل straight استفاده میکنیم.

برای کار در محیط cli بعد از اینکه اتصالات مربوط را انجام دادیم و به وسیله نرم افزار hyper terminal یه دستگاه متصل شدیم باید در ابتدا محیط user mode به صورت زیر دیده شود.

<   router

برای انجام تنظیمات دستگاه باید وارد محیط global بشیم به صورت زیر

router > e

router # config t

(router #(config

در این قسمت قصد ورود به یک اینترفیس را داریم در مد اینترفیس همه دستوراتی که اجرا میشه بر روی اینترفیس اعمال میشه نه کل اینترفیس های روتر از طریق دستور زیر وارد تنطیمات اینترنت سریال روتر میشویم.

router (config)# interface serial 0

الان وارد محیط اینتر فیس شده ایم که میتوانیم دستورات خود را وارد کنیم. برای باز گشت به حالت قبل میتوانیم از دستور exit استفاده نماییم، یا برای تغییر نام روتر میتوانیم از دستور زیر استفاده کنیم.

router (config)# hostname ccna
(ccna (config#

اگر احساس میکنید یه مقدار گنگ و سخته نگران نباشید تا اخر اموزش ccna زیاد با این دستورات کار داریم اینها فقط نمونه هایی برای اشنایی با محیط config است.

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت سوم

آموزش سیسکو Cisco قسمت چهارم

آموزش سیسکو Cisco قسمت پنجم

منبع : ilikephp