نوشته‌ها

شناسایی آسیب پذیری zero-day در Win32

شناسایی آسیب پذیری zero-day در Win32

شناسایی آسیب پذیری zero-day در Win32 :با وجودیک آسیب‌پذیری ارتقای سطح دسترسی درویندوز،وقتیWin32نمی‌تواندبه اشیاء داخل حافظه رسیدگی کند،نفوذگرمی‌تواندکددلخواه را درسطح هسته اجراکند.

متخصصان امنیت، ‫آسیب‌پذیری ‫zero-day جدیدی در سیستم عامل ‫ویندوز کشف کرده‌اند. این نقص، هنگام بررسی نفوذ برخی مهاجمان و درحالی کشف شده‌است که فرد نفوذگر سعی داشت از طریق یک آسیب‌پذیری ناشناخته در سیستم عامل ویندوز به شبکه هدف حمله کند.

تحلیل‌های انجام شده بیشترحول کتابخانه‌ای به نام win32.sysبوده‌است که درواقع فایل مربوط به درایورWin32محسوب می‌شود.

متن منتشر شده مایکروسافت بدین شرح است:

«یک آسیب‌پذیری ارتقای سطح دسترسی (elevation of privilege) در ویندوز وجود دارد به‌طوری که وقتی Win32 نمی‌تواند به اشیاء داخل حافظه رسیدگی (handle) کند، فرد نفوذگر با استفاده از این آسیب‌پذیری قادر به اجرای کد دلخواه در سطح هسته (kernel mode) خواهدبود.

در صورت استفاده صحیح، مهاجم قادربه نصب نرم‌افزارها،مشاهده،تغییرویاحذف اطلاعات ویاحتی ایجاداکانت جدیدبا اختیارات کامل است.

شناسایی آسیب پذیری zero-day در Win32

برای استفاده از این آسیب‌پذیری، مهاجم ابتدابایددرداخل سیستم وارد(log on)شودوسپس یک برنامه مخصوص وازپیش طراحی‌شده رااجراکندتاکنترل سیستم موردنظررابه دست گیرد.»

از لحاظ جغرافیایی، بیشتر حملات به کامپیوترهای خاورمیانه صورت گرفته‌است که نشان‌دهنده حملات هدفمند (targeted attack) است.

مایکروسافت یک به‌روزرسانی امنیتی را به‌صورت اضطراری منتشر و از همه کاربران درخواست کرده‌است که در اولین فرصت ممکن سیستم‌های خود را به‌روزرسانی کنند. این آسیب‌پذیری روز ۹ اکتبر ۲۰۱۸ شناسایی شد و درجه ریسک آسیب‌پذیری بالاست، اما به دلیل نبود کد مخرب به‌صورت عمومی و ارائه وصله توسط مایکروسافت، متوسط در نظر گرفته شده‌است.

 

سیستم‌های عامل تحت تاثیر این آسیب‌پذیری عبارت‌اند از:

• Microsoft Windows 10 Version 1607 for 32-bit Systems 
• Microsoft Windows 10 Version 1607 for x64-based Systems 
• Microsoft Windows 10 Version1803 for32-bit Systems 
• Microsoft Windows 10 Version 1803 for x64-based Systems 
• Microsoft Windows 10 Version 1809 for 32-bit Systems 
• Microsoft Windows 10 Version 1809 for x64-based Systems 
• Microsoft Windows 10 for 32-bit Systems 
• Microsoft Windows 10 for x64-based Systems 
• Microsoft Windows 10 version 1703 for 32-bit Systems 
• Microsoft Windows 10 version 1703 for x64-based Systems 
• Microsoft Windows 10 version 1709 for 32-bit Systems 
• Microsoft Windows 10 version 1709 for x64-based Systems 
• Microsoft Windows ۷ for 32-bit Systems SP۱ 
• Microsoft Windows ۷ for x64-based Systems SP۱ 
• Microsoft Windows 8.1 for 32-bit Systems 
• Microsoft Windows 8.1 for x64-based Systems 
• Microsoft Windows RT 8.1 
• Microsoft Windows Server 1709 
• Microsoft Windows Server 1803 
• Microsoft Windows Server 2008 R2 for Itanium-based Systems SP1 
• Microsoft Windows Server 2008 R2 for x64-based Systems SP1 
• Microsoft Windows Server 2008 for 32-bit Systems SP2 
• Microsoft Windows Server 2008 for Itanium-based Systems SP2 
• Microsoft Windows Server 2008 for x64-based Systems SP2 
• Microsoft Windows Server 2012 
• Microsoft Windows Server 2012 R2 
• Microsoft Windows Server 2016 
• Microsoft Windows Server 2019

از آنجایی‌که برای استفاده از این آسیب‌پذیری فرد حمله‌کننده نیازمند دسترسی محلی به کامپیوتر هدف است، ضروری است این دسترسی صرفا به اشخاص مورد اعتماد داده شده و درصورت امکان از محیط‌های محدود شده استفاده شود.

 

شناسایی آسیب پذیری zero-day در Win32

منبع خبر: پایگاه خبری امنیت فناوری اطلاعات

 

کارکنان بخش امنیت خواهان تغییر شغل خود هستند

حملات شبکه های بیسیم

هشدار حمله Ghost DNS به روترهای خانگی

پیشگیری از حملات IKE CRYPTO در سیستم عامل سیسکو

 

هشدار حمله Ghost DNS به روترهای خانگی

هشدار حمله Ghost DNS به روترهای خانگی

هشدار حمله Ghost DNS به روترهای خانگی: پژوهشگران امنیتی درباره نفوذ هکرها به صدهزار مودم و روتر خانگی در برزیل با حمله سایبری Ghost DNS هشدار دادند.

حمله سایبری جدیدی از طریق بدافزار Ghost DNS، صدهزار روتر خانگی را در برزیل آلوده‌ کرده‌است. هکرها در این حمله می ‌توانند اطلاعات حساس کاربر را با دستکاری مسیر ترافیک و هدایت قربانی به سمت صفحات جعلی سرقت کنند.

به گفته گروهی از پژوهشگران هم‌اکنون کنترل بیش از صدهزار مودم و روتر خانگی از برندهایی چون D-Link ،MikroTik ،TP-Link ،Huawei و SpeedTouch به دست هکرها افتاده است و آنها آدرس سرورهای DNS را برای مقاصد خود تغییر داده‌اند.

پژوهشگران از ۲۰ سپتامبر ۲۰۱۸ خبر از یک حمله گسترده داده‌اند. روند اینگونه است که در هنگام بازدید از صفحات آلوده به کدهای مخرب، یک اسکریپت به منظور بررسی باز بودن درگاه‌های روتر اجرا می‌‌شود و تلاش می‌کند از طریق حملات بروت فورس (Brute Force) به صفحه تنظیمات آن وارد شوند. در صورتی که حمله موفقیت‌آمیز باشد، آدرس‌های DNS و همچنین کلمه عبور روتر عوض می‌‌شود تا ضمن هدایت ترافیک کاربر به سمت شبکه‌های تحت کنترل هکرها، قادر به ورود به تنظیمات و بازگردانی آنها نباشد. از آنجایی که بسیاری از کاربران هرگز کلمه عبور پیش‌فرض روتر خود را تغییر نمی‌دهند، بسیاری از روترها در برابر این نوع حملات آسیب‌پذیر هستند.

بروت فورس یکی از انواع حملات هکری برای به‌دست آوردن رمز های عبور است. در این روش هکر با استفاده از نرم‌افزارهای مخصوص سعی می‌کند تمام عبارت‌های ممکن را بررسی کند. آشنایی با حملات brute force برای همه مدیران سایت‌ها و کاربران اینترنتی که دارای پنل مدیریت اینترنتی یا نام کاربری و رمز عبور در یک سایت خاص هستند لازم و ضروری است، چراکه با شناخت این نوع حمله و راهکار‌های مقابله با آن گامی بلند در راه ارتقای امنیت سایبری برداشته‌شده و میزان کمتری از سایت‌ها توسط این روش خطرناک مورد نفوذ قرار می‌گیرند.

حمله Ghost DNS به روترهای خانگی

این حمله را شرکت امنیت سایبری Netlab360 شناسایی کرده‌است. برندهایی که در این حمله تحت تاثیر قرار گرفته‌اند در ذیل آمده‌اند:

• 3COM OCR-812
• AP-ROUTER
• D-LINK
• D-LINK DSL-2640T
• D-LINK DSL-2740R
• D-LINK DSL-500
• D-LINK DSL-500G/DSL-502G
• Huawei SmartAX MT880a
• Intelbras WRN240-1
• Kaiomy Router
• MikroTiK Routers
• OIWTECH OIW-2415CPE
• Ralink Routers
• SpeedStream
• SpeedTouch
• Tenda
• TP-LINK TD-W8901G/TD-W8961ND/TD-8816
• TP-LINK TD-W8960N
• TP-LINK TL-WR740N
• TRIZ TZ5500E/VIKING
• VIKING/DSLINK 200 U/E

بررسی‌های شرکت امنیت سایبری Netlab ۳۶۰، حاکی از آن است که هکرها کاربران را به سمت صفحات جعلی فیشینگ هدایت می‌کنند و اطلاعات آنها را سرقت می‌کنند.

کاربران برای جلوگیری از حملات این‌چنینی باید Firmware های روتر خود را به‌روز نگه دارند و از برنامه‌های ضدویروس قدرتمند استفاده کنند. همچنین کلمه عبور پیش‌فرض روتر را تغییر دهند.

 

منبع خبر: پایگاه خبری امنیت فناوری اطلاعات

هشدار حمله Ghost DNS به روترهای خانگی

آموزش ساختن Sub Interface در روتر سیسکو

آموزش ساختن Sub Interface در روتر سیسکو

آموزش ساختن Sub Interface در روتر سیسکو :sub interface در واقع همان vlan هائیست که ما بر روی یک پورت روتر سیسکو متصل به ترانک تعریف میکنیم. به بیان دیگر برای دسترسی به vlan های تعریف شده روی یک سوئیچ سیسکو و استفاده از inter vlan Routing توسط روتر میبایست یک اینترفیس روتر به یک پورت ترانک trunk از سوئیچ متصل شده و ساب اینترفیس ها با شماره متناظر vlan ها روی آن تعریف شود.

روتر های سیسکو

روتر های سیسکو برای ارتباطات trunk از 2 پروتکل که یکی مختص تجهیزات سیسکو و دیگری استاندارد جهانی است پشنیبانی میکنند.

اولی ISL یا همان Cisco Inter-Switch Link است که پروپایوتری سیسکو است در واقع پروتکل ‌vlan Encapsulation مختص سیسکو است که فقط توسط دستگاه های خود سیسکو و شاید بعضی دیوایس های دیگر پشتیبانی شود.

البته ISL با اقبال عمومی روبرو نشد و در حال حاضر اکثرا از پروتکل دوم به نام 802.1Q که استاندارد جهانی است استفاده میکنند. اصولا در صنعت کامپیوتر معدود استاندارهای proprietary شرکت های خاص به موفقیت نایل شد از جمله شرکت apple که سرسختانه بر سر مواضع خود ایستاد و توانست یک استاندارد اختصاصی برای خود داشته باشد و هیچ الزامی با سازگاری با دیگر تولید کنندگان نرم افزار و سخت افزار ندارد! و این خود سیاستی است بس خطر ناک برای وابسته کردن مشتری!

برای مثال پروتکل EIGRP – IGRP سیسکو که بسیار قوی تر از OSPF است باز هم به دلیل اینکه فقط توسط خود روتر های و سوئیچ های سیسکو پشتیبانی میشود در اسکیل های بزرگ استفاده نمیشود برای مثال روتینگ داخلی شبکه ایران به دلیل استفاده از دیوایس های مختلف مثلا سیسکو، هواوی، جونیپر و … و یک دست نبودن در حال حاضر بر روی OSPF قرار دارد که به نظر من از EIGRP ضعیف تر عمل میکند! که البته این خود باعث عدم وابستگی به یک سکوی خاص و برند خاص میشود.

آموزش ساختن Sub Interface در روتر سیسکو

خب با توجه به مطالب بالا dot1Q یا همان 802.1q پروتکل رایج برای vlan encapsulation است. برای کانفیگ vlan ها بر روی روتر سیسکو ابتدا یک اینترفیس را به یک پورت ترانک از سوئیچی که میخواهیم از vlan های تعریف شده روی آن استفاده کنیم متصل کرده و بدین ترتیب عمل میکنیم:

router(config)#int gig 0/0
router(config-if)#description Trunk interface
router(config-if)#exit
router(config)#int gig 0/0.10 # 10 is vlan number that determine in switch
router(config-if)#encapsulation dot1Q 10
router(config-if)#ip add 192.168.1.1 255.255.255.0
router(config-if)#exit
router(config)#int gig 0/0.20
router(config-if)#encapsulation dot1Q 20
router(config-if)#ip add 192.168.2.0 255.255.255.0
router-sub-interface
router sub interface

کافیست پورت gig 0/0 روتر به یک پورت ترانک از سوئیچ مربوطه متصل و vlan های 10-20 و .. روی آن تعریف شده باشد، هر کلاینت میباید gateway خود را IP روی اینترفیس روتر ست کند که ترافیک خارج از subnet برای route شدن به سمت روتر ارسال شود.

آموزش ساختن Sub Interface در روتر سیسکو

 

منبع : گیک بوی

 

شاید این موارد نیز مورد علاقه شما باشد:

تعویض پورت پیش فرض تلنت در روتر سیسکو

دسترسی Telnet به روتر سیسکو

مدیریت سوئیچ روتر سیسکو

مراحل بوت شدن روتر سیسکو

آموزش تنظیم IP روتر و سوئیچ سیسکو

آموزش SNMP در روتر و سوئیچ های سیسکو

مراحل Boot کردن روتر های سیسکو

برگرداندن روتر یا سوئیچ سیسکو به تنظیمات کارخانه

اینترفیس های روتر و سوئیچ سیسکو

آموزش دستورات Show در روترهای سیسکو

راه اندازی SSH در سوئیچ ها و روتر های سیسکو

دستورات تنظیمات روتر و سوئیچ سیسکو

آموزش ساختن Sub Interface در روتر سیسکو

آموزش روش های ایمن سازی تجهیزات سیسکو

آموزش روش های ایمن سازی تجهیزات سیسکو

آموزش روش های ایمن سازی تجهیزات سیسکو :میخواهیم در این مقاله 10 دستور کارردی جهت ایمن سازی تجهیزات سیسکو معرفی کنیم.

آموزش روش های ایمن سازی تجهیزات سیسکو

۱- تعیین طول پسورد

با استفاده از دستور زیر شما می توانید طول پسوردهای ورودی در سیسکو را مدیریت کنید. این نکته لازم به ذکر است که سعی کنید حداقل از طول 8 کارکتر جهت بالا بردن امنیت تجهیزات خود استفاده نمایید.

(Router (config) #security passwords min-length 8 ( Minimum length of all user/enable passwords

✅طول پسورد را می توان از صفر تا 16 کاراکتر مشخص کرد.

۲- استفاده از دستور Enable Secret

همانظور که می دانید یکی از دستوراتی که خیلی در پیکربندی تجهیزات سیسکو استفاده می شود دستور enable password است اما به علت مشکل امنیتی و عدم کد گذاری پسورد پیشنهاد می شود از دستور Enable Secret استفاده کنید.

*Router (config) #enable secret cisco123

۳- قراردادن پسورد درراه های دسترسی به تجهیزات

ما جهت دسترسی به تجهیزات سیسکو روش های مختلفی از قبیل vty , Comsole , aux … داریم که برای بالا بردن امنیت تجهیزات سیسکو خود می بایست پسورد مناسبی جهت دسترسی به آن ها قرار دهیم تا از دسترسی افراد سودجو به تجهیزات جلوگیری کنیم.

۴- فعال سازی سرویس کدگذاری پسوردها

با استفاده از سرویس password encryption به صورت خودکار تمام رمزهای مشخص شده کد گذاری می شوند.

Router (config) #service password-encryption

۵- غیرفعال کردن Password Recovery

همانطور که می دانید امکان Password Recovery در محیط Rommon در تجهیزات سیسکو وجود دارد که این قابلیت در محیط های که تجهیزات در محیط های امنی از لحاظ فیزیکی وجود ندارند می تواند بسیار خطرناک باشد زیرا هکر به راحتی می تواند با استفاده از این قابلیت به تجهیزات ما دسترسی پیدا کند. با استفاده از دستور زیر می توانید این قابلیت را غیر فعال کنید.

Router (config) # no Service Password Recovery

۶- محدودیت در تعداد دفعات وارد کردن پسورد

یکی از روشهای هک استفاده از حملات کرکینگ است که در این روش هکر به صورت مکرر از یک دیکشنری جهت وارد کردن پسورد استفاده می کنند از این رو ما باید برای ورود پسوردها محدودیت ایجاد کنیم برای این امر از دستور زیر استفاده می کنیم.

Router (config) # Security authentication failure rate 5

با توجه به دستور بالا اگر 5 بار پسورد اشتباه زده شود 15 ثانیه وقفه در دادن پسورد ایجاد می شود.

۷- محدودیت زمان کار نکردن کاربر با تجهیزات

(Router (config) #line console 0 (Vty or Aux
(Router (config-line) #exec-timeout 2 (Min) 30 (Sec

با توجه به دستور بالا در صورتی که کاربر 2 دقیقه 30 ثانیه کانفیگی انجام ندهد ارتباط قطع می شود و باید مجددا متصل شویم.

۸- محدودیت تعداد دفعات لاگین اشتباه در یه بازده زمانی خاص

Router (config) #login block-for 30 attempts 5 within 10

در کد بالا اگر کاربری در 10 ثانیه 5 بار اشتباه پسورد را وارد کند به مدت 30 ثانیه بلاک می شود.

۹- مخفی کردن فایل Boot

جهت بالابردن امنیت تجهیزات سیسکو ، فایل boot خود را با استفاده از دستور بالا می توانید مخفی کنید.

Router(config)#secure boot-image

۱۰- ایجاد پشتیبان مخفی از کانفیگ تجهیزات

Router(config)#secure boot-config

منبع: گیک بوی

آموزش روش های ایمن سازی تجهیزات سیسکو

 

 

شاید این موارد نیز مورد علاقه شما باشد

آموزش روش های ایمن سازی تجهیزات سیسکو

دستورات پیکربندی سوئیچ سیسکو

دستورات تنظیمات روتر و سوئیچ سیسکو

آموزش تنظیم IP روتر و سوئیچ سیسکو

بازنشانی پیکربندی سوئیچ های سیسکو به پیش فرض کارخانه

آموزش SNMP در روتر و سوئیچ های سیسکو

دسترسی Telnet به روتر سیسکو

راه اندازی SSH در سوئیچ ها و روتر های سیسکو

آموزش روش های ایمن سازی تجهیزات سیسکو

آموزش تنظیم IP روتر و سوئیچ سیسکو

آموزش تنظیم IP روتر و سوئیچ سیسکو

آموزش تنظیم IP روترو سوئیچ سیسکو  :تنظیم IP روتر سیسکو و یا ست کردن IP روتر و یا اختصاص IP به روتر سیسکو و یا سوئیچ سیسکو اولین گام در راه اندازی قابلیت های مسیریابی routing و دسترسی از طریق آدرس دهی IP به روتر سیسکو و یا سوئیچ سیسکو است.

تنظیم IP Address مختص تجهیزات سیسکو که در لایه سه کار میکنند از قبیل سوئیچ لایه سه سیسکو و یا روتر سیسکو ، الزاما نیست، چراکه برای دسترسی های مدیریتی میبایست اقدام به ست کردن IP بر روی سوئیچ لایه دو سیسکو نیز نمود کما اینکه سوئیچ های لایه 2 سیسکو فاقد امکان مسیریابی IP هستند.

تنظیم IP روتر سیسکو، اولین گام در عملیاتی نمودن روتر سیسکو و یا سوئیچ سیسکو است چرا که ما در شبکه های IP با Subnet ها سر و کار داریم و در واقع هر شبکه محدود به یک سابنت (اصلی) است بدین مفهوم که هر اینترفیس محدود به Broadcast Domain همان Network که در آن آدرس دهی شده است میباشد و پکت های میبایست برای رسیدن به مقصد مسیریابی شوند که این نکته فرق اصلی روتینگ و بریجینگ است. در Bridging ما محدود به یک مدیا که همچنین محدود به یک تکنولوژی لایه دو که همه در یک Broadcast Domain هستند میشویم لکن در شبکه لایه سه یا یک Routed Network ، ما با Subnet ها سر و کار داریم و همچنین یک پکت ممکن است برای رسیدن به مقصد از انواع رسانه ها و تکنولوژی های لایه 2 با MTU های مختلف و مدیوم های متفاوت عبور کند.

در حقیقت روتر جدول مسیریابی یا همان دید خود از شبکه را از سه طریق میسازد:

1. شبکه های متصل به اینترفیس هایش Prefix – Subnet هایی که در وضعیت Connected یعنی تعریف شده روی اینترفیس های حقیقی و یا مجازی روتر (همین بحث ما که مربوط به تنظیم IP روی اینترفیس های روتر سیسکو) است.

2. Static Route ها.

3. Route هایی که از طریق کارکرد Routing Protocol ها بدست می آورد نظیر OSPF – EIGRP BGP و …

آموزش تنظیم IP روتر و سوئیچ سیسکو

بنابراین تعریف IP بر روی اینترفیس روتر سیسکو اولین و مهمترین قدم برای عملیاتی کردن یک روتر سیسکو است. کمی از بحث اصلی دور شدیم منتها پرداختن به مفهوم و تفاوت های اصلی شبکه های لایه 2 و شبکه های لایه سه و فرق عملیات Routing – روتینگ و Bridging – بریجینگ و همچنین تاثیر مهم شبکه های Connected بر روی صحت عملکرد روتر میتواند دید شفاف تری نسبت به این امر را حاصل نماید برای مثال اگر شما یک Prefix معروف مثل 8.8.8.0/24 که یکی از DNS های معروف و پر استفاده عمومی ست را روی یکی از اینترفیس های روتر خود ست کنید (مثلا 8.8.8.1/24)

زمانی که از پشت روتر سعی کنید 8.8.8.8 را پینگ کنید به RTO برخواهید خورد چرا که روتر در جدول مسیریابی میبیند که این سابنت به شکل Connected است لذا درخواست را به سمت Gateway خود نمیفرستد حتی اگر این Prefix توسط یک Routing Protocol در جدول مسیریابی نوشته شده باشد به دلیل اینکه Connected Route ها بالاترین ارزش و کمترین Metric را دارند باز هم Packet ها به سمت مقصد هدایت نخواهد شد.

روتر سیسکو و یا سوئیچ سیسکو و کلا هر دیوایس لایه 3 با پروتکل های لایه 3 قابل آدرس دهی (در اینجا IP) سر و کار دارند لذا همانطور که ابتدا اشاره شد قدم اول برای راه اندازی روتر سیسکو اختصاص آدرس IP به اینترفیس روتر سیسکو – اینترفیس سوئیچ سیسکو است در واقع پس از آدرس دهی ست که روتر سیسکو موقعیت خود را تشخیص و شبکه متصل به اینترفیس خود را شناسایی کرده و سپس میتواند به تبادل Packet و انجام عملیات مسیریابی و تشکیل جدول مسیریابی Routing table بپردازد.

دراین مقاله برای جلوگیری ازپیچیدگی مابه روش اختصاص IP به چند اینترفیس متداول روتر و سوئیچ سیسکو میپردازیم.

اختصاص IP به اینترفیس اترنت روتر سیسکو:

روتر سیسکو اغلب به شکل پیشفرص دارای یک یا چند اینترفیس اترنت Ethernet یا فست اترنت Fast Ethernet و یا Gigabit Ethernet هستند شما میتوانید برای آگاهی از اینترفیس های روتر سیسکو از این دستور استفاده کنید:

show interface summary

همانگونه که از خروجی دستور show interface sum پیداست لیست انواع اینترفیس های روتر اعم از اینترفیس های فیزیکی از قبیل Serial – OC3 – Ethernet و مجازی از قبیل Sub Interface و Tunnel و loopback نمایش داده میشوند.

برای تنظیم IP روتر سیسکو برای اینترفیس های فیزیکی نظیر FastEthernet – Ethernet – GigabitEthernet بدین ترتیب عمل مینماییم:

R1>en
Password: 
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z
R1(config)#int gi 0/1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit

برای انواع دیگراینترفیس های اترنت نیزروال به همین صورت است فقط میبایست نام آنهاراپس ازدستورinterfaceواردنموده وسپسIP Addressبه همراه Subnet راواردکنید.

در صورتی که مایل باشید به اینترفیس روتر سیسکو بیش از یک IP اختصاص دهید لازم است که پس از وارد نمودن IP و Subnet Mask از عبارت Secondary استفاده کنید این عبارت برای آدرس های سوم الی آخر فرقی نخواهد کرد برای مثال برای کانفیگ سومین آدرس بر روی یک اینترفیس روتر سیسکو نیز همانند IP دوم عمل کنید.

برای پاک کردن یکIP ازروی اینترفیس روترسیسکودرصورتی که همان یک IP برروی آن باشدویابخواهیدهمه IP Address هاراحذف نماییدکافی است ازدستور:

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int gi 0/1
R1(config-if)#no ip address

xIP-config.jpg.pagespeed.ic.1koFWnQnFJ

استفاده نمایید.

تنظیم IP Address بر روی اینترفیس سریال روتر سیسکو

اینترفیس های سریال روتر سابق بر این استفاده های گسترده ای در اتصالات wan در ارتباط روتر سیسکو با dsu/csu ها مثل مودم های G.SHDSL – ATM – E1 و … داشتند که با پیشرفت تکنولوژی و افزایش نیاز به سرعت های بالاتر استفاده از این نوع اینترفیس به علت منسوخ شدن تکنولوژی های مرتبط آنچنان مرسوم نیست و دیگر کمتر روتری را میبینیم که مجهز به wic 1t یا wic 2t باشد معذالک ذکر روش تنظیم آدرس IP بر روی اینترفیس های سریال که البته به ندرت اتفاق میافتاد خالی از لطف و مرور خاطرات نیست:

R1(config)# interface serial 0/0/0
R1(config-if)# description Link to R2
R1(config-if)# ip address 209.165.200.225 255.255.255.252
R1(config-if)# clock rate 128000
R1(config-if)# no shutdown
R1(config-if)# exit

تنظیم IP Address بر روی پورت سوئیچ لایه سه سیسکو

سوئیچ های لایه سه سیسکو امکان مسیریابی رادارامیباشندبنابراین میتوانیدبرروی اینترفیس های سوئیچ لایه سه سیسکونظیرسوئیچ سیسکو3560وسوئیچ سیسکو3750 IP ست کنید.

برای تنظیم آدرس IP روی سوئیچ سیسکو ، بدین ترتیب عمل کنید:

R1-3750#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1-3750(config)#int gi 1/0/16
R1-3750(config-if)#no switchport
R1-3750(config-if)#ip address 192.168.57.1 255.255.255.0
R1-3750(config-if)#exit
R1-3750(config)#do sh run int gi 1/0/16
Building configuration…
Current configuration : 93 bytes
!
interface GigabitEthernet1/0/16
no switchport
ip address 192.168.57.1 255.255.255.0
end

ست کردن IP روی اینترفیس های مجازی روتر و سوئیچ سیسکو

vlan ها، تانل ها ( tunnel )، لوپ بک ( loopback )، ساب اینترفیس ها ( sub interface ), … جزء اینترفیس های غیر فیزیکی که به آنها میتوان اینترفیس های مجازی از لحاظ ابعاد وجودی البته اطلاق کرد برای مثال شما میتوانید بر روی یک Vlan حتی در یک سوئیچ لایه 2 سیسکو IP ست کنید لکن این IP تنها به جهت دسترسی به سوئیچ قابل استفاده خواهد بود و استفاده های لایه سه ای نخواهد داشت:

R1-3750#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1-3750(config)#int vlan 301
R1-3750(config-if)#ip address 192.168.65.1 255.255.255.0
R1-3750(config-if)#exit
R1-3750(config)#do sh run int vlan 301
Building configuration…
Current configuration : 64 bytes
!
interface Vlan301
ip address 192.168.65.1 255.255.255.0
end

همچنین در مواردی که یک سوئیچ سیسکو را با یک روتر سیسکو به جهت استفاده از intervlan routing ترانک کرده و یا به هر دلیل نیازمند استفاده از VLAN ها بر روی روتر سیسکو هستید به سادگی میتوانید از sub interface ها IP ست کنید:

R1-Core#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1-Core(config)#int gi 0/1.312
R1-Core(config-subif)#encapsulation dot1Q 312
R1-Core(config-subif)#ip address 192.168.66.1 255.255.255.0
R1-Core(config-subif)#exit
R1-Core(config)#do sh run int gi 0/1.312
Building configuration…
Current configuration : 119 bytes
!
interface GigabitEthernet0/1.312
encapsulation dot1Q 312
ip address 192.168.66.1 255.255.255.0
no cdp enable
end

تنظیم IP Address روی اینترفیس loopback روتر سیسکو

اینترفیس های LOOPBACK یک عضو بی بدیل بر روی روتر های سیسکو هستند آنها مجازی هستند و به هیچ جا متصل نیستند لکن به دلیل اینکه هیچ وقت Down نمیشوند در عمل امکانات مدیریتی مهمی در تنظیم روتر سیسکو به ارمغان می آورند اینترفیس های لوپ بک این اطمینان را به شما میدهند که یک اینترفیس حداقل روی روتر سیسکو همیشه UP و دارای یک IP مشخص است اغلب IP Address تنظیم شده بر روی اینترفیس loopback روتر سیسکو به عنوان IP اصلی روتر در مواقع مختلف مورد استفاده قرار میگیرد.

R1(config)#interface loopback 0
R1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 192.169.1.1 255.255.255.0

آموزش تنظیم IP روتر و سوئیچ سیسکو

درمجموع درشبکه های لایه سه مبتنی برIPاولین وبنیادی ترین بخش آدرس هایIPهستنداین آدرس هاهستندکهRouting Tableروتر هارامیسازندوامکان کارکردشبکه جهانی اینترنت رامیسرمیکنند.

البته در سالهای اخیر IP Version 4 به دلیل محدودیت تعداد تقریبا به اتمام رسید و تمامی Valid IP های version 4 در دنیا توسط سازمانهای جهانی Ripe Iana Arin واگذار Allocate شدند و همکنون دنیا به سمت استفاده از IP Version 6 میرود.

آموزش تنظیم IP روتر و سوئیچ سیسکو

 

منبع : گیک بوی

 

آموزش تنظیمات اولیه سوئیچ های سیسکو

دستورات تنظیمات روتر و سوئیچ سیسکو

چگونگی اتصال به سوئیچ سیسکو

تعویض پورت پیش فرض تلنت در روتر سیسکو

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

دسترسی Telnet به روتر سیسکو

اینترفیس های روتر و سوئیچ سیسکو

تکنولوژی Cisco StackWise چیست

آموزش مفاهیم مسیریابی

آموزش دستورات Show در روترهای سیسکو

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پیاده سازی Protected Port در سوئیچ سیسکو

آموزش تنظیم IP روتر و سوئیچ سیسکو

 

راه اندازی DHCP بر روی سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو :DHCP یکی از پر کاربرد ترین سرویس های شبکه است که در خفا و پس ضمینه مسئول اختصاص آدرس های IP به کلاینت های شبکه است این سرویس جزء لاینفک شبکه های بزرگ کوچک بوده و از ابتدایی ترین تراکنش های ارتباطی در شبکه های LAN است.

DHCP سرور

DHCP سرور

هنگامی که شما یک کلاینت را به یک شبکه مرتبط میکنید و یا با یک سرور PPP ارتباط برقرار میکنید پس از احراز هویت دریافت آدرس IP از ابتدایی ترین واکنش هاست. استفاده از DHCP علاوه بر افزایش کارایی شبکه به افزایش چشمگیر امنیت در شبکه های مبتنی بر سیسکو می انجامد. بدین ترتیب که به عنوان یک مدیر شبکه امکان مدیریت و رصد مشکلات به سادگی امکان پزیر است و همچنین از مشکلاتی نظیر IP Conflict و دسترسی غیر مجاز به آدرس های IP جلوگیری به عمل می آید. پیاده سازی DHCP بر روی روتر ها و سویئچ های سیسکو به سادگی امکان پذیر بوده و ترافیک و لود چندانی را به دستگاه تحمیل نمینماید.

راه اندازی DHCP بر روی سوئیچ سیسکو

شروع کار:

توصیه میشود ابتدا یک دیتابیس برای نگهداری واگذاری آدرس های IP ایجاد و دسترسی FTP به آن را میسر نمایید:

Router(config)# ip dhcp database ftp://user:password@172.16.1.1/router-dhcp timeout 80

جلوگیری از اعطای آدرس های 100 تا 103:

Router(config)# ip dhcp excluded-address 172.16.1.100 172.16.1.103
Router(config)# ip dhcp pool 1
Router(dhcp-config)# utilization mark high 80 log
Router(dhcp-config)# network 172.16.0.0 /16
Router(dhcp-config)# domain-name rootlan #domain name
Router(dhcp-config)# dns server 217.218.127.127 217.218.155.155 #dci dns servers
Router(dhcp-config)# default-router 172.16.1.100 172.16.1.101 #this is the Gateway address
Router(dhcp-config)# option 19 hex 01 #additional dhcp option code for example tftp address
Router(dhcp-config)# lease 30 # the lease amount

بدین ترتیب امکان استفاده از امکانات DHCP بر روی روتر و سوئیچ های سیسکو میسر میگردد البته امکانات پیشرفته تری نیز وجود داره که در صورت نیاز میتوانید از آنها استفاده کنید لازم به توضیح است استفاده از سرویس DHCP بر روی شبکه های VLAN که دارای Access Switch و Core Switch هستند بر روی سوئیچ های لایه دسترسی توصیه میشود.

اگر به هر دلیلی مایل به استفاده از دیتابیس جهت ثبت واگذاری IP نبودید میتوانید از این کامند استفاده نمایید:

Router(config)# no ip dhcp conflict logging

توسط این دستور میتوانید میزان استفاده از منابع IP را مشاهده کنید:

Router(config)# ip dhcp use class

راه اندازی DHCP بر روی سوئیچ سیسکو

شاید این موارد نیز مورد علاقه شما باشد:

پیاده سازی پروتکل مسیریابی RIP

آسیب‌پذیری پروتکل UPnP در برابر حملات DDOS

پروتکل OSPF

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش پیکربندی پروتکلهای بردار فاصله

پروتکل های مسیریابی Classful vs Classless

پروتکل ISL انحصاری شرکت سیسکو

تغییر firmware تلفن های سیسکو

مفهوم SDN

راه اندازی DHCP بر روی سوئیچ سیسکو

حمله بدافزار VPNFilter به کاربران و شبکه های کامپیوتری

حمله بدافزار VPNFilter به کاربران و شبکه های کامپیوتری

حمله بدافزار VPNFilter به کاربران و شبکه های کامپیوتری

VPNFilter یک بدافزار طراحی شده برای آلوده کردن روترها است. تا تاریخ 24 ماه مه 2018 چنین تخمین زده میشود که این بد افزار حدود 500000 تا 1000000 دستگاه روتر را آلوده کرده باشد. این بد افزار قابلیت سرقت اطلاعات را برای مجریان حمله فراهم کرده، و همچنین با داشتن قابلیت کلید مرگ یا (kill switch) این امکان را به شخص حمله کننده میدهد که دستگاه روتر را از کار انداخته و غیر قابل استفاده نماید. پلیس فدرال آمریکا این احتمال را میدهد که این بدافزار توسط گروه حملات سایبری (Fancy Bear (Pawn Storm ایجاد و گسترش داده شده باشد.

بررسی بدافزار VPNFilter نشان میدهد که قابلیت آلوده سازی روترهای صنعتی و همچنین روترهای خانگی و اداری تولید شده توسط شرکتهای Linksys، MikroTik، Netgear، و TP-Link را دارا میباشد.

حذف بدافزار VPNFilter

FBI به کاربران قربانی VPNFilter پیشنهاد کرد که برای حذف این بدافزار، روترهای خود را ری‌ست کنند.

به گزارش افتانا (پایگاه خبری امنیت فناوری اطلاعات)، در پی تحقیقات در مورد بدافزار VPNFILTER که صدها هزار روتر را در سراسر دنیا آلوده کرده‌است، FBI به همه‌ مشتریان و مدیران شرکت‌ها هشدار داد که روترهای خود را ری‌ست کنند تا این بدافزار حذف شود.

VPNFilter می‌تواند روترهای خانگی و شرکت‌های کوچک را به‌طور کامل از کار بیندازد. درضمن این بدافزار می‌تواند از طریق روتر اطلاعات کاربر را بدزدد. به بیان دیگر این بدافزار می‌تواند جاسوسی شما را بکند و یا به‌طور کامل روتر شما را خراب کند. هنوز معلوم نیست که هدف پشت VPNFilter چیست و یا چه کسی آن را ساخته اما FBI گفته که در حال تلاش برای نابودی آن است.

بدافزار VPNFilter

هنوز چیزهای بسیار زیادی درمورد بدافزار VPNFilter نمی‌دانیم. به گفته تیم امنیتی سیسکو، بیش از 500هزار روتر در 54 کشور دنیا آلوده شده‌اند که بیشتر آنها در اوکراین هستند.

دستگاه‌های آلوده‌ شناسایی شده به شرح زیر هستند:

• Linksys E1200
• Linksys E2500
• Linksys WRVS4400N
• Netgear DGN2200
• Netgear R6400
• Netgear R7000
• Netgear R8000
• Netgear WNR1000
• Netgear WNR2000
• QNAP TS251
• QNAP TS439 Pro
• TP-Link R600VPN

هنوز مشخص نیست که چقدر از این دستگاه‌ها دقیقاً در آمریکا، استرالیا، انگلیس، ایران، اکراین و یا هرجای دیگری هستند، اما FBI توصیه کرد که هرکسی که یک روتر در خانه دارد آن را ریبوت کند. البته این توصیه در هر شرایطی خوب و مهم است درنتیجه ارزش آن را دارد که چند دقیقه در یک روز را برای آن وقت بگذارید.

FBI همچنین توصیه کرد که روتر خود را آپدیت کرده و جدیدترین پچ‌های امنیتی سفت‌افزاری را دریافت کنید و رمز خود را نیز تغییر دهید. حتی اگر روتر شما آلوده نیست نیز این کار را انجام دهید.

 

منبع خبر: افتانا (پایگاه خبری امنیت فناوری اطلاعات)

پروتکل OSPF

پروتکل OSPF

پروتکل OSPF

پروتکل OSPF :پروتکل مسیریابی OSPF پروتکل قدرتمند و پرطرفداری است که در RFC 2328 شرح داده شده است. این پروتکل برای پیدا کردن Neighbor یا در واقع روترهای متصل به خود  از Hello Message استفاده میکند. پیام Hello به آدرس Multicast 224.0.0.5)AllSPFRouters) ارسال میگردد اگر در رسانه ای خاص Multicast قابل استفاده نباشد، از Unicast استفاده میکند (در این حالت آدرس همسایه باید از قبل تنظیم شده باشد).

آشنایی با پروتکل OSPF

پروتکل مسیریابی Open Shortest Path First که به اختصار OSPF نامیده می شود یک پروتکل مسیریابی Link state است که میتواند ترافیک های مربوط به پروتکل IP را مدیریت کند. پروتکل OSPF نسخه های مختلفی دارد که در حال حاضر از نسخه ۲ آن بیشتراستفاده می شود.OSPF بصورت انحصاری توسط شرکت ها ارائه میشوند و یک پروتکل کاملا جامع و بدون وابستگی به هیچ برند خاصی است ، تقریبا همه روترهایی که در دنیا وجود دارند از پروتکل OSPF پشتیبانی می کنند.

پروتکل مسیریابی Open Shortest Path First یا پروتکل OSPF از الگوریتم Shortest Path First یا SPF که توسط Dijkstra طراحی شده است برای جلوگیری از به وجود آمدن Routing Loop در توپولوژی شبکه ها استفاده می کند و به نوع یک شبکه Loop Free ایجاد می کند. پروتکل OSPF فرآیند Convergence سریعی دارد و از طرفی قابلیت Incremental Update را نیز با استفاده ازLSA یا Link State Advertisement فراهم می کند. پروتکل مسیریابی OSPF یک پروتکل Classless است و به شما این اجازه را می دهد که برای طراحی یک ساختار سلسله مراتبی شبکه از VLSM و Route Summarization به راحتی استفاده کنید.

معرفی پروتکل OSPF

معرفی پروتکل OSPF

معایب پروتکل OSPF

مهمترین معایبی که در پروتکل OSPF وجود دارد این است که OSPF برای نگهداری لیست OSPF Neighbor ها ، توپوپولوژی شبکه که شامل یک دیتابیس از تمامی روترها و Route های موجود در آنهاست و همچنین Routing Table خود روتر به حافظه RAM نسبتا بیشتری در مقایسه با پروتکل های Distance Vector نیاز دارد.همچنین پروتکل OSPF به قدرت پردازشی یا CPU بیشتری برای اجرا کردن الگوریتم SPF نیاز دارد و همین موارد باعث می شود که OSPF در رده بندی پروتکل های مسیریابی پیچیده یا Complex Protocol قرار بگیرد. دو مفهوم بسیار مهم در مواردی که می خواهید از پروتکل OSPF استفاده کنید وجود دارند که اولین مفهوم Autonomous System و دومین مفهوم Area می باشد.

تنظیمات اولیه در OSPF

Area در OSPF برای ایجادکردن ساختارمسیریابی سلسله مراتبی یا موثری(Hierarchical Routing)در یک Autonomous System استفاده میشود. Area ها تعیین کننده این هستندکه چگونه وبه چه اندازه اطلاعات مربوط بهRoutingبایستی درشبکه به اشتراک گذاشته شود. OSPF دولایه وراثت یاHierarchyدارد،لایهBackboneیاArea 0 ولایه های خارج ازBackboneیاAreaهای بین عدد۱تا۶۵۵۳۵،این دوAreaای متفاوت هستندکه میتوان دربین آنهااطلاعات مسیریابی راSummarizeکرد. RouteSummarizationبه ما کمک میکندکه بتوانیم Routing Tableهای خودرافشرده سازی وکوچکترکنیم.تمامی Areaها بایستی بهArea 0متصل شوندوتمامی روترهادراینAreaازیک توپولوژی یکسان استفاده میکنند.

 

 

سایر مطالب مرتبط با یان مقاله:

آموزش مفاهیم مسیریابی

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش پیکربندی پروتکلهای بردار فاصله

 

آشنایی با سوئیچ سیسکو

آشنایی با سوئیچ سیسکو

آشنایی با سوئیچ سیسکو

به طور معمول در شبکه دستگاه های مختلف و متنوعی وجود دارد که با توجه به ماهیت عملیاتی خود، یک سری عملیات خاص را انجام میدهند. از جمله سخت افزارهایی که میتوان به آنها اشاره کرد عبارت اند از روترها، سوئیچ ها، هاب ها و تقویت کننده هاست.

در این مقاله قصد داریم تا با جزئیات بیشتر از سخت افزارهای سوئیچ و روتر آشنا شوید.

سوئیچ ها دستگاه هایی هستند که قادر به پردازش فریم های لایه دوم بوده و بین دستگاه های متصل شده به سوئیچ یک ارتباط 1 به 1 ایجاد میکند. این ارتباط میتواند به صورت Full-Duplex یا Half-Duplex صورت پذیرد. از لحاظ قدرت پردازش و انتقال فریم، سوئیچ ها در کلاس های متفاوتی قرار میگیرند. که بسته به نوع نیاز باید سوئیچی انتخاب شود تا علاوه بر مقرون به صرفه بودن کارآیی موردنیاز در شبکه را فراهم آورد.

 

لینک دانلود: معرفی سوئیچ سیسکو

فرمت: PDF

حجم: 2.52 MB

 

فصل دوم مدیریت سوئیچ و روتر سیسکو

فصل سوم آموزش اولیه مفاهیم پل ها و سوئیچ های سیسکو

فصل چهارم آموزش پیکربندی VLAN سوئیچ سیسکو

فصل پنجم آموزش مفاهیم مسیریابی

فصل ششم آموزش پیکربندی پروتکلهای بردار فاصله

فصل هفتم آموزش پیکربندی پروتکل های مسیریابی پیشرفته

راه اندازی SSH

راه اندازی SSH در سوئیچ ها و روتر های سیسکو

راه اندازی SSH در Cisco

در اکثر مواقع شما بعد از پیکربندی Router یا Switch خود نیاز به این دارید که از راه دور به دستگاه دسترسی داشته باشید تا در صورت نیاز جهت پیکربندی یا رفع عیب به دستگاه متصل شوید. مثلا در نظر بگیرید که شما یک یا چند Device را در سطح یک شهر یا کشور پیکربندی کرده اید و پس از این کار باید به مشترکین خود خدمات پشتیبانی ارائه دهید . در صورتی که از راه دور دسترسی به این دستگاه ها نداشته باشید ، هنگامی که نیاز به ایجاد تغییر در پیکربندی دستگاه یا رفع عیب باشید باید جهت دسترسی به دستگاه مسیر زیادی را طی کنید که این مستلزم وقت و هزینه زیاد خواهد بود.

جهت حل این مشکل سیسکو از پروتکل هایی نظیر Telnet و SSH استفاده می کند. که پروتکل SSH ایمن تر از Telnet می باشد .

راه اندازی SSH :

جهت تنظیم روتر و یا کنترل آن و سوئیج های سیسکو نیاز به پروتکل هایی از قبیل Telnetداریم . این پروتکل بیشترین استفاده را دارد ولی باید ایراد عمده  آن را هم در نظر گرفت .  این نقص به یک نیروی خارجی اجازه دسترسی پیدا کردن به اطلاعاتی که بین شبکه و دستگاه مدیریت رد و بدل میشود را میدهد .  Telnet در انتقال اطلاعات به صورت Clear-Text   عمل میکند.  بدین ترتیب که حتی کلمه عبور و تنظیمات سوئیچ و روتر به طور کامل قابل شنود و دسترسی است .

البته برطرف کردن این مشکل راه حلی دارد و آن استفاد از پروتکل  SSH یا Secure Shell است که اطلاعات را به صورت کد شده میان سرور و کلاینت رد و بدل میکند. . تنظیمات روتر و سوئیچ با استفاده از  Public Key  و Private Key  انجام میشوند .

تفاوت ها و شباهت های Telnet و SSH

۱٫ هر دوی پروتکل ها به صورت مشترک یک هدف را دنبال می کنند .

۲٫ SSH در مقایسه با Telnet بسیار ایمن تر است .

۳٫ SSH هنگام انتقال ترافیک ابتدا ترافیک را رمزنگاری می کند سپس ترافیک را ارسال می کند اما Telnet ترافیک را به همان شکل اصلی خود یا اصطلاحا Plane Text ارسال می کند که در صورتی که هکر ترافیک ارسالی بین مبدا و مقصد را دریافت کند می تواند این اطلاعات را به راحتی بخواند.

۴٫ SSH قادر است جهت عملیات تشخیص هویت از Public Key استفاده کند ولی Telnet این امکان را ندارد .

شکل رمز نگاری شده اطلاعات که توسط پروتکل SSH ارسال شده

SSH---Session

SSH—Session

 

استفاده از پروتکل Telnet و عدم رمزنگاری اطلاعات

Telnet---session

Telnet—session

راه اندازی SSH :

قبل از راه اندازی SSH می بایست از نسخه IOS ، سیستم عامل روتر و سوئیچ های سیسکو ، اطمینان حاصل کنید. در واقع، IOS می بایست سیستم Encryption مورد نیاز SSH را پشتیبانی کند. اگر“K9” در اسم فایل IOS  موجود باشد، شما قادر به راه اندازی SSH  می باشید.

برای کنترل نسخه IOS مورد استفاده بروی روتر یا سوئیچ از دستور  show version# استفاده کنید.

Press RETURN to get started.
Router>enable
Router#show version
Cisco IOS Software, 1841 Software (C1841-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.

۱- -تنظیم Hostname روی Router یا Switch سیسکو (Hostname اسم دستگاه شما)

Press RETURN to get started.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname RootLan
RootLan(config)#

۲-تعیین یک Domain Name برای اتصالات SSH (domain name نام دامین یا مجموعه شما خواهد بود)

Press RETURN to get started.
RootLan>enable
RootLan#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RootLan(config)#ip domain-name RootLan.com
RootLan(config)#

۳-تعیین IP Address برای دسترسی از راه دور به ورتر یا سوئیچ سیسکو

حالا اگر از روتر استفاده می کنید باید به یکی از پورت های شبکه اترنت IP بدهید اما اگر از سوییچ استفاده می کنید چون سوئیچ یک دستگاه لایه ۲ ای می باشد و IP لایه ۳ است، باید یک اینترفیس مجازی Interface Vlan بسازیم و به آن IP تخصیص دهیم.

Press RETURN to get started.
RootLan>enable
RootLan#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
rootlan(config)#interface vlan 1
rootlan(config-if)#ip address 192.168.1.1 255.255.255.0
rootlan(config-if)#no shutdown
rootlan(config-if)#
%LINK-5-CHANGED: Interface Vlan1, changed state to up

۴ -تعیین کلیدهای Crypto Key برای رمزنگاری اطلاعات در پروتکل SSH

(از آنجایی که SSH داده های ارسالی را رمزنگاری میکند نیاز است تا یک کلید (RSA Key) برای این کار تولید کنیم)
SSH برای Encrypt کردن ارتباط نیاز به یک کلید دارد. این کلید بوسیله روتر یا سوئیچ شما تولید و استفاده می شود. برای این کار می توانید از دستور crypto key generate rsa استفاده کنید. طول  کلید  تولید  شده  می تواند از ۳۶۰ تا۴۰۹۶  بیت متغیر باشد. هر چه طول کلید بیشتر باشد، امنیت بالاتر ولی Load بروی دستگاه بیشتر خواهد بود. به صورت پیش فرض ۵۱۲ بیت انتخاب می شود.مقدار ۵۱۲ طول پیشفرض کلید شماست، اگر امنیت بیشتری میخواهید از ۱۰۲۴ یا حتی مقدار بیشتری استفاده کنید. اگر ۵۱۲ انتخاب شماست کافی است اینتر را بزنید.

Press RETURN to get started.
RootLan>enable
RootLan#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RootLan(config)#crypto key generate rsa
The name for the keys will be: RootLan.rootlan.com
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.
How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable…[OK]
RootLan(config)#
 ۵-تعریف یک کاربر و کلمه عبور به صورت Local
بر روی Router یا Switchبرای راه اندازی SSH نیاز  به  ساختن  یک User Account  بروی  روتر یا سوئیچ  دارید. برای این کار می توانید از دستور username در IOS سیسکو استفاده کنید.
Press RETURN to get started.
RootLan>enable
RootLan#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RootLan(config)#username rootlan password cisco
RootLan(config)#exit

۶-فعال کردن SSH و Telnet بر روی پورت های VTY

لاین VTY در واقع درگاه مجازی برای ارتباطات مدیریتی روتر یا سوئیچ می باشد و Authentication جهت اتصال را به Local Database روتر یا سوئیچ که یک User Account بروی آن ساختید ارجاء دهید.

Press RETURN to get started.
RootLan>enable
RootLan#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RootLan(config)#line vty 0 15
RootLan(config-line)#login local
RootLan(config-line)#
RootLan#

 ۷-تعیین نسخه ۲ پروتکل SSH
راه اندازی SSH بروی روتر یا سوئیچ، برای بالا بردن امنیت لازم است که نسخه SSH را به نسخه ۲ ارتقاء دهیم. برای ارتقاء نسخه SSH میتوان از دستور IP SSH Version 2 استفاده کرد. لازم به ذکر است برای راه اندازی نسخه ۲ SSH حداقل طول کلید را باید ۷۶۸ بیت انتخاب کرده باشید.

Press RETURN to get started.
RootLan>enable
RootLan#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RootLan(config)#ip ssh version 2
RootLan(config)#

حال شما میتوانید از کامپیوتر مورد نظر در داخل شبکه به سوئیچ یا روتر کانفیگ شده خود توسط دستور زیر SSH بزنید . وارد محیط  Command Prompt میشوید و ابتدا IP که به سویچ و یا روتر اختصاص دادیم را PING میکنیم در صورت امکان PING موفق با دستور زیر به روتر و یا سوئیچ مورد تظر SSH میزنیم .

PC>ssh -l rootlan 192.168.1.1

Open

Password: cisco

rootlan#

آموزش استاندارد ۸۰۲٫۱Q IEEE در سوئیچ های سیسکو

آموزش دستورات تنظیمات روتر و سوئیچ سیسکو

آموزش پرتکل مسیریابی BGP