نوشته‌ها

رفع آسیب پذیری های جدید سیسکو

رفع آسیب پذیری های جدید سیسکو

رفع آسیب پذیری های جدید سیسکو : سیسکو برای ۱۷ آسیب‌ پذیری جدید در محصولاتش وصله عرضه کرد.

سیسکو اواسط ماه اکتبر ۱۷ آسیب‌ پذیری را اصلاح کرده‌است که یک مورد از این آسیب‌ پذیری‌ها بحرانی و ۸ مورد آن دارای درجه حساسیت بالا است.

سایر آسیب‌ پذیری‌ها دارای درجه حساسیت متوسط هستند.

جزئیات این آسیب‌ پذیری‌ها در جدول زیر ارائه شده‌است:

 

cisco1

cisco1

cisco2

cisco2

cisco3

cisco3

رفع آسیب پذیری های جدید سیسکو

منبع خبر : پایگاه خبری امنیت فناوری اطلاعات

فروشگاه سوئیچ سیسکو

سیسکو درباره آسیب‌پذیری بحرانی در سیستم ها هشدار داد

امنیت VLAN و Trunk در سوئیچ های سیسکو

آموزش روش های ایمن سازی تجهیزات سیسکو

تعویض پورت پیش فرض تلنت در روتر سیسکو

پیشگیری از حملات IKE CRYPTO در سیستم عامل سیسکو

کانفیگ Port Security سوئیچ سیسکو

 

آموزش سیسکو Cisco قسمت پنجم

آموزش سیسکو Cisco قسمت پنجم

آموزش سیسکو Cisco قسمت پنجم

در جلسه قبل به طور کامل با rip اشنا شدیم، در این جلسه پیاده سازی آن را انجام میدهیم . از همان شکل سناریو ip static استفاده میکنیم.

آموزش سیسکو

مرحله اول تنظیمات روتر 1 و 2

اینترفیس fast ethernet 0/0 روتر 1
router1# config t
router1(config)#interface fast 0/0
router1(config-if)# ip address 192.168.14.1 255.255.255.0
router1 (config-if)# no shutdown
اینترفیس serial0/1/0 روتر 1
router1# config t
router1(config)#interface serial 0/1/0
router1(config-if)# ip address 192.168.15.1 255.255.255.0
router1 (config-if)# no shutdown

روتر دوم هم به همین صورت تنطیم میکنم . با توجه به ip address هایی که در شکل است . با دستورات بالا ما به اینترفیس ها ای پی دادیم.

پیکربندی rip
برای وارد کردن دستورات rip باید ابتدا به مد configuration روتر برویم و با دستور router rip وارد مد rip شده و شبکه ایی که مستقیم به اینترفیس های روتر 1 متصل هستند یا به عبارت دیگه شبکه هایی که در داخل جدول مسیر یابی روتر به عنوان شبکه های connected شناسایی و تشخیص داده میشوند را در مقابل دستور network وارد کنیم . شکل دستورات به صورت زیر است:

پیکربندی روتر 1

router1 # config t
router1 (config)# router rip

این دستور باعث فعال شدن پروتکل rip بر روی router میشود.

router1 ( config-router)# network 192.168.14.0

این دستور باعث میشود که شبکه 192.168.14.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل rip به روتر های همسایه اعلام بشود.

router1 ( config-router)# network 192.168.15.0

 

این دستور باعث میشود که شبکه 192.168.15.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل rip به روتر های همسایه اعلام بشود.

router1#copy running- config startup-config

این دستور باعث میشود اطلاعات ما ذخیره شود.

پیکربندی روتر 2

router2 # config t
router2(config)# router rip

این دستور باعث فعال شدن پروتکل rip بر روی router میشود.

router2 ( config-router)# network 192.168.16.0

این دستور باعث میشود که شبکه 192.168.16.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل rip به روتر های همسایه اعلام بشود.

router2 ( config-router)# network 192.168.15.0

این دستور باعث میشود که شبکه 192.168.15.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکلrip به روتر های همسایه اعلام بشود.

router2#copy running- config startup-config

این دستور باعث میشود اطلاعات ما ذخیره شود.
بعد از انجام کار های بالا rip بر روی هر دو روتر پیکر بندی شد . برای مشاهده جدول مسیر یابی روتر ها از دستور زیر استفاده میشود:

 rourer1# show ip route

بعد از اینکه با rip اشنا شدیم حالا میرسیم به محبوب ترین پروتکل مسیر یابی در سیسکو:

eigrp:مخفف

enhance interior gateway routing protcol
پروتکل eigrp پروتکل اختصاصی سیسکو است . شرکت سیسکو همه توانمندی های محبوب پروتکل های linkstate و distance vector را در این پروتکل قرار داده و آن را به صورت یک پروتکل اختصاصی ارائه داده .
این پروتکل قادر به فعالیت در شبکه های بزرگ و گسترده است و یکی از محبوب های این پروتکل پیکربندی و مدیریت ساده آن است.
این پروتکل یک پروتکل classless است و قادر به پشتیبانی از توانمندی vlsm است و از پیامهای multicast برای update جدول مسیریابی استفاده میکند.
این پروتکل برای محاسبه metric و انتخاب بهترین مسیر از پارامتر های bandwigth و delay استفاده میکند.
در eigrp نیاز به تعریف یک شماره به نام as یا autonomous system میباشد که این شماره بابد در کل روتر های یک شبکه که پروتکل eigrp بر روی آنها تعریف میشود یکسان باشد.
بعداز توضیحات مختصر در مورد eigrp پیکربندی را با توجه به شکل زیر آغاز میکنیم

آموزش سیسکو

مرحله اول تنظیمات روتر 1 و 2
اینترفیس fast ethernet 0/0 روتر 1

router1# config t
router1(config)#interface fast 0/0
router1(config-if)# ip address 192.168.2.1 255.255.255.0
router1 (config-if)# no shutdown
اینترفیس serial0/0/0 روتر 1
router1# config t
router1(config)#interface serial 0/0/0
router1(config-if)# ip address 192.168.0.1 255.255.255.0
router1 (config-if)# no shutdown

روتر 2

اینترفیس fast ethernet 0/0 روتر 2
router2# config t
router2(config)#interface fast 0/0
router2(config-if)# ip address 192.168.3.1 255.255.255.0
router2 (config-if)# no shutdown
اینترفیس serial0/0/0 روتر 2
router2# config t
router2(config)#interface serial 0/0/0
router2(config-if)# ip address 192.168.0.2 255.255.255.0
router1 (config-if)# no shutdown

اینترفیس0/1/serial0 روتر 2

router2# config t

router2(config)#interface serial0/0/1

router2(config-if)# ip address 192.168.1.1 255.255.255.0

router2 (config-if)# no shutdown

همانطور که در شکل میبینید روتر دو دارای سه اینترفیس هست پس هر 3 اینترفیس باید ip address بگیرند.

روتر3

اینترفیس fast ethernet 0/0 روتر 3
router3# config t
router1(config)#interface fast 0/0
router3(config-if)# ip address 192.168.4.1 255.255.255.0
router1 (config-if)# no shutdown
اینترفیس1/serial0/0 روتر 3
router1# config t
router1(config)#interface serial 0/0/1
router1(config-if)# ip address 192.168.1.2 255.255.255.0
router1 (config-if)# no shutdown

در تنظیمات eigrp شما باید شبکه هایی که مستقیما به اینترفیس روتر 1 متصل می باشند یا به عبارتی شبکه هایی که در داخل جدول مسیریابی روتر 1 به عنوان شبکه connected شناسایی و تشخیص داده میشوند در routing mode در مقابل network نوشته میشوند تنظیمات در دستورات زیر نشان داده شده:
تنظیم eigrp در روتر 1

 router1#config t
router1 (config)# router eigrp 100

فعال کردن پروتکل eigrp روی روتر و تعیین شماره به عنوان as

 router1 (config-router)# network 192.168.0.0

این دستور باعث میشود شبکه 192.168.0.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیع شود.

router1 (config-router)# network 192.168.2.0

این دستور باعث میشود شبکه 192.168.2.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیغ شود.

تنظیم eigrp در روتر 2

 router2#config t

router2 (config)# router eigrp 100

فعال کردن پروتکل eigrp روی روتر و تعیین شماره به عنوان as

 router2 (config-router)# network 192.168.1.0

این دستور باعث میشود شبکه 192.168.1.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیع شود.

router2 (config-router)# network 192.168.3.0

این دستور باعث میشود شبکه 192.168.3.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیغ شود.

تنظیم eigrp در روتر 3

 router3#config t

router3(config)# router eigrp 100

فعال کردن پروتکل eigrp روی روتر و تعیین شماره به عنوان as

 router3(config-router)# network 192.168.1.0

این دستور باعث میشود شبکه 192.168.1.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیع شود.

router3 (config-router)# network 192.168.4.0

این دستور باعث میشود شبکه 192.168.4.0 که به صورت مستقیم به روتر متصل میباشد توسط پروتکل به روتر های همسایه تبلیغ شود.
همانطور که در تنظیمات مشاهده میکنید مقدار as برای روتر1 . روتر 2 . روتر 3 شماره 100 است که در هر سه روتر این عدد مشترک است.

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت سوم

آموزش سیسکو Cisco قسمت چهارم

آموزش سیسکو Cisco قسمت پنجم

منبع : ilikephp

آموزش سیسکو Cisco قسمت چهارم

آموزش سیسکو Cisco قسمت چهارم

آموزش سیسکو Cisco قسمت چهارم

با سلام خدمت دوستان . جلسه چهارم آموزش CCNA را آغاز میکنیم.
در این جلسه با static routes و dynamic اشنا میشویم.
به صورت خلاصه اگر بخواهم routing را تشریح کنم . به پروسه انتقال packet از یک شبکه به شبکه دیگر با استفاده از router و تجهیزات لایه 3 را routing میگویند.
روتر ها برای اینکه بتوانند به صورت صحیح در شبکه وظایف مسیریابی و برقراری ارتباط بین شبکه ها را انجام دهند قبل از استفاده باید تنظیم شوند و جدول مسیریابی routing table بر روی روتر ایجاد شود. وجود این جدول برای مسیریابی مورد نیاز است . روتر تصمیمات مسیریابی خودش را بر اساس این جدول اتخاذ میکند . به نوعی دیگر هر روتر در جدول مسیریابی خودش باید از وجود همه شبکه هایی که قصد مسیریابی و ارتباط با آنها را دارد اصلاع داشته باشد.
جدول مسیریابی یا routing table در روتر به دو صورت است:
1- صورت static route
2 – به صورت dynamic routing
برای پیکربندی جدول مسیر یابی router به صورت static مدیر شبکه باید از اطلاعات مربوط به شبکه های موجود و مسیرهای آنها مطلع باشد و به صورت دستی مسیرها و شبکه ها را در درون این جدول اضافه نماید . این روش مزایا و معایبی دارد:
مزایای استفاده :
– این روش بار اضافی یا overhead برای cpu روتر نخواهد داشت.
– این روش پهنای باند لینک های ارتباطی بین روتر ها را برای update جدول های مسیریابی اشغال و مورد استفاده قرار نمیدهد.
– امنیت این روش بالاتر است.

معایب استفاده از این روش :
– برای پیکربندی static route باید به همه مسیرهای داخلی آشنایی کامل داشته باشید.
– اگر یک مسیر داخلی شما اضافه شود باید به صورت دستی روی همه روتر ها تعریف شود.
– در صورتی که مسیری دچار مشکل شود امکان استفاده از مسیر های دیگر به صورت داینامیک نیست.
در اینجا با یک مثال static route را پیاده سازی میکنیم.
آموزش سیسکو

مرحله اول تنظیمات روتر اول و روتر دوم و تنظیم ip address

اینترفیس fast ethernet 0 روتر 1
 router1# config t
 router (config)# interface fastethernet 0
 router1 (config-if)#ip address 192.168.14.1 255.255.255.0
 router (config-if)# no shut
 اینترفیس0/1/0 serial روتر 1

router1# config t
 router (config)# interface serial 0/1/ 0
 router1 (config-if)#ip address 192.168.15.1 255.255.255.0
 router (config-if)# no shut
 اینترفیس fast ethernet 0 روتر 2
 router2# config t
 router2 (config)# interface fastethernet 0
 router1 (config-if)#ip address 192.168.16.1 255.255.255.0
 router2 (config-if)# no shut
 اینترفیس 0/1/0 serial روتر 2

router2# config t
 router (config)# interface serial 0/1/ 0
 router2 (config-if)#ip address 192.168.16.1 255.255.255.0
 router 2 (config-if)# no shut

همانطور که قبلا گفتیم روتر ها بر اساس جدول مسیر یابی یا routing table اقدام به مسیر یابی و عبور بسته های اطلاعاتی میکنند. و بر اساس همین جدول تصمیم میگیرند که packet را از طریق کدام اینترفیس خود خارج کنند .
برای مشاهده جدول مسیر یابی یا routing table از دستور زیر استفاده میشود، این دستور را ابتدا در روتر یک وارد میکنیم.

router#show ip route

با استفاده از این جدول مسیر یابی روتر مشاهده میشود.
بعد از وارد کردن دستور بالا مشاهده میکنیم که در این جدول خبری از شبکه روتر دوم نیست. به عبارت دیگر هنوز شبکه روتر دوم شناسایی نشده است . برای اینکار ما باید این مسیر را به صورت دستی یا static وارد کنیم، که روتر ها از وجود این شبکه مطلع شوند و آن را در جدول مسیر یابی خود وارد کنند.
برای اینکار بر روی روتر 1 باید مسیر 192.168.16.0 را که به صورت مستقیم به روتر 2 متصل است را به صورت دستی برای روتر 1 تعریف نماییم.

router 1 (config)# ip route 192.168.16.0 255.255.255.0 192.168.15.2

در دستور بالا 192.168.16.0 شبکه راه دور هست که به صورت مستقیم به روتر 2 وصل شده .
در واقع با استفاده از دستور بالا روتر یک متوجه میشود که هر بسته اطلاعاتی که مقصد آن شبکه 192.168.16.0 است باید آن را به آدرس اینترفیس 192.168.15.2 که اینترفیس روتر 2 است هدایت کند.
و در روتر 2 نیز همین دستور را به صورت زیر وارد میکنیم:

router 2(config)# ip route 192.168.14.0 255.255.255.0 192.168.15.1

بعد از این کار میتوانیم جدول مسیر یابی درون هر دو روتر را مشاهده کنیم و ببینیم که هر دو شبکه شناسایی شده اند.

router1(config)#show ip route

حالا که با route static آشنا شدیم و نحوه ی پیاده سازی آن را دیدیم، در این قسمت با پروتکل های مسیر یابی داینامیک آشنا میشویم . و در این جلسه با پروتکل rip بیشتر آشنا میشویم.
پروتکل های مسیریابی داینامیک مثلrip , igrp, eigrp, ospf و غیره این توانایی را به روتر ها خواهند داد که به صورت dynamic جدول مسیریابی ها بین روتر های موجود در یک شبکه داخلی مبادله شود و مسیر های اضافه و جدول مسیریابی خود را با ارسال update ها بین یکدیگر به روزرسانی کنند.
برای استفاده از مسیر یابی به صورت داینامیک شما باید این پروتکل ها را روی روتر پیکربندی کنید . بعد از تنظیم این پروتکل ها روتر با روتر همسایه ارتباط بر قرار کرده و جدول های مسیر یابی را بین یکدیگر مبادله میکنند.

(routing information protocol (rip

این پروتکل دارای دو نسخه با توانمندی های مختلف است هر دو از الگوریتم مسیر یابی distance vector استفاده میکنند.

rip version 1
 rip version 2

rip version 1
این پروتکل جهت update کردن جدول مسیریابی بین روترهای شبکه از پیام های brodcast استفاده میکند که هر 30 ثانیه یکبار کل جدول مسیر یابی را از طریق اینترفیس های فعال منتشر میکند و metric در این پروتکل بر اساس hop count محاسبه میشه و این پروتکل محدودیت 15 hopcount را دارد.
rip version 2
این پروتکل هم از نوع distance vector است اما پیشرفته از ورژن 1.
این پروتکل از multicasting به جای broadcast استفاده میکند.
این پروتکل از احراز هویت پشتیبانی میکند که باعث میشود روتر ها قبل از update جدول مسیریابی و رد و بدل کردن جدول های یکدیگر را احراز هویت کنند.
metric
ممکن است در شبکه شما برای رسیدن به یک شبکه چندین مسیر یا لینک وجود داشته باشد در این وضعیت از واحدی به نام متریک (metric) برای انتخاب بهترین مسیر استفاده میشود . هر پروتکل مسیر یابی به یک شکل و فرم metric را محاسبه میکند از نظر rip بهترین مسیر مسیری است که دارای کمترین تعداد روتر یا hop های کمتری باشد . با توجه به شکل زیر برای دسترسی به شبکه e ازطریق شبکه a چندین مسیر استفاده میشود .

آموزش سیسکو

همانطور که در شکل بالا مشاهده میکنید دو مسیر برای رسیدن شبکه e وجود دارد اما با توجه به تعریف metric در rip مسیری که دارای کمترین hop یا روتر در مسیر است بهترین مسیر برای رسیدن به مقصد است . در نتیجه مسیر بالا در جدول مسیر یابی نمایش داده میشود

در اینجا جلسه چهارم به پایان میرسد در جلسه بعدی نحوی پیاده سازی rip را با هم مرور خواهیم کرد.

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت سوم

آموزش سیسکو Cisco قسمت چهارم

آموزش سیسکو Cisco قسمت پنجم

منبع : ilikephp

مدارک سیسکو

مدارک سیسکو

مدارک سیسکو :

سیسکو در 156 کشور دنیا، به منظور تعلیم افراد برای طراحی و نگهداری شبکه های کامپیوتری، مرکزهای آموزشی تأسیس کرده است. سیسکو مدارکی را برای متخصصین در زمینه های مختلف شبکه ارائه میکند که شامل این مدارک میشود:

دسته ی اول  (دستیار یا کارشناس شبکه)

 Associate یا دستیار، یعنی قرار گرفتن در ابتدای مسیر.گرایش شما هرچه که باشد میبایست پیش از اخذ هر مدرک و یا گذراندن هر دوره ای، CCNA با گرایش Routing&Switching را بگذرانید! بعدازآن چنانچه

خواستارتغییرگرایش از Routing&Switching به سایرگرایشها باشید، میبایست مدرک Associate آن گرایش را نیز اخذ کنید، مثلاً چنانچه به Security علاقه مند هستید، باید مدرک CCNA با گرایش Security را کسب کرده و سپس به سطح بالاتر یعنی Professional صعود نمود.

Associate Certifications

CCNA Routing and Switching •

CCDA •

CCNA Data Center •

CCNA Security •

CCNA Service Provider •

CCNA Service Provider Operations •

CCNA Video •

CCNA Voice •

CCNA Wireless •

دسته ی دوم (کارشناس ارشد شبکه)

Professional Certifications

CCDP •

CCNP •

CCNP Data Center •

CCNP Security •

CCNP Service Provider •

CCNP Service Provider Operations •

CCNP Voice •

CCNP Wireless •

دسته ی سوم (متخصص شبکه یا همان دکترای شبکه)

Expert Certifications

CCDE •

CCIE Collaboration •

CCIE Data Center •

CCIE Routing & Switching •

CCIE Security •

CCIE Service Provider •

CCIE Service Provider Operations •

(CCIE Voice (Retiring February 13, 2014 •

CCIE Wireless •

دسته ی چهارم (معمار شبکه و هم هکاره شبکه)

سطح Architect که در سالها اخیر توسط سیسکو ارائه شده است، بالاترین سطح مدرک مهندسی شبکه در بین کلیه ی مدارک بین المللی شبکه است. ظاهراً شرکت سیسکو با ارائه ی این سطح خواسته تا برترین متخصصان بین المللی شبکه را گلچین نماید، شاید بتوان رتبه ی Cisco Certified Architect معادل فوق دکترای شبکه در گرایش Design دانست !