نوشته‌ها

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو :همانطور که گفته شد پروتکل های مسیریابی به سه دسته Distance Vector و Link State و Hybrid تقسیم بندی می شوند ، در این نکته قصد داریم پروتکل های مسیریابی یا روتینگ Distance Vector که ساده ترین نوع پروتکل های مسیریابی هستند را برای شما تشریح کنیم. همانطور که از نام اینگونه پروتکل ها نیز پیداست از دو فاکتور Distance یا مسافت و Vector یا جهت برای پیدا کردن مقصد استفاده می کنند. روترهایی که از پروتکل های مسیریابی Distance Vector استفاده می کنند به روترهای همسایه یا Neighbor های خود در خصوص توپولوژی شبکه و تغییراتی که در وهله های زمانی متفاوت انجام می شود اطلاع رسانی می کنند ، این اطلاع رسانی با استفاده از Broadcast انجام می شود و از آدرس IP ای به شکل 255.255.255.255 برای اینکار استفاده می کند.

پروتکل های Distance Vector از الگوریتم Bellman-Ford برای پیدا کردن بهترین مسیر برای رسیدن به مقصد استفاده می کنند.

روترهای مورداستفاده درتوپولوژی های Distance Vector برای اینکه ازاطلاعات موجوددرRouting Tableهای روترهای همسایه خودمطلع شوندبررویInterfaceهای خوددرخواست راBroadcastمیکنند.

همچنین این پروتکل ها برای Share کردن اطلاعات Routing Protocol خود نیز از ساختار Broadcasting استفاده می کنند.

معرفی پروتکل های مسیریابی Distance Vector

الگوریتم های Distance Vector تغییراتی که در Routing Table انجام می شود را بلافاصله برای روترهای همسایه خود در همه جهات ( روی همه Interface ) ارسال می کنند. با هر تبادلی که انجام می شود ، روتر Distance Value مربوط به Route دریافت شده را افزایش می دهد و Distance Value خودش را نیز بر روی Route های جدید قرار می دهد. روتری که این تغییرات یا Update ها را دریافت می کند نیز به همین ترتیب Route های خودشان را بر روی این Table قرار می دهند و برای روترهای باقی مانده ارسال می کنند ، این فرآیند به همین شکل ادامه پیدا می کند.

پروتکل های مسیریابی Distance Vector

پروتکل های Distance Vector به این موضوع توجه نمی کنند که چه کسی به Update هایی که ارسال می شوند گوش می کند ، جالب اینجاست بدانید پروتکل های Distance Vector حتی در صورتیکه هیچ تغییری در Routing Protocol خود نداشته باشند نیز بصورت متناوب Routing Table خود را Broadcast می کنند ، یعنی حتی اگر توپولوژی شبکه شما تغییر هم نکرده باشد Broadcasting انجام می شود.

پروتکل های Distance Vector ساده ترین نوع از پروتکل های مسیریابی یا Dynamic Routing هستند که در مجموعه سه تایی که عنوان شد قرار می گیرند. پیاده سازی و رفع ایراد این نوع از پروتکل ها بسیار ساده است ، همچنین روتر برای انجام فرآیند های پردازشی نیاز به منابع بسیار کمتری دارد. منطق کاری Distance Vector ها ساده است ، آنها Routing Update ها را دریافت می کنند ، مقدار Metric را افزایش می دهند ، نتایج را با مقدادیر موجود در Routing Table خود مقایسه می کنند و در صورت نیاز Routing Table را Update می کنند. پروتکل هایی مثل Routing Information Protocol یا RIP نسخه یک و Interior Gateway Routing Protocol یا IGRP از مهمترین و معروف ترین پروتکل های Dynamic Routing موجود در روترهای امروزی می باشند.

معرفی پروتکل های مسیریابی Link State

در اینجا قصد داریم به شما پروتکل های مسیریابی Link state را معرفی کنیم و تفاوت های آن با پروتکل های Distance Vector را نیز عنوان کنیم. پروتکل های Link State بر خلاف پروتکل های Distance Vector شبکه ها را در قالب Hop Count و تعداد روترهای موجود در آن نمی بینند در عوض یک دیدگاه جامع و کامل در خصوص توپولوژی های مورد استفاده در شبکه ایجاد می کنند که همه جزئیات شبکه های موجود در توپولوژی را در خود دارد ، تمامی روترها با Cost های آنها در این دید جامع و کامل وجود خواهند داشت.

در پروتکل های Link State هر یک از روترهایی که از یکی از پروتکل های Link State استفاده می کند اطلاعات کاملی در خصوص خود روتر ، لینک های مستقیم متصل شده به آن و وضعیت آن لینک ها را در اختیار شبکه قرار می دهد. این اطلاعات توسط پیام های Multicast به همه روترهای موجود در شبکه ارسال می شود دقیقا بر خلاف پروتکل های مسیریابی Distance Vector که اینکار را به وسیله استفاده از فرآیند Broadcast انجام می دادند. فرآیند مسیریابی Link State به گونه ای است که با ایجاد شدن کوچکترین تغییری در توپولوژی شبکه های موجود بلافاصله این تغییر بصورت Incremental برای سایر روترها هم ارسال می شود تا توپولوژی شبکه روی همه روترها همیشه بروز باشد.

هر کدام از روترهای موجود در شبکه های Link State یک کپی از این توپولوژی شبکه را در خود دارند و آن را تغییر نمی دهند ، بعد از اینکه آخرین تغییرات شبکه ها را دریافت کردند هر روتر بصورت کاملا مستقل به محاسبه بهترین مسیرها برای رسیدن به شبکه های مقصد می پردازد.

معرفی پروتکل های مسیریابی Link State

پروتکل های مسیریابی Link State بر اساس الگوریتمی به نام Shortest Path First یا SFP برای پیدا کردن بهترین مسیر برای رسیدن به مقصد پایه ریزی شده اند. نام دیگر این الگوریتم Dijkstra است. در الگوریتم Shortest Path First یا SPF زمانیکه وضعیت یک لینک ارتباطی تغییر می کند ، یک Routing Update که به عنوان Link-State Advertisement یا LSA شناخته می شود ایجاد می شود و بین تمامی روترهای موجود تبادل می شود.

زمانیکه یک روتر LSA Routing Update را دریافت می کند ، الگوریتم Link-State با استفاده از آن کوتاه ترین مسیر را برای رسیدن به مقصد مورد نظر محاسبه می کند. هر روتر برای خود یک نقشه کامل از شبکه ها ایجاد می کند. نمونه ای از پروتکل مسیریابی Link-State پروتکل ای به نام Open Shortest Path First یا OSPF است.

چند واژه مهم در خصوص پروتکل های Link State وجود دارد که بد نیست با آنها آشنا شوید:

Link-State Advertisement یا LSA :

یک Packet کوچک اطلاعاتی است که در آن اطلاعات مربوط به Routing بین روترها رد و بدل می شود

Topological Database :

مجموعه اطلاعاتی که از LSA ها دریافت می شود

الگوریتم SPF یا Dijkstra :

الگوریتمی است که محاسبات بر روی database های موجود در SPF Tree را انجام می دهد

Routing Table :

یک لیست از مسیرها و Interface های شناسایی شده است.

پروتکل های مسیریابی Link State در عین اینکه به مدت زمان کمتری برای Converge شدن نسبت به پروتکل های مسیریابی Distance Vector برخوردارند در مقابل بوجود آمدن Routing Loop هم نسبت به Distance Vector ها مقاوم تر هستند و کمتر موردی پیش می آید که Routing Loop در پروتکل های Link State ایجاد شود. اما از طرفی دیگر الگوریتم های مورد استفاده در پروتکل های Link State به قدرت پردازشی CPU و حافظه RAM به نسبت پروتکل های Distance Vector نیاز دارند. پروتکل های Link State از یک ساختار سلسله مراتبی و موروثی استفاده می کنند که این ساختار باعث کاهش فاصله ها و نیاز کمتر به انتقال LSA ها می شود.

پروتکل های Link State ازمکانیزم Multicast برای اشتراک گذاری اطلاعات مسیریابی استفاده می کنند.

فقط روترهایی که از پروتکل های مسیریابی Link State استفاده می کنند این Routing Update ها را پردازش می کنند.

Link State ها فقط زمانی اطلاعات روتر را ارسال می کنند که در شبکه تغییری ایجاد شده باشد و صرفا همان تغییر را برای سایر روترها ارسال می کنند ، پیاده سازی پروتکل های مسیریابی Link-State پیچیده تر و پر هزینه تر از پیاده سازی پروتکل های Distance Vector می باشد و هزینه نگهداری آنها نیز به نسبت بیشتر است.

 

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

منبع: گیک بوی

 

شاید این موارد نیز مورد علاقه شما باشد:

مفهوم Dynamic Routing در روتر سیسکو

پیاده سازی پروتکل مسیریابی RIP

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش مفاهیم مسیریابی

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش تنظیم IP روتر و سوئیچ سیسکو

پیاده سازی Protected Port در سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو

آموزش SNMP در روتر و سوئیچ های سیسکو

آشنایی با پروتکل RIP

پروتکل OSPF

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

مفهوم Dynamic Routing در روتر سیسکو

مفهوم Dynamic Routing در روتر سیسکو

مفهوم Dynamic Routing در روتر سیسکو :Static routingاین قابلیت رابه مدیریت شبکه میدهدکه بتواندبصورت دستی یک سریRouteهای خاص رادرRouting Tableروترایجادکند.

Dynamic Routing از پروتکل های مسیریابی یا Routing Protocol برای شناسایی شبکه ها و مقصدها و همچنین پیدا کردن بهترین مسیر برای رساندن بسته اطلاعاتی به مقصد استفاده می کنند.

مفهوم Dynamic Routing در روتر سیسکو

Dynamic Routing این قابلیت را به Routing Table می دهد که بتواند زمانیکه یک Router خاموش است یا در دسترس نیست یا اینکه یک شبکه جدید به مجموعه اضافه می شود این تغییرات را در Routing Table ها اضافه کند. Dynamic Routing با استفاده از Routing Protocol ها این قابلیت را دارند که بصورت مستمر با شبکه تبادل اطلاعات داشته باشند و وضعیت هر یک از Router های شبکه را بررسی کنند و با استفاده از Broadcast و یا Multicast با هم ارتباط برقرار کنند و اطلاعات Routing Table را بروز کنند. با این روش همیشه توپولوژی شبکه بروز باقی می ماند و همگی دستگاه های روتر شبکه از آخرین Routing Table بروز استفاده می کنند. از پروتکل های Dynamic Routing می توان به Routing Information Protocol یا RIP ، Enhanced Interior Gateway Routing Protocol یا EIGRP و Open Shortest Path First یا OSPF اشاره کرد.

 

 

Dynamic Routing

Dynamic Routing

اما بصورت کلی ما Routing Protocol ها ره به سه دسته کلی تقسیم بندی می کنیم:

Routing Protocol های Distance-Vector :

پروتکل های Distance Vector از معیار Hop Count یا تعداد روترهای مسیر برای Metric در Routing Table های خود استفاده می کنند. الگوریتم مورد استفاده در اینگونه از پروتکل ها بسیار ساده است و Routing Table با محاسبات ساده ریاضی ایجاد می شود. پروتکل های Distance Vector معمولا برای شبکه های کوچکی که کمتر از 16 عدد Router در آنها وجود دارد مورد استفاده قرار می گیرند در واقع این نوع پروتکل ها با کم کردن تعداد Router های مسیر از به وجود آمدن Loop در شبکه یا بهتر بگوییم Routing Loop در شبکه جلوگیری می کنند.

این پروتکل ها در وهله های زمانی معین Routing Table های خود را با یکدیگر یکسان سازی می کنند ، یکی از مشکلات الگوریتم های Distance Vector در این است که کلیه اطلاعات موجود در Routing Table را حتی با کوچکترین تغییر برای سایر روترهای مجموعه ارسال می کنند و Incremental Update را در واقع پشتیبانی نمی کردند که در نسخه های جدید الگوریتم های Distance Vector این مشکل حل شد. الگوریتم های مسیریابی مثل RIPv1 و IGRP از این نوع Routing protocol ها هستند.

Routing Protocol های Link-State :

در پروتکل های Routing ای که بصورت Link State کار می کنند تفاوت محسوسی با حالت Distanced Vector وجود دارد. الگوریتم های مورد استفاده در این نوع پروتکل ها نسبت به Distanced Vector ها کاملا متفاوت عمل می کند و دارای پیچیدگی های خاص خود می باشد، در این الگوریتم ها از فاکتورهایی مثل Hop Count ، فاصله ، سرعت لینک و ترافیک بصورت همزمان برای تعیین بهترین مسیر و بهترین cost برای انجام عملیات Routing استفاده می شود. آنها از الگوریتمی به نام Dijkstra برای تعیین پایینترین cost برای Route ها استفاده می کنند.

روترهایی که از پروتکل های Link State استفاده می کنند فقط زمانی Routing Table های همدیگر را یکسان سازی می کنند که چیز جدیدی به Routing Table یکی از Router ها اضافه شده باشد. به همین دلیل هم کمترین ترافیک را در هنگام یکسان سازی Routing Table با همدیگر ایجاد می کنند. الگوریتم های مسیریابی مثل OSPF و IS-IS از این نوع پروتکل های Link State هستند.

Routing Protocol های Hybrid :

همانطور که از نام این نوع پروتکل Routing نیز پیداست این نوع پروتکل ترکیبی از پروتکل های Distance Vector و Link State است و در واقع مزایای هر یک از این نوع پروتکل ها را در خود جای داده است. زمانیکه صحبت از قدرت پردازشی روترها می شود از قابلیت های Distance Vector ها (به دلیل پردازش کمتر) و زمانیکه صحبت از تبادل Routing Table ها در شبکه می باشد از قابلیت های Link State ها استفاده می کند. امروزه تقریبا همه شبکه های بزرگ در دنیا از پروتکل های Hybrid استفاده می کنند ، الگوریتم مسیریابی مثل EIGRP از انواع پروتکل های Hybrid Routing هستند.

 

مفهوم Dynamic Routing در روتر سیسکو

منبع: گیک بوی

 

شاید این موارد نیز مورد علاقه شما باشد:

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

آموزش روتینگ سوئیچ لایه سه سیسکو

روش های سوئیچینگ و مسیریابی در شبکه های محلیش

پیاده سازی پروتکل مسیریابی RIP

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش مفاهیم مسیریابی

پروتکل های مسیریابی Classful vs Classless

آموزش تنظیم IP روتر و سوئیچ سیسکو

مفهوم Dynamic Routing در روتر سیسکو

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP :پروتکل Rip از نوع Distance Vector می باشد و به طور کلی از الگوریتم مسیر یابی Bellmanford استفاده می کند. این الگوریتم بسیار سبک است و به همین دلیل Load بسیار کمی روی CPU و RAM روتر می اندازد.

مشخصات پروتکل مسیریابی RIP

Administrative Distance (AD) = 120
Metric = Hop Count
در Routing Table با حرف R نشان داده می شود.
Infinite Metric = 16

دو Version نیز دارد که به RIP V1 و RIPv2 معروف است.

در Routing protocol بین روتر ها بسته های update ارسال می شود که شامل اطلاعات مربوط به شبکه هایی است که آن روتر در اختیار دارد.

در RIP V1 بسته های update با خود Subnet mask حمل نمی کنند در نتیجه نسخه اول RIP از subnetting ، supernetting و VLSM پشتیبانی نمی کند و بسته های update به آدرس ۲۵۵.۲۵۵.۲۵۵.۲۵۵ ارسال می شود.

پیاده سازی پروتکل مسیریابی RIP

در RIPv2 بسته های update با خود Subnet mask حمل می کنند پس بر خلاف نسخه اول ، این نسخه از subnetting ، supernetting و VLSM پشتیبانی می کند و بسته های update به آدرس ۲۲۴.۰.۰.۹ که یک آدرس از نوع multicast است ، ارسال می شود.

Update های RIP هر ۳۰ ثانیه یک باربه صورت Full ارسال می شود.

RIP V1 اهراز هویت (Authentication) ندارد.
RIPv2 اهراز هویت ( Authentication ) دارد.
به طور کلی RIP ، Convergence Time بالایی دارد و دید به Topology Table شبکه ندارند در نتیجه مستعد Loop است به همین دلیل این Routing protocol روش هایی برای جلوگیری از Loop در اختیار دارد.

روش های جلوگیری از Loop

Split Horizon بدین معنااست که روتر حق نداردمسیری راکه ازیک روتر دیگرگرفته است دوباره به آن روتر اعلام کند.
Route Poisoning بدین معنا ست که اگر مسیری قطع شده آن مسیر با Infinite Metric=16 نشان داده شود .
Triggered Update بدین معنا است که روتر نباید صبر کند تا زمان Full update ( که هر ۳۰ ثانیه یک بار است) برسد.بلکه هر موقع نیاز به Route Poisoning شد بسته update را در همان لحظه ارسال کند .

Hold down Timer بدین معنا است که هر زمان بسته Update به روتری رسید ۱۸۰ ثانیه صبر کند و سپس تغییرات را در Routing Table خود اعمال کند.
Split Horizon With Poison Reverse بدین معنا است که روتر حق ندارد مسیری را که از یک روتر دیگر گرفته است دوباره به آن روتر اعلام کند مگر اینکه آن مسیر Route Poison شده باشد.
و بدین صورت و بااستفاده ازاین پنج روش RIP قادراست درصورت به وجودآمدن Loopتا حدی ازبروزفاجعه جلوگیری کند.

برای یادگیری دستورات RIP به بررسی یک سناریو می پردازیم.

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

ما می خواهیم با استفاده از روش RIP ارتباط تمامی روتر ها و سوئیچ ها را با یکدیگر برقرار کنیم.در ابتدا باید وارد هر یک از روتر ها شده و اینترفیس های مربوطه را روشن کرده سپس به آن ها IP های مورد نظر را بدهیم و بعد از این config کردن RIP را آغاز می کنیم.

اختصاص IP Address برای اینترفیس های Fast Ethernet و Serial روتر

با استفاده ازدستورات زیردرقسمت CLI روترها بر اساس سناریو آموزش IP های اینترفیس های روتر رواختصاص میدیم:

Router-1:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-2:
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/1
Router(config-if)#ip address 11.11.11.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-3:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 11.11.11.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit

بعد از اختصاص IP ها بر روی اینترفیس روترها حال نوبت به کانفیگ ارتباط این ۲ شبکه و روترها باهم با استفاده از پروتکل RIP هست که برای انجام این کار نیز دستورات زیر را بر روی روترها انجام میدیم:

Router-1
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 172.16.88.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-2
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 11.11.11.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-3
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 192.168.1.0
Router(config-router)#network 11.11.11.0
Router(config-router)#exit

 

پیاده سازی پروتکل مسیریابی RIP

سایر مطالب مرتبط با یان مقاله:

آشنایی با پروتکل RIP

پروتکل OSPF

آموزش مفاهیم مسیریابی

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش پیکربندی پروتکلهای بردار فاصله

پروتکل OSPF

پروتکل OSPF

پروتکل OSPF

پروتکل OSPF :پروتکل مسیریابی OSPF پروتکل قدرتمند و پرطرفداری است که در RFC 2328 شرح داده شده است. این پروتکل برای پیدا کردن Neighbor یا در واقع روترهای متصل به خود  از Hello Message استفاده میکند. پیام Hello به آدرس Multicast 224.0.0.5)AllSPFRouters) ارسال میگردد اگر در رسانه ای خاص Multicast قابل استفاده نباشد، از Unicast استفاده میکند (در این حالت آدرس همسایه باید از قبل تنظیم شده باشد).

آشنایی با پروتکل OSPF

پروتکل مسیریابی Open Shortest Path First که به اختصار OSPF نامیده می شود یک پروتکل مسیریابی Link state است که میتواند ترافیک های مربوط به پروتکل IP را مدیریت کند. پروتکل OSPF نسخه های مختلفی دارد که در حال حاضر از نسخه ۲ آن بیشتراستفاده می شود.OSPF بصورت انحصاری توسط شرکت ها ارائه میشوند و یک پروتکل کاملا جامع و بدون وابستگی به هیچ برند خاصی است ، تقریبا همه روترهایی که در دنیا وجود دارند از پروتکل OSPF پشتیبانی می کنند.

پروتکل مسیریابی Open Shortest Path First یا پروتکل OSPF از الگوریتم Shortest Path First یا SPF که توسط Dijkstra طراحی شده است برای جلوگیری از به وجود آمدن Routing Loop در توپولوژی شبکه ها استفاده می کند و به نوع یک شبکه Loop Free ایجاد می کند. پروتکل OSPF فرآیند Convergence سریعی دارد و از طرفی قابلیت Incremental Update را نیز با استفاده ازLSA یا Link State Advertisement فراهم می کند. پروتکل مسیریابی OSPF یک پروتکل Classless است و به شما این اجازه را می دهد که برای طراحی یک ساختار سلسله مراتبی شبکه از VLSM و Route Summarization به راحتی استفاده کنید.

معرفی پروتکل OSPF

معرفی پروتکل OSPF

معایب پروتکل OSPF

مهمترین معایبی که در پروتکل OSPF وجود دارد این است که OSPF برای نگهداری لیست OSPF Neighbor ها ، توپوپولوژی شبکه که شامل یک دیتابیس از تمامی روترها و Route های موجود در آنهاست و همچنین Routing Table خود روتر به حافظه RAM نسبتا بیشتری در مقایسه با پروتکل های Distance Vector نیاز دارد.همچنین پروتکل OSPF به قدرت پردازشی یا CPU بیشتری برای اجرا کردن الگوریتم SPF نیاز دارد و همین موارد باعث می شود که OSPF در رده بندی پروتکل های مسیریابی پیچیده یا Complex Protocol قرار بگیرد. دو مفهوم بسیار مهم در مواردی که می خواهید از پروتکل OSPF استفاده کنید وجود دارند که اولین مفهوم Autonomous System و دومین مفهوم Area می باشد.

تنظیمات اولیه در OSPF

Area در OSPF برای ایجادکردن ساختارمسیریابی سلسله مراتبی یا موثری(Hierarchical Routing)در یک Autonomous System استفاده میشود. Area ها تعیین کننده این هستندکه چگونه وبه چه اندازه اطلاعات مربوط بهRoutingبایستی درشبکه به اشتراک گذاشته شود. OSPF دولایه وراثت یاHierarchyدارد،لایهBackboneیاArea 0 ولایه های خارج ازBackboneیاAreaهای بین عدد۱تا۶۵۵۳۵،این دوAreaای متفاوت هستندکه میتوان دربین آنهااطلاعات مسیریابی راSummarizeکرد. RouteSummarizationبه ما کمک میکندکه بتوانیم Routing Tableهای خودرافشرده سازی وکوچکترکنیم.تمامی Areaها بایستی بهArea 0متصل شوندوتمامی روترهادراینAreaازیک توپولوژی یکسان استفاده میکنند.

 

 

سایر مطالب مرتبط با یان مقاله:

آموزش مفاهیم مسیریابی

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش پیکربندی پروتکلهای بردار فاصله

 

آموزش پیکربندی پروتکل های بردار فاصله

آموزش پیکربندی پروتکلهای بردار فاصله

آموزش پیکربندی پروتکلهای بردار فاصله

در فصل های قبل دانشی در مورد انواع پروتکل های مسیریابی، مزایا و معایب آن ها را کسب کردید. در این فصل با تنظیمات پروتکل های مسیریابی بردار فاصله (DV) و پیکربندی دو نمونه از این پروتکل ها آشنا خواهید شد. پروتکل های IGRP و RIP از جمله پروتکل های بردار فاصله میباشند.

لینک دانلود: آموزش پیکربندی پروتکل های بردار فاصله

فرمت: PDF

حجم: 5.75 MB

 

فصل اول آشنایی با سوئیچ سیسکو

فصل دوم مدیریت سوئیچ و روتر سیسکو

فصل سوم آموزش اولیه مفاهیم پل ها و سوئیچ های سیسکو

فصل چهارم آموزش پیکربندی VLAN سوئیچ سیسکو

فصل پنجم آموزش مفاهیم مسیریابی

فصل هفتم آموزش پیکربندی پروتکل های مسیریابی پیشرفته

 

مطالب مرتبط:

پروتکل های مسیریابی Classful vs Classless

روش های سوئیچینگ و مسیریابی در شبکه های محلی

آموزش دستورات Show در روترهای سیسکو

آموزش دستورات Show در روترهای سیسکو

آموزش دستورات Show در روترهای سیسکو:

 در این مقاله با اجرای دستور زیر جدول روتینگ را بررسی می‌کنیم.

دستور Show IP Route:

Router#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

* – candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

D 192.168.1.0/24 [90/30720] via 192.168.2.1, 00:04:48, FastEthernet0/0

C 192.168.2.0/24 is directly connected, FastEthernet0/0

D 192.168.3.0/24 [90/30720] via 192.168.2.2, 00:04:47, FastEthernet0/0

C 192.168.4.0/24 is directly connected, FastEthernet0/1

با دستور Show IP Route، جدول روتینگ نمایش داده شده است که اگر به جدول توجه کنید، دو شبکه را دریافت کرده که با حرف D شروع می‌ شوند. حرف D به معنای Eigrp است و نشان‌ دهنده‌ ی این است که از روترهای دیگر این شبکه ها را یاد گرفته، شبکه‌ های پشت روترهای R2 و R3 را یاد گرفته است. در روترهای دیگر هم به همین صورت است.

 

دستور show ip eigrp neighbors:

برای نمایش همسایگی (Neighbors)، باید از دستور زیر در مد Privileged استفاده کنید:

 

Router#show ip eigrp neighbors

IP-EIGRP neighbors for process 200

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

۰ ۱۹۲.۱۶۸.۲.۱ Fa0/0 13 00:44:14 40 1000 0 6

۱ ۱۹۲.۱۶۸.۲.۳ Fa0/0 11 00:39:02 40 1000 0 7

این دستور در روتر R2 وارد شده است و نتیجه ی آن را مشاهده می‌ کنید؛ لیست Ip هایی که با آن‌ ها ارتباط همسایگی دارد را نمایش داده است.

 

دستور Show Ip Eigrp Interface:

این دستور برای نمایش اطلاعات interface هایی است که پروتکل EIGRP روی آن فعال‌ شده است. این دستور را در R2 وارد می‌ کنیم:

 

Router#show ip eigrp interface
IP-EIGRP interfaces for process 200
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0 2 0/0 1236 0/10 0 0
Fa0/1 0 0/0 1236 0/10 0 0

 

به نتیجه ی کار دقت کنید، اگر به Fa0/0 دقت کنید، نوشته است، PEER 2، یعنی اینکه از طریق اینترفیس Fa0/0 توانسته دو تا Neghibors را یاد بگیرد، Neighbors همان اینتر فیس های روترهای همسایه هستند که روی آن‌ ها Eigrp راه‌ اندازی شده است.

 

دستور Show IP eigrp Topology:

این دستور کل اطلاعات جدول توپولوژی را به شما نمایش می‌ دهد و می‌ گوید که شبکه را از کدام مسیر دریافت کرده و …

 

Router#show ip eigrp topology
IP-EIGRP Topology Table for AS 200
Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,r – Reply status
P 192.168.2.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 192.168.3.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/1
P 192.168.4.0/24, 1 successors, FD is 30720
via 192.168.2.3 (30720/28160), FastEthernet0/0
P 192.168.1.0/24, 1 successors, FD is 30720
via 192.168.2.1 (30720/28160), FastEthernet0/0

اگر به گزینه ی اول نگاه کنید، می‌ گوید شبکه ی ۱۹۲.۱۶۸.۲.۰ یک مسیر successor است، یعنی یک مسیر اصلی است و از طریق اینتر فیس FastEthernet 0/0 وارد همین روتر که داخل آن هستیم، شده است. بقیه هم به همین صورت است، پس نتیجه می گیریم که این جدول، کل اینترفیس هایی را به ما نشان می‌ دهد که Eigrp روی آن‌ ها Run شده است.

دستور Show IP eigrp Traffic:

این دستور نشان‌ دهنده ی پکت های دریافتی و ارسالی است، مانند زیر:

 

Router#show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 100
Hellos sent/received: 0/0
Updates sent/received: 0/0
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 0/0
Input queue high water mark 1, 0 drops
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0

مطالب مرتبط 

 

دستورات تنظیمات روتر و سوئیچ سیسکو

دستورات پیکربندی سوئیچ سیسکو

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت سوم

آموزش سیسکو Cisco قسمت چهارم

آموزش سیسکو Cisco قسمت پنجم

روش های سوئیچینگ و مسیریابی در شبکه های محلی

روش های سوئیچینگ و مسیریابی در شبکه های محلی

تعریف سوئیچینگ

فرآیند های Routing یا مسیریابی و سوئیچینگ (Switching) اساس و پایه کاری یک ارتباط شبکه را تشکیل می دهند. اگر کمی در خصوص دوره های شرکت سیسکو آشنایی داشته باشید حتما با این دو واژه برخورد کرده اید.

در واقع هر کدام از این فرآیند ها در لایه های مختلفی از شبکه انجام می شوند و به عنوان یک کارشناس شبکه شما باید تفاوت آنها را به خوبی بدانید. فرآیند سویچینگ یا Switching در لایه دوم از مدل OSI انجام می شود و به معنی رد و بدل کردن Packet های Data ی شبکه بین تجهیزات یک شبکه محلی یا Local است ، زمانیکه صحبت از شبکه محلی می شود یعنی اطلاعات قرار نیست از شبکه شما خارج شود و فقط در شبکه محلی یا LAN شما باقی می ماند.

سویچ های شبکه با استفاده از ساختار آدرس سخت افزاری کارت شبکه یا همان MAC Address می دانند که باید Packet ها یا بهتر بگوییم Frame ها را به سمت کدام مقصد ارسال کنند. یک سویچ برای خود دارای یک جدول آدرس سخت افزاری یا MAC Address Table است که در آن تمامی آدرس های MAC ای که به پورت های سویچ متصل شده اند را نگه می دارد ، در لایه دوم از مدل OSI ما به بسته های اطلاعاتی Frame یا Ethernet Frame می گوییم و سویچ با استفاده از مکانیزم MAC Table قادر به شناسایی مبدا و مقصد ارسالی Frame ها می باشد ، با توجه به اینکه سویچ دقیقا سخت افزارهایی که به خود وصل شده اند را با استفاده از این جدول می شناسد فقط می توان از فرآیند Switching در شبکه های کوچک LAN استفاده کرد. به MAC Address Table برخی اوقات CAM Table هم گفته می شود.

روش های سوئیچینگ

سوییچ ها به منظور مسیریابی ترافیک موجود در شبکه از سه روش سوییچینگ استفاده می کنند .

1. Store and forward
2. Cut through
3. Fragment Free

Switching

Switching

Store and Forward

در این روش سوئیچ در ابتدا کل بسته اطلاعاتی را ذخیره میکند ، سپس به خطایابی آن بسته میپردازد و در صورتی که خطایی در آن بسته پیدا کند سریعا آن بسته را حذف میکند ولی در صورتی که خطایی پیدا نکرد سوییچ آدرس کارت شبکه گیرنده بسته را جستجو کرده و بعد از پیدا کردن آدرس کارت شبکه مقصد آن بسته را به نود مقصد ارسال میکند .

این نوع سوئیچ ها برای شبکه های محلی بسیار مناسب هستند چرا که بسته های اطلاعاتی خراب شده را پاکسازی میکنند و به همین دلیل این سوئیچ ها باعث کاهش بروز عمل تصادف یا Coliisions خواهند شد .

این روش ساده ترین روش سوئیچینگ است .

پل ها یا هاب ها از این روش فقط استفاده میکنند در صورتی که سوئیچ ها از هر سه روش بالا نیز استفاده میکنند .

در این روش سوئیچ زمانی که فریمی را دریافت میکند ، در ابتدا آن را در حافظه RAM خود Buffer میکند و در مرحله بعد آدرس های Source mac و Destination mac را از هدر فریم خوانده ولی قبل از ارسال آن به سمت مقصد ، کد CRC فریم را از بخش Trailer آن چک میکند در صورتی که عدد CRC صحیح بود ، سوئیچ فریم را به سمت مقصد ارسال میکند و اگر خراب بود آن فریم را به عنوان یک Corrupted Frame یا یک فریم خراب تشخیص داده و توسط سوئیچ Drop میشود.

میتوانیم بگوییم که روش Store and forward روش خوبی است چرا که فریم ها بررسی میشوند و در صورت خراب بودن توسط سوئیچ سریعا Drop میشوند و فریم به مقصد ارسال نمیشود و مشکل این روش سرعت پایین آن است.
دلیل این سرعت پایین هم این است که بررسی کد CRC از یک طرف و خواندن Source mac و Destination mac از طرف دیگر بار زیادی را روی پردازنده تحمیل میکند.

Cut Through

این نوع از سویئچ ها سه یا چهار بایت اول یک بسته را میخوانند تا بالاخره آدرس مقصد را پیدا کنند سپس بسته را به آن بخش یا سگمنتی که آدرس مقصد بسته را دارد ارسال میکنند و بقیه قسمت های باقی مانده را ار نظر خطایابی مورد بررسی قرار نمی دهند .

این نوع سوئیچ ها ، به محض دریافت بسته ، سریعا Mac Address بسته را می خوانند و آن 6 بایت آدرس MAC را ذخیره میکنند و در حالتی که بقیه بسته ها در حال رسیدن به سوئیچ هستند ، بسته ای که بررسی کرده را به سمت نود مقصد ارسال میکند .
در این نوع سوئیچینگ فقط قسمت های اولیه فریم که شامل Preamble و آدرس MAC گیرنده می شود توسط دستگاه چک میشود و فریم سریعا به مقصد خودش هدایت میشود.

خوبیه این روش نسبت به حالت Store and forward این است که سرعت بالاتری دارد و مشکل این روش یا بهتر بگویم نقطه ضعف این روش احتمال فرستاده شدن فریم های بد به مقصد های مورد نظر است زیرا که CRC فریم مورد اندازه گیری واقع نمیشود .

خیلی از شرکت های تولید کننده یک سری امکانات را بر روی دستگاه اضافه میکنند (یعنی چی ؟)

به این صورت که دستگاه در کنار استفاده از روش Cut through ، اقدام به اندازه گیری CRC فریم هم میکند و تعداد فریم های مشکل دار را در حافظه خودش نگه میدارد سپس اگر این فریم های بد از حدی پیشرفت کردن به صورت خودکار عمل switching به Store and forward تبدیل میشود که به آن Dynamic Switching نیز میگویند .

Fragment Free

این نوع از سوئیچینگ هم مانند Cut through عمل میکند با این تفاوت که در این روش قبل از اینکه بسته ارسال شود 64 بایت اول که شامل preamble , MAC است را نگه میدارند این کار به این دلیل بیشتر خطاها و برخورد ها در طول اولین 64 بایت بسته اطلاعاتی اتفاق می افتد .

با توجه به این موضوع که اندازه فریم های Ethernet حداقل 64 بایت است ، استفاده از Fragment Free روش بهتری برای عمل سوئیچینگ است .هدف از این روش Fragmnet Free کاهش فریم هایی است که کمتر از 64 بایت بوده که این نوع فریم ها runt نامیده میشوند و به قولی به این روش Runt less هم می گویند .

در این روش نیز باز هم مانند Cut Through فریم های بد توسط دستگاه عبور داده می شوند که با فن Dynamic Switching میشود این مشکل را تا حدی برطرف کرد .

این نکته هم خالی از لطف نیست که بدانید این نوع عمل سوئیچینگ در افزایش عملکرد دستگاه به تنهایی موثر نیست و فاکتور های دیگری نیز مانند امکانات و performance دستگاه نیز باید مورد توجه قرار بگیرند …