نوشته‌ها

مفهوم Dynamic Routing در روتر سیسکو

مفهوم Dynamic Routing در روتر سیسکو

مفهوم Dynamic Routing در روتر سیسکو :Static routingاین قابلیت رابه مدیریت شبکه میدهدکه بتواندبصورت دستی یک سریRouteهای خاص رادرRouting Tableروترایجادکند.

Dynamic Routing از پروتکل های مسیریابی یا Routing Protocol برای شناسایی شبکه ها و مقصدها و همچنین پیدا کردن بهترین مسیر برای رساندن بسته اطلاعاتی به مقصد استفاده می کنند.

مفهوم Dynamic Routing در روتر سیسکو

Dynamic Routing این قابلیت را به Routing Table می دهد که بتواند زمانیکه یک Router خاموش است یا در دسترس نیست یا اینکه یک شبکه جدید به مجموعه اضافه می شود این تغییرات را در Routing Table ها اضافه کند. Dynamic Routing با استفاده از Routing Protocol ها این قابلیت را دارند که بصورت مستمر با شبکه تبادل اطلاعات داشته باشند و وضعیت هر یک از Router های شبکه را بررسی کنند و با استفاده از Broadcast و یا Multicast با هم ارتباط برقرار کنند و اطلاعات Routing Table را بروز کنند. با این روش همیشه توپولوژی شبکه بروز باقی می ماند و همگی دستگاه های روتر شبکه از آخرین Routing Table بروز استفاده می کنند. از پروتکل های Dynamic Routing می توان به Routing Information Protocol یا RIP ، Enhanced Interior Gateway Routing Protocol یا EIGRP و Open Shortest Path First یا OSPF اشاره کرد.

 

 

Dynamic Routing

Dynamic Routing

اما بصورت کلی ما Routing Protocol ها ره به سه دسته کلی تقسیم بندی می کنیم:

Routing Protocol های Distance-Vector :

پروتکل های Distance Vector از معیار Hop Count یا تعداد روترهای مسیر برای Metric در Routing Table های خود استفاده می کنند. الگوریتم مورد استفاده در اینگونه از پروتکل ها بسیار ساده است و Routing Table با محاسبات ساده ریاضی ایجاد می شود. پروتکل های Distance Vector معمولا برای شبکه های کوچکی که کمتر از 16 عدد Router در آنها وجود دارد مورد استفاده قرار می گیرند در واقع این نوع پروتکل ها با کم کردن تعداد Router های مسیر از به وجود آمدن Loop در شبکه یا بهتر بگوییم Routing Loop در شبکه جلوگیری می کنند.

این پروتکل ها در وهله های زمانی معین Routing Table های خود را با یکدیگر یکسان سازی می کنند ، یکی از مشکلات الگوریتم های Distance Vector در این است که کلیه اطلاعات موجود در Routing Table را حتی با کوچکترین تغییر برای سایر روترهای مجموعه ارسال می کنند و Incremental Update را در واقع پشتیبانی نمی کردند که در نسخه های جدید الگوریتم های Distance Vector این مشکل حل شد. الگوریتم های مسیریابی مثل RIPv1 و IGRP از این نوع Routing protocol ها هستند.

Routing Protocol های Link-State :

در پروتکل های Routing ای که بصورت Link State کار می کنند تفاوت محسوسی با حالت Distanced Vector وجود دارد. الگوریتم های مورد استفاده در این نوع پروتکل ها نسبت به Distanced Vector ها کاملا متفاوت عمل می کند و دارای پیچیدگی های خاص خود می باشد، در این الگوریتم ها از فاکتورهایی مثل Hop Count ، فاصله ، سرعت لینک و ترافیک بصورت همزمان برای تعیین بهترین مسیر و بهترین cost برای انجام عملیات Routing استفاده می شود. آنها از الگوریتمی به نام Dijkstra برای تعیین پایینترین cost برای Route ها استفاده می کنند.

روترهایی که از پروتکل های Link State استفاده می کنند فقط زمانی Routing Table های همدیگر را یکسان سازی می کنند که چیز جدیدی به Routing Table یکی از Router ها اضافه شده باشد. به همین دلیل هم کمترین ترافیک را در هنگام یکسان سازی Routing Table با همدیگر ایجاد می کنند. الگوریتم های مسیریابی مثل OSPF و IS-IS از این نوع پروتکل های Link State هستند.

Routing Protocol های Hybrid :

همانطور که از نام این نوع پروتکل Routing نیز پیداست این نوع پروتکل ترکیبی از پروتکل های Distance Vector و Link State است و در واقع مزایای هر یک از این نوع پروتکل ها را در خود جای داده است. زمانیکه صحبت از قدرت پردازشی روترها می شود از قابلیت های Distance Vector ها (به دلیل پردازش کمتر) و زمانیکه صحبت از تبادل Routing Table ها در شبکه می باشد از قابلیت های Link State ها استفاده می کند. امروزه تقریبا همه شبکه های بزرگ در دنیا از پروتکل های Hybrid استفاده می کنند ، الگوریتم مسیریابی مثل EIGRP از انواع پروتکل های Hybrid Routing هستند.

 

مفهوم Dynamic Routing در روتر سیسکو

منبع: گیک بوی

 

شاید این موارد نیز مورد علاقه شما باشد:

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

آموزش روتینگ سوئیچ لایه سه سیسکو

روش های سوئیچینگ و مسیریابی در شبکه های محلیش

پیاده سازی پروتکل مسیریابی RIP

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش مفاهیم مسیریابی

پروتکل های مسیریابی Classful vs Classless

آموزش تنظیم IP روتر و سوئیچ سیسکو

مفهوم Dynamic Routing در روتر سیسکو

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP :پروتکل Rip از نوع Distance Vector می باشد و به طور کلی از الگوریتم مسیر یابی Bellmanford استفاده می کند. این الگوریتم بسیار سبک است و به همین دلیل Load بسیار کمی روی CPU و RAM روتر می اندازد.

مشخصات پروتکل مسیریابی RIP

Administrative Distance (AD) = 120
Metric = Hop Count
در Routing Table با حرف R نشان داده می شود.
Infinite Metric = 16

دو Version نیز دارد که به RIP V1 و RIPv2 معروف است.

در Routing protocol بین روتر ها بسته های update ارسال می شود که شامل اطلاعات مربوط به شبکه هایی است که آن روتر در اختیار دارد.

در RIP V1 بسته های update با خود Subnet mask حمل نمی کنند در نتیجه نسخه اول RIP از subnetting ، supernetting و VLSM پشتیبانی نمی کند و بسته های update به آدرس ۲۵۵.۲۵۵.۲۵۵.۲۵۵ ارسال می شود.

پیاده سازی پروتکل مسیریابی RIP

در RIPv2 بسته های update با خود Subnet mask حمل می کنند پس بر خلاف نسخه اول ، این نسخه از subnetting ، supernetting و VLSM پشتیبانی می کند و بسته های update به آدرس ۲۲۴.۰.۰.۹ که یک آدرس از نوع multicast است ، ارسال می شود.

Update های RIP هر ۳۰ ثانیه یک باربه صورت Full ارسال می شود.

RIP V1 اهراز هویت (Authentication) ندارد.
RIPv2 اهراز هویت ( Authentication ) دارد.
به طور کلی RIP ، Convergence Time بالایی دارد و دید به Topology Table شبکه ندارند در نتیجه مستعد Loop است به همین دلیل این Routing protocol روش هایی برای جلوگیری از Loop در اختیار دارد.

روش های جلوگیری از Loop

Split Horizon بدین معنااست که روتر حق نداردمسیری راکه ازیک روتر دیگرگرفته است دوباره به آن روتر اعلام کند.
Route Poisoning بدین معنا ست که اگر مسیری قطع شده آن مسیر با Infinite Metric=16 نشان داده شود .
Triggered Update بدین معنا است که روتر نباید صبر کند تا زمان Full update ( که هر ۳۰ ثانیه یک بار است) برسد.بلکه هر موقع نیاز به Route Poisoning شد بسته update را در همان لحظه ارسال کند .

Hold down Timer بدین معنا است که هر زمان بسته Update به روتری رسید ۱۸۰ ثانیه صبر کند و سپس تغییرات را در Routing Table خود اعمال کند.
Split Horizon With Poison Reverse بدین معنا است که روتر حق ندارد مسیری را که از یک روتر دیگر گرفته است دوباره به آن روتر اعلام کند مگر اینکه آن مسیر Route Poison شده باشد.
و بدین صورت و بااستفاده ازاین پنج روش RIP قادراست درصورت به وجودآمدن Loopتا حدی ازبروزفاجعه جلوگیری کند.

برای یادگیری دستورات RIP به بررسی یک سناریو می پردازیم.

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

ما می خواهیم با استفاده از روش RIP ارتباط تمامی روتر ها و سوئیچ ها را با یکدیگر برقرار کنیم.در ابتدا باید وارد هر یک از روتر ها شده و اینترفیس های مربوطه را روشن کرده سپس به آن ها IP های مورد نظر را بدهیم و بعد از این config کردن RIP را آغاز می کنیم.

اختصاص IP Address برای اینترفیس های Fast Ethernet و Serial روتر

با استفاده ازدستورات زیردرقسمت CLI روترها بر اساس سناریو آموزش IP های اینترفیس های روتر رواختصاص میدیم:

Router-1:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-2:
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/1
Router(config-if)#ip address 11.11.11.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-3:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 11.11.11.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit

بعد از اختصاص IP ها بر روی اینترفیس روترها حال نوبت به کانفیگ ارتباط این ۲ شبکه و روترها باهم با استفاده از پروتکل RIP هست که برای انجام این کار نیز دستورات زیر را بر روی روترها انجام میدیم:

Router-1
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 172.16.88.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-2
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 11.11.11.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-3
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 192.168.1.0
Router(config-router)#network 11.11.11.0
Router(config-router)#exit

 

پیاده سازی پروتکل مسیریابی RIP

سایر مطالب مرتبط با یان مقاله:

آشنایی با پروتکل RIP

پروتکل OSPF

آموزش مفاهیم مسیریابی

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش پیکربندی پروتکلهای بردار فاصله

انواع اینترفیس های روتر و سوئیچ سیسکو

اینترفیس های روتر و سوئیچ سیسکو

اینترفیس های روتر و سوئیچ سیسکو

ارتباط و متصل شدن دستگاه های شبکه به روتر و سوئیچ سیسکو از طریق interface یا port اترنت است که بصورت ثابت(Fixed) هستند و براساس سرعت، پهنای باند و استفاده در شبکه LAN و WAN متفاوت هستند:

(Ethernet (10-Mbps

(Fast Ethernet (100-Mbps

(Gigabit Ethernet(1000-Mbps

در روتر و سوئیچ های ماژولار(modular) جایی بنام اسلات(slot)وجودداردکه میتوان اینترفیس هایی که نیاز داریم رااضافه کرد.
اینترفیس پورت سریال (Serial interface) برای ارتباط در شبکه WAN برای اتصال Point to Point دو روتر باهم مورد استفاده است که می توان اینترفیس پورت سریال(Serial interface) را براساس سرعت ، پهنای باند و دیگر پارامتر ها تنظیم کرد.

برروی روتر، پورت های(FXO,FXS) را هم میتوان دید که در تکنولوژی ویپ (voip) استفاده میشوند.

و همچنین پورت AUX یا (auxillary port) که برای ارتباط مستقیم کنسول به روتر از راه دور است در واقع میتوان آن را به عنوان پشتیبانی برای دسترسی ضروری به روتر دانست. به این صورت که با متصل شدن پورت AUX به مودم ، از راه دور می توان دسترسی کنسول به روتر داشت .

auxillary port

auxillary port

بادستور(show interfaces) در سوئیچ و روتر میتوان تعداد اینترفیس ها را با جزئیات بیشتر مشاهده و بررسی کرد:

Router#show interfaces
(FastEthernet0/0 is administratively down, line protocol is down (disabled
(Hardware is Lance, address is 000a.41a2.6501 (bia 000a.41a2.6501
,MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
,ARP type: ARPA, ARP Timeout 04:00:00
….Last input 00:00:08, output 00:00:05, output hang

که شامل مشخصات سخت افزاری میباشد ، مانند : off , on بودن اتصال و عدم اتصال کابل به اینترفیس، آدرس فیزیکی ۰۰۰a.41a2.6501: MAC address ، پهنای باند BW 100mg، نوع Encapsulation پورت اترنت ARPA و…

با دستور [اسم اینترفیس ]show interfaces میتوان اینترفیس مورد نظر و مشخص شده ای را بررسی کرد:

R1#show interfaces ethernet 0/0
Ethernet0/0 is administratively down, line protocol is down
(Hardware is AmdP2, address is cc01.1804.0000 (bia cc01.1804.0000
,MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
,….ARP type: ARPA, ARP Timeout 04:00:00

و همچنین برای مشاهده ماژول های نصب شده با دستور show diag می توان بررسی کرد:

R1#show diag
Slot 0:
Ethernet Port adapter, 4 ports
Port adapter is analyzed
Port adapter insertion time unknown
EEPROM contents at hardware discovery:
Hardware revision 1.0 Board revision B0
,….Serial number 7720321 Part number 800-03490-01

اختصاص ip address به اینترفیس های روتر :

روتر عمکردش در لایه 3 مدل ios هست و مسیریابی را از طریق پروتکل ip انجام میدهد و باعث ارتباط subnet های مختلف می شود. بنابراین interface های روتر قابلیت گرفتن ip address را مانند بخشی از subnet دارند و واسطی برای انتقال data می شوند.

Router>enable
Router#conf terminal
#(Router(config
Router(config)# interface fastEthernet 0/0

بعد وارد شدن به مد Configuration ، با دستور interface ، اینترفیس پورت مورد نظر را انتخاب میکنیم که در اینجا (fastEthernet 0/0) است و وارد مد اینترفیس ” config-if” می شوید.

توجه کنید : بصورت ثابت اولین slot اینترفیس در Router شماره (صفر) است و اگر بصورت ماژولار خواستید اینترفیسی اضافه کنید باید از slot دوم استفاده کنید و در Router ، شماره (یک) میشود . بنابراین fastEthernet 0/0 یا (fastEthernet slot/port), یعنی به ترتیب شماره ی slot ، صفر و شماره ی port، صفر است.

Router(config-if)# ip address 192 .168.1.1 255 .255.255.0

بعدازمشخص کردن اینترفیس با دستور (ip address) ،آدرس ip و subnet mask مورد نظر را وارد میکنید.

Router(config-if)# no shutdown

اینترفیس های روتر بصورت پیش فرض خاموش و غیرفعال اند، پس با دستور “no shutdown” آن را فعال میکنید.

در ضمن دستور “no” در اکثر موارد برای نقض و غیر فعال کردن پارامتری استفاده می شود.

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

بعدهر config، پیام های syslog را مشاهده میکنیدکه اعمال تنظیمات وتغییراتی که انجام داده ایم رابه ما نشان میدهند.
در syslog بالا تغییر حالت اینترفیس و اتصال اینترفیس به شبکه را به ما اعلام می کند.

Router#show ip interface brief

Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 ۱۹۲ .۱۶۸.۱.۱ YES manual up up
FastEthernet0/1 unassigned YES NVRAM administratively down down

بادستور”show ip interface brief” میتوان وضعیت ip address ،تعداد اینترفیس ها و پارامتر های دیگری رابصورت خلاصه مشاهده وبررسی کرد.

همانطورکه میبینیدfastEthernet 0/0 ،باگرفتن ip address فعال شده (Status up, Protocol up)، ولی fastEthernet 0/1 هنوز config نشده است.

 

مطالب مرتبط:

آموزش مفاهیم مسیریابی

آموزش دستورات Show در روترهای سیسکو

پروتکل های مسیریابی Classful vs Classless

دستورات پیکربندی سوئیچ سیسکودستورات پیکربندی سوئیچ سیسکو

دستورات تنظیمات روتر و سوئیچ سیسکو

آموزش مفاهیم مسیریابی

آموزش مفاهیم مسیریابی

آموزش مفاهیم مسیریابی

همانطور که میدانید اینترنت مجموعه ای از شبکه های محلی است و با استفاده از دستگاه هایی به نام روتر به یکدبگر متصل شده اند.

درواقع زمانی که کامپیوترهانیاز داشته باشند تا در شبکه های محلی با یکدیگر ارتباط برقرار کنند، از آدرس دهی لایه 2 و دستگاه های لایه 2 استفاده میکنند.

نحوه عملکرد سوئیچ در فصل های قبل به صورت مفصل مورد بررسی قرار گرفته است.

حال برای اینکه شبکه های محلی بتوانند با یکدیگر ارتباط برقرار کنند نیاز به یک آدرس دهی سراسری به نام آدرس IP است.

از آنجایی که از آدرس دهی IP برای مسیریابی بین شبکه های محلی استفاده میشود نیاز به یک دستگاه به نام Router احساس میشود تا بتوان بسته های شبکه های محلی را به مقصد تحویل داد.

در واقع هر شبکه محلی که نیاز داشته باشد تا با سایر شبکه های محلی در ارتباط باشد نیاز به یک روتر دارد. روتر به عنوان دروازه بین شبکه محلی با سایر شبکه ها شناخته شده که اصطلاحا به آن Gateway گفته میشود.

هر اینترفیسی که بر روی روتر قرار دارد دارای یک آدرس IP است و این IP باید در محدوده آدرس شبکه ای باشد که اینترفیس به آن متصل شده است.

 

لینک دانلود: آموزش مفاهیم مسیریابی

فرمت: PDF

حجم: 5.55 MB

فصل اول آشنایی با سوئیچ سیسکو

فصل دوم مدیریت سوئیچ و روتر سیسکو

فصل سوم آموزش مفاهیم اولیه پل ها سوئیچ های سیسکو

فصل چهارم آموزش پیکربندی VLAN سوئیچ سیسکو

فصل ششم آموزش پیکربندی پروتکلهای بردار فاصله

فصل هفتم آموزش پیکربندی پروتکل های مسیریابی پیشرفته

 

مطالب مرتبط:

دستورات تنظیمات روتر و سوئیچ سیسکو

پروتکل های مسیریابی Classful vs Classless

مراحل بوت شدن روتر سیسکو

Inter Vlan Routing از طریق روتر