نوشته‌ها

پروتکل های مسیریابی - Dynamic Routing سیسکو

پروتکل های مسیریابی Dynamic Routing سیسکو

پروتکل های مسیریابی Dynamic Routing سیسکو

پروتکل های مسیریابی Dynamic Routing سیسکو: پروتکل های مسیریابی به سه دسته Distance Vector و Link State و Hybrid تقسیم می‌شوند. ابتدا در قسمت اول مقاله درباره‌ی پروتکل های مسیریابی Distance Vector صحبت خواهیم کرد. سپس به توضیح و بسط دو پروتکل دیگر می‌پردازیم.

پروتکل های مسیریابی Distance Vector

این نوع روتینگ، جزو ساده‌ترین پروتکل های مسیریابی به شمار می‌رود. همان‌طور که از نام آن مشخص است؛ از دو فاکتور Distance یا مسافت و Vector یا جهت، برای پیدا کردن مقصد استفاده می‌کند.

روترهایی که از پروتکل های مسیریابی Distance Vector استفاده می‌کنند، به روترهای همسایه یا Neighbor خود اطلاع رسانی می‌کنند. این داده‌ها شامل اطلاعاتی از قبیل توپولوژی شبکه و تغییراتی که در بازه‌های زمانی متفاوت انجام می‌شود؛ هستند. نحوه‌ی ارتباط با استفاده از Broadcast انجام می‌شود و از آدرس IP به شکل 255.255.255.255 استفاده می‌کند.

پروتکل های مسیریابی Distance Vector از الگوریتم Bellman-Ford برای پیدا کردن بهترین مسیر جهت رسیدن به مقصد استفاده می‌کند. روترهای مورد استفاده در توپولوژی Distance Vector، برای دست‌یابی به اطلاعات موجود در Routing Table های روترهای همسایه، درخواست Broadcast می‌کنند. در نهایت از این اطلاعات برای به روز رسانی Interface خود استفاده می‌کنند. همچنین برای به اشتراک گذاری اطلاعات Routing Protocol خود، از ساختار Broadcasting بهره می‌برند.

نحوه‌ی فعالیت

الگوریتم‌های Distance Vector تغییراتی را که در Routing Table انجام می‌شود، بلافاصله برای روترهای همسایه خود ارسال می کنند. این اطلاعات بر روی تمام Interface ها منتشر می‌شود. با هر تبادلی که انجام می‌شود، روتر Distance Value مربوط به مسیر دریافت شده را افزایش می‌دهد. سپس Distance Value خودش را هم بر روی Route های جدید قرار می‌دهد. روتری که این تغییرات را دریافت می‌کند به همین ترتیب Route های خودش را بر روی این Table قرار می‌دهد. به همین شکل برای روترهای باقی‌مانده نیز ارسال می‌کند و این فرآیند تا آخرین روتر ادامه می‌یابد.

در Distance Vector به این موضوع توجه نمی‌شود که چه کسی به Update هایی که ارسال می‌شود؛ گوش می‌کند. نکته جالب این است که پروتکل های مسیریابی Distance Vector در صورتی که هیچ تغییری در Routing Protocol خود نداشته باشند نیز به صورت متناوب Routing Table خود را Broadcast می‌کنند. یعنی اگر توپولوژی شبکه تغییر نکرده باشد هم Broadcasting انجام می‌شود.

پیاده‌سازی و رفع عیب این نوع پروتکل بسیار ساده است. روتر برای انجام فرآیندهای پردازشی نیاز به منابع بسیار کمتری دارد. منطق کاری Distance Vector ساده است. این پروتکل Routing Update را دریافت می‌کند، مقدار Metric را افزایش می‌دهد، نتایج را با مقادیر موجود در Routing Table خود مقایسه می‌کند و در صورت نیاز Routing Table را Update می‌کند. پروتکل‌هایی مثل Routing Information Protocol یا RIP نسخه یک و Interior Gateway Routing Protocol یا IGRP از مهم‌ترین و معروف‌ترین پروتکل های مسیریابی Dynamic Routing در روترهای امروزی هستند.

پروتکل های مسیریابی Link State

در این بخش، پروتکل های مسیریابی Link state را معرفی می‌کنیم و تفاوت‌های آن را با پروتکل های Distance Vector شرح خواهیم داد. پروتکل های Link State بر خلاف پروتکل های Distance Vector، شبکه‌ها را در قالب Hop Count و تعداد روترهای موجود در آن نمی‌بینند. در عوض یک دیدگاه جامع و کامل در خصوص توپولوژی های مورد استفاده در شبکه ایجاد می‌کنند که همه جزئیات شبکه‌های موجود در توپولوژی را در خود دارد. تمامی روترها با Cost های آن‌ها در این دید جامع و کامل وجود خواهند داشت.

در پروتکل های Link State هر یک از روترهایی که از یکی از این پروتکل‌ها استفاده کند؛ اطلاعات کاملی در خصوص خود روتر، لینک‌های مستقیم متصل شده به آن و وضعیت آن لینک‌ها را در اختیار شبکه قرار می‌دهد. این اطلاعات توسط پیام های Multicast به همه روترهای موجود در شبکه ارسال می‌شود. این عمل بر خلاف پروتکل های مسیریابی Distance Vector است که آن را به وسیله استفاده از فرآیند Broadcast انجام می‌دادند.

فرآیند مسیریابی Link State به گونه ای است که با ایجاد کوچک‌ترین تغییر در توپولوژی شبکه‌های موجود، این تغییرات بلافاصله به صورت Incremental برای سایر روترها هم ارسال می‌شود تا توپولوژی شبکه روی همه روترها همیشه به‌روز باشد.

هر کدام از روترهای موجود در پروتکل های مسیریابی Link state یک کپی از این توپولوژی را در خود دارند و آن را تغییر نمی‌دهند. پس از آن‌که آخرین تغییرات شبکه‌ها را دریافت کردند، هر روتر به صورت مستقل به محاسبه بهترین مسیر برای رسیدن به شبکه‌ی مقصد می‌پردازد.

ویژگی پروتکل های مسیریابی Link State

پروتکل های مسیریابی Link State بر اساس الگوریتمی به نام Shortest Path First یا SPF برای پیدا کردن بهترین مسیر جهت رسیدن به مقصد، پایه‌ریزی شده‌اند. در الگوریتم SPF زمانی که وضعیت یک لینک ارتباطی تغییر می‌کند، یک Routing Update که به عنوان Link-State Advertisement یا LSA شناخته می‌شود ایجاد می‌شود. این به‌روزرسانی بین تمامی روترهای موجود تبادل خواهد شد.

هنگامی که روتری LSA Routing Update را دریافت می‌کند؛ الگوریتم Link-State با استفاده از آن، کوتاه‌ترین مسیر را برای رسیدن به مقصد مورد نظر محاسبه می‌کند. هر روتر برای خود یک نقشه کامل از شبکه‌ها ایجاد می‌کند. نمونه‌ای از پروتکل مسیریابی Link-State پروتکلی به نام Open Shortest Path First یا OSPF است.

کلید واژه‌های مهم در پروتکل های Link State:

  • Link-State Advertisement یا LSA: یک Packet کوچک اطلاعاتی است که اطلاعات مربوط به Routing را بین روترها رد و بدل می‌کند
  • Topological Database: مجموعه اطلاعاتی که از LSAها دریافت می‌شود
  • الگوریتم SPF یا Dijkstra: الگوریتمی است که محاسبات database های موجود در SPF Tree را انجام می‌دهد
  • Routing Table: یک لیست از مسیرها و Interface های شناسایی شده است

مزایا و معایب

پروتکل های مسیریابی Link State در عین حال که به مدت زمان کمتری برای Converge شدن نسبت به پروتکل های مسیریابی Distance Vector برخوردارند؛ در مقابل ایجاد Routing Loop هم نسبت به Distance Vector مقاوم‌تر هستند. به ندرت Routing Loop در Link State ایجاد می‌شود. از طرفی الگوریتم‌های مورد استفاده در پروتکل های Link State به قدرت پردازشی CPU و حافظه RAM بیشتری نسبت به پروتکل های Distance Vector نیاز دارند. پروتکل های Link State از یک ساختار سلسله مراتبی و موروثی استفاده می‌کنند که این ساختار باعث کاهش فاصله‌ها و نیاز کمتر به انتقال LSA می‌شود.

پروتکل های مسیریابی Link State از مکانیسم Multicast برای به اشتراک گذاری اطلاعات استفاده می‌کنند. تنها روترهایی که از پروتکل های مسیریابی Link State استفاده می‌کنند این Routing Update ها را می‌توانند پردازش کنند.

Link State ها فقط زمانی اطلاعات روتر را ارسال می‌کنند که در شبکه تغییری ایجاد شده باشد. در نهایت فقط همان تغییر را برای سایر روترها ارسال می‌کنند. پیاده‌سازی پروتکل های مسیریابی Link State پیچیده‌تر و پر هزینه‌تر از پیاده‌سازی پروتکل‌های Distance Vector است. هزینه‌ی نگهداری آن‌ها نیز به مراتب بیشتر است.

پروتکل های مسیریابی Dynamic Routing سیسکو

منبع: گیک بوی

پروتکل های مسیریابی Dynamic Routing سیسکو
5 (100%) 1 vote

مفهوم Dynamic Routing در روتر سیسکو

مفهوم Dynamic Routing در روتر سیسکو

مفهوم Dynamic Routing در روتر سیسکو: Static routing این قابلیت را به مدیر شبکه می‌دهد که بتواند به صورت دستی یک سری Route های خاص را در Routing Table ایجاد کند. Dynamic Routing از پروتکل های مسیریابی یا Routing Protocol برای شناسایی شبکه‌ها استفاده می‌کند. در پیدا کردن بهترین مسیر جهت رساندن بسته اطلاعاتی نیز بهره می‌برد.

Dynamic Routing این قابلیت را به Routing Table می‌دهد که در زمان خاموشی Router، نبودن دسترسی به آن یا اضافه شدن شبکه جدید، تغییرات را در Routing Table اضافه کند. Dynamic Routing با استفاده از Routing Protocol به صورت مستمر با شبکه تبادل اطلاعات دارد. همچنین وضعیت روترهای شبکه را بررسی می‌کند و با استفاده از Broadcast یا Multicast با سایر روترها ارتباط برقرار خواهد کرد. حتی می‌تواند اطلاعات Routing Table را به‌روز رسانی کند.

توپولوژی شبکه با استفاده از این شیوه‌ها همیشه به‌روز باقی می‌ماند. تمام روترهای شبکه نیز از جدیدترین Routing Table استفاده خواهند کرد. از پروتکل های Dynamic Routing می‌توان به Routing Information Protocol یا به اختصار RIP و Enhanced Interior Gateway Routing Protocol یا EIGRP و همچنین Open Shortest Path First با سرواژه OSPF اشاره کرد.

به طور کلی پروتکل های مسیریابی به سه دسته تقسیم می‌شوند که در زیر به تشریح هر کدام خواهیم پرداخت.

Distance Vector

پروتکل های Distance Vector از معیار Hop Count یا تعداد روترهای مسیر برای Metric در جدول مسیریابی خود استفاده می‌کنند. الگوریتم آن بسیار ساده است و Routing Table با محاسبات ساده ریاضی ایجاد می‌شود. پروتکل های Distance Vector به طور معمول برای شبکه‌های کوچک کمتر از ۱۶ روتر مورد استفاده قرار می‌گیرند. در واقع این نوع پروتکل ها با کم کردن تعداد روترهای مسیر از به وجود آمدن Loop در شبکه یا همان Routing Loop جلوگیری می‌کنند.

این پروتکل‌ها در زمان‌های معین Routing Table های خود را با یکدیگر یکسان سازی می‌کنند. یکی از معایب الگوریتم‌های Distance Vector این است که کلیه اطلاعات موجود در جدول مسیریابی را با کوچک‌ترین تغییر برای سایر روترهای مجموعه ارسال می‌کنند. در نسخه های جدید از Incremental Update هم پشتیبانی می‌شود. الگوریتم‌های مسیریابی مانند RIPv1 و IGRP از این نوع پروتکل هستند.

Link State

در پروتکل های Link State تفاوت واضحی با حالت Distance Vector وجود دارد. الگوریتم‌های مورد استفاده در این نوع پروتکل‌ها نسبت به Distance Vector کاملا متفاوت عمل می‌کند. در این نوع، از فاکتورهایی مثل Hop Count، فاصله، سرعت لینک و ترافیک به صورت همزمان برای تعیین بهترین مسیر و انجام مسیریابی استفاده می‌شود. آن‌ها از الگوریتمی به نام Dijkstra برای تعیین پایین‌ترین هزینه برای Route ها استفاده می‌کنند.

روترهایی که از پروتکل های Link State استفاده می‌کنند فقط زمانی Routing Table های یکدیگر را یکسان‌سازی می‌کنند که مورد جدیدی به Routing Table یکی از روترها اضافه شده باشد. به همین دلیل کم‌ترین ترافیک را در زمان یکسان‌سازی ایجاد می‌کنند. الگوریتم‌های مسیریابی مانند OSPF و ISIS از این نوع پروتکل هستند.

Hybrid

این نوع پروتکل ترکیبی از پروتکل های Distance Vector و Link State است. در واقع مزایای هر یک از آن‌ها را در خود جای داده است. هنگامی که صحبت از قدرت پردازشی روترها می‌شود؛ از قابلیت‌های Distance Vector به دلیل پردازش کمتر نام برده می‌شود. زمانی که بحث از تبادل Routing Table ها در شبکه باشد؛ از قابلیت‌های Link State مورد بهره‌برداری قرار خواهد گرفت. امروزه تمام شبکه‌های بزرگ در دنیا از پروتکل های Hybrid استفاده می‌کنند. الگوریتم مسیریابی EIGRP از انواع پروتکل های Hybrid Routing است.

مفهوم Dynamic Routing در روتر سیسکو

مفهوم Dynamic Routing در روتر سیسکو
5 (100%) 1 vote

راه اندازی DHCP بر روی سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو: DHCP یکی از پر کاربرد ترین سرویس های شبکه است که در خفا و پس زمینه مسئول اختصاص آدرس های IP به کلاینت های شبکه است. این سرویس جزء لاینفک شبکه های بزرگ و کوچک بوده و از ابتدایی ترین تراکنش های ارتباطی در شبکه های LAN است.

DHCP سرور

DHCP سرور

هنگامی که شما یک کلاینت را به یک شبکه مرتبط می‌کنید و یا با یک سرور PPP ارتباط برقرار می‌کنید؛ پس از احراز هویت دریافت آدرس IP از ابتدایی ترین واکنش هاست. استفاده از DHCP علاوه بر افزایش کارایی شبکه به افزایش چشمگیر امنیت در شبکه های مبتنی بر سیسکو می انجامد. بدین ترتیب که به عنوان یک مدیر شبکه امکان مدیریت و رصد مشکلات به سادگی امکان پزیر است و همچنین از مشکلاتی نظیر IP Conflict و دسترسی غیر مجاز به آدرس های IP جلوگیری به عمل می آید. پیاده سازی DHCP بر روی روتر ها و سویئچ های سیسکو به سادگی امکان پذیر بوده و ترافیک و لود چندانی را به دستگاه تحمیل نمینماید.

راه اندازی DHCP بر روی سوئیچ سیسکو

شروع کار:

توصیه می‌شود ابتدا یک دیتابیس برای نگهداری واگذاری آدرس های IP ایجاد و دسترسی FTP به آن را میسر نمایید.

Router(config)# ip dhcp database ftp://user:password@172.16.1.1/router-dhcp timeout 80

جلوگیری از اعطای آدرس های 100 تا 103:

Router(config)# ip dhcp excluded-address 172.16.1.100 172.16.1.103
Router(config)# ip dhcp pool 1
Router(dhcp-config)# utilization mark high 80 log
Router(dhcp-config)# network 172.16.0.0 /16
Router(dhcp-config)# domain-name rootlan #domain name
Router(dhcp-config)# dns server 217.218.127.127 217.218.155.155 #dci dns servers
Router(dhcp-config)# default-router 172.16.1.100 172.16.1.101 #this is the Gateway address
Router(dhcp-config)# option 19 hex 01 #additional dhcp option code for example tftp address
Router(dhcp-config)# lease 30 # the lease amount

بدین ترتیب امکان استفاده از امکانات DHCP بر روی روتر و سوئیچ های سیسکو میسر میگردد البته امکانات پیشرفته تری نیز وجود داره که در صورت نیاز میتوانید از آنها استفاده کنید لازم به توضیح است استفاده از سرویس DHCP بر روی شبکه های VLAN که دارای Access Switch و Core Switch هستند بر روی سوئیچ های لایه دسترسی توصیه میشود.

اگر به هر دلیلی مایل به استفاده از دیتابیس جهت ثبت واگذاری IP نبودید میتوانید از این کامند استفاده نمایید:

Router(config)# no ip dhcp conflict logging

توسط این دستور می‌توانید میزان استفاده از منابع IP را مشاهده کنید:

Router(config)# ip dhcp use class

راه اندازی DHCP بر روی سوئیچ سیسکو

شاید این موارد نیز مورد علاقه شما باشد:

پیاده سازی پروتکل مسیریابی RIP

آسیب‌پذیری پروتکل UPnP در برابر حملات DDOS

پروتکل OSPF

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش پیکربندی پروتکلهای بردار فاصله

پروتکل های مسیریابی Classful vs Classless

پروتکل ISL انحصاری شرکت سیسکو

تغییر firmware تلفن های سیسکو

مفهوم SDN

راه اندازی DHCP بر روی سوئیچ سیسکو
5 (100%) 1 vote
پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP :پروتکل Rip از نوع Distance Vector می باشد و به طور کلی از الگوریتم مسیر یابی Bellmanford استفاده می کند. این الگوریتم بسیار سبک است و به همین دلیل Load بسیار کمی روی CPU و RAM روتر می اندازد.

مشخصات پروتکل مسیریابی RIP

Administrative Distance (AD) = 120
Metric = Hop Count
در Routing Table با حرف R نشان داده می شود.
Infinite Metric = 16

دو Version نیز دارد که به RIP V1 و RIPv2 معروف است.

در Routing protocol بین روتر ها بسته های update ارسال می شود که شامل اطلاعات مربوط به شبکه هایی است که آن روتر در اختیار دارد.

در RIP V1 بسته های update با خود Subnet mask حمل نمی کنند در نتیجه نسخه اول RIP از subnetting ، supernetting و VLSM پشتیبانی نمی کند و بسته های update به آدرس ۲۵۵.۲۵۵.۲۵۵.۲۵۵ ارسال می شود.

پیاده سازی پروتکل مسیریابی RIP

در RIPv2 بسته های update با خود Subnet mask حمل می کنند پس بر خلاف نسخه اول ، این نسخه از subnetting ، supernetting و VLSM پشتیبانی می کند و بسته های update به آدرس ۲۲۴.۰.۰.۹ که یک آدرس از نوع multicast است ، ارسال می شود.

Update های RIP هر ۳۰ ثانیه یک باربه صورت Full ارسال می شود.

RIP V1 اهراز هویت (Authentication) ندارد.
RIPv2 اهراز هویت ( Authentication ) دارد.
به طور کلی RIP ، Convergence Time بالایی دارد و دید به Topology Table شبکه ندارند در نتیجه مستعد Loop است به همین دلیل این Routing protocol روش هایی برای جلوگیری از Loop در اختیار دارد.

روش های جلوگیری از Loop

Split Horizon بدین معنااست که روتر حق نداردمسیری راکه ازیک روتر دیگرگرفته است دوباره به آن روتر اعلام کند.
Route Poisoning بدین معنا ست که اگر مسیری قطع شده آن مسیر با Infinite Metric=16 نشان داده شود .
Triggered Update بدین معنا است که روتر نباید صبر کند تا زمان Full update ( که هر ۳۰ ثانیه یک بار است) برسد.بلکه هر موقع نیاز به Route Poisoning شد بسته update را در همان لحظه ارسال کند .

Hold down Timer بدین معنا است که هر زمان بسته Update به روتری رسید ۱۸۰ ثانیه صبر کند و سپس تغییرات را در Routing Table خود اعمال کند.
Split Horizon With Poison Reverse بدین معنا است که روتر حق ندارد مسیری را که از یک روتر دیگر گرفته است دوباره به آن روتر اعلام کند مگر اینکه آن مسیر Route Poison شده باشد.
و بدین صورت و بااستفاده ازاین پنج روش RIP قادراست درصورت به وجودآمدن Loopتا حدی ازبروزفاجعه جلوگیری کند.

برای یادگیری دستورات RIP به بررسی یک سناریو می پردازیم.

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

ما می خواهیم با استفاده از روش RIP ارتباط تمامی روتر ها و سوئیچ ها را با یکدیگر برقرار کنیم.در ابتدا باید وارد هر یک از روتر ها شده و اینترفیس های مربوطه را روشن کرده سپس به آن ها IP های مورد نظر را بدهیم و بعد از این config کردن RIP را آغاز می کنیم.

اختصاص IP Address برای اینترفیس های Fast Ethernet و Serial روتر

با استفاده ازدستورات زیردرقسمت CLI روترها بر اساس سناریو آموزش IP های اینترفیس های روتر رواختصاص میدیم:

Router-1:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-2:
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/1
Router(config-if)#ip address 11.11.11.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-3:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 11.11.11.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit

بعد از اختصاص IP ها بر روی اینترفیس روترها حال نوبت به کانفیگ ارتباط این ۲ شبکه و روترها باهم با استفاده از پروتکل RIP هست که برای انجام این کار نیز دستورات زیر را بر روی روترها انجام میدیم:

Router-1
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 172.16.88.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-2
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 11.11.11.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-3
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 192.168.1.0
Router(config-router)#network 11.11.11.0
Router(config-router)#exit

 

پیاده سازی پروتکل مسیریابی RIP

سایر مطالب مرتبط با یان مقاله:

آشنایی با پروتکل RIP

پروتکل OSPF

آموزش مفاهیم مسیریابی

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش پیکربندی پروتکلهای بردار فاصله

پیاده سازی پروتکل مسیریابی RIP
5 (100%) 1 vote