Inter Vlan Routing از طریق روتر

InterVlan Routing از طریق روتر

VLANها برای جدا سازی ترافیک شبکه ، افزایش امنیت شبکه و تقسیم یک شبکه بزرگ به چندین شبکه کوچک استفاده می شود . ما می دانیم که سیستم ها متعلق به یک VLAN نمی توانند با سیستم های متعلق به سایر VLAN ها ارتباط برقرار کنند مگر اینکه نام VLAN و VLAN ID با آنها منطبق نباشد . با این حال ، یک روش به نام InterVlan Routing است که اجازه می دهد تا VLAN های مختلف با یکدیگر ارتباط برقرار کنند . به منظور برقراری ارتباط بین InterVLAN ، شما نیاز به یک دستگاه لایه 3 مانند روتر یا سوئیچ لایه 3 دارید .

Encapsulation dot1Q برای InterVlan Routing استفاده می شود . در این پست، ما توضیح خواهیم داد که چگونه InterVLAN را روی روترها و سوئیچ های سیسکو پیکربندی کنید .

پیکربندی مرحله InterVLAN Routing گام به گام

ما از توپولوژی زیر برای نشان دادن نحوه پیکربندی مسیریابی InterVLAN استفاده خواهیم کرد .

InterVlan Routing
1- در Switch1، دستورات زیر را برای ایجاد یک VLAN با نام Sales با شناسه VLAN به عنوان 10 اجرا کنید.

Switch1(config)#vlan 10
Switch1(config-vlan)#name Sales
Switch1(config-vlan)#exit

2 – هنگامی که VLAN Sales ایجاد کرده اید ، دستورات زیر را اجرا کنید تا Fa0/1 interface را به VLAN Sales اختصاص دهید .

Switch1(config)#interface fa0/1
Switch1(config-if)#switchport mode access
Switch1(config-if)#switchport access vlan 10
Switch1(config-if)#exit

3 – بعد، دستورات زیر را برای ایجاد یک VLAN دیگری با نام Account با شناسه VLAN به عنوان 20 اجرا کنید .

Switch1(config)#vlan 20
Switch1(config-vlan)#name Account
Switch1(config-vlan)#exit

4- بعد، دستورات زیر را برای اختصاص interface Fa0 / 2 به VLAN حساب اجرا کنید .

Switch1(config)#interface fa0/2
Switch1(config-if)#switchport mode access
Switch1(config-if)#switchport access vlan 20
Switch1(config-if)#exit

5- بعد، دستورات زیر را در Switch1 اجرا کنید تا VLAN trunking را در interface Fa0 / 3 فعال کنید .

Switch1(config)#interface fa0/3
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#exit

6- پس از پیکربندی VLAN ها و VLAN trunking در Switch1، تنظیمات TCP / IP زیر را در PC0 پیکربندی کنید :

IP address: 10.0.0.1
Subnet mask: 255.0.0.0
Default gateway: 10.0.0.100

7- بعد، تنظیمات TCP / IP زیر را در PC1 پیکربندی کنید .

IP address: 20.0.0.1
Subnet mask: 255.0.0.0
Default gateway: 20.0.0.100

8- هنگامی که شما تنظیمات TCP / IP مناسب را روی PC0 و PC1 پیکربندی کرده اید، به Router بروید . در روتر ، دستورات زیر را اجرا کنید تا interface Fa0 / 0 را از حالت Down به حالت UP تغییر دهید .

Router(config)#interface fa0/0
Router(config-if)#no ip address
Router(config-if)#no shutdown
Router(config-if)#exit

9- در روتر، دستورات زیر را برای فعال کردن پروتکل dot1Q encapsulation همراه با شناسه VLAN و پیکربندی آدرس IP 10.0.0.100/8 در interface Fa0 / 0.10 اجرا کنید .

Router(config)#interface fa0/0.10
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 10.0.0.100 255.0.0.0
Router(config-subif)#exit

10 در روتر، دستورات زیر را برای فعال کردن پروتکل dot1Q encapsulation همراه با شناسه VLAN و پیکربندی آدرس IP 20.0.0.100/8 درinterface Fa0 / 0.20 اجرا کنید .

Router(config)#interface fa0/0.20
Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 20.0.0.100 255.0.0.0
Router(config-subif)#exit

11- بعد، دستورات زیر را برای پیکربندی مسیریابی RIP (یا هر نوع دیگر بسته به انتخاب شما) در روتر اجرا کنید .

Router(config)#router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#network 20.0.0.0
Router(config)#exit

شکل زیر  پیکربندی InterVlan Routing روتر را نشان می دهد.

InterVlan Routing

12- این همه چیزی است که شما باید InterVlan Routing را پیکربندی کنید . اکنون، زمان برای تایید پیکربندی شما است . برای انجام این کار دستور Command Prompt را روی PC1 باز کنید و دستورات زیر را برای بررسی اتصال به PC0 تایپ کنید ، همانطور که در شکل زیر نشان داده شده است .

PC>tracert 10.0.0.1
PC>ping 10.0.0.1

InterVlan Routing

13- در شکل قبلی شما می توانید ببینید که PC1 می تواند با PC0 ارتباط برقرار کند . در صورتی که ، هر دو رایانه های شخصی (PC0 و PC1) متعلق به زیر شبکه های مختلف (10.0.0.0/8 و 20.0.0.0/8) و VLAN ها (فروش و حسابداری) هستند. به این عملیات Inter Vlan گفته می شود .

برای آگاهی از قیمت سوئیچ سیسکو ، روی عبارت مورد نظر کلیک کنید .

منبع : networklessons.com

لینک های مفید : آموزش پیکر بندی Vlan سوئیچ سیسکو

5/5 - (1 امتیاز)
0 پاسخ

دیدگاه خود را ثبت کنید

تمایل دارید در گفتگوها شرکت کنید؟
در گفتگو ها شرکت کنید.

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *