نوشته‌ها

آموزش سیسکو استفاده از علامت سوال در CLI

آموزش سیسکو استفاده از علامت سوال در CLI

آموزش سیسکو استفاده از علامت سوال در CLI

آموزش سیسکو استفاده از علامت سوال در CLI : در IOS دستگاه های سوئیچ و روتر، دستورات و پارامتر های زیادی برای تنظیم وجود دارد. بنابراین حفظ و بخاطر سپردنشان دشواراست. استفاده از قابلیت علامت سوال (?) باعث افزایش جذابیت استفاده از cli و همچنین کمک در هنگام فراموشی دستورات می شود.

لیست همه command هایی که می توان در این مد استفاده کرد را نشان می دهد :

?#Router

لیست همه command هایی که حرف اولشان c است را نشان میدهد :

clear , clock , configure , connect , copy

اگر علامت سوال را با فاصله  از command استفاده کنید لیست subcommand های بعدی که می توانید استفاده کنید را نشان می دهد :

? Router#clock

خروجی : set Set the time and date

وقتی command یا دستور کامل شده است و subcommand دیگری برای تنظیم ندارد :

? Router#clock set 10:30:30 december 18 2017

<cr> : خروجی

کوتاه کردن دستورات و استفاده از کلیدTab :

Router>enable یا Router>en یا Router>enab

Router#configure terminal یا Router#conf t

نوشتن بخشی از command و استفاده از کلید Tab باعث کامل شدن command میشود:

Router>en (Tab کلید)
خروجی : Router>enable

Router#conf t (Tab کلید)
خروجی : Router#conf terminal

آشنایی با چند دستور ساده در Router

تغییر نام Router با دستور ، (hostname) :

Router>enable
Router#conf t
Router(config)# hostname R1
R1(config)#

فعال کردن درخواست رمزعبور هنگام ورود به Privileged Mode :

R1>enable
R1#conf terminal
R1(config)# enable password 123456

بهتراست که از enable secret ) command ) ، بجای (enable password) استفاده کرد. بدلیل اینکه (enable secret) با الگوریتم md5 رمزنگاری (hash) شده است .
البته اگر برای هردو enable secret و enable password پسورد تعیین کرده باشید، اولویت با enable secret است و در هنگام درخواست پسورد ، شما باید پسورد enable secret را وارد کنید.

R1(config)# enable secret 123456

البته با دستور service password-encryption هم میتوان همه پسورد های مورد استفاده در ios را بصورت رمزنگاری درآورد. گرچه این روش رمزنگاری، رمزگشایی شده است ولی بهتر از پسورد قابل شنود (sniff) یا واضح (Clear Text) است.

R1(config)# service password-encryption

بدلیل ارتباط مستقیم console به دستگاه، برای برقراری امنیت دسترسی کابر در هنگام ورود از طریق console به cli بهتر است پسورد گذاشته شود. با دستور line console 0 وارد مد config-line می شویم و با دستور password، پسورد دلخواهی می گذارید و حتما بعد از وارد شدن و تعیین پسورد در console line باید با دستور login تنظیمات مربوط را فعال کنید.

Router(config)# line console 0 [عدد صفر شماره پورت کنسول روی دستگاه ] Router(config-line)# password 123456
Router(config-line)# login

نحوه ذخیره تنظیمات در حافظ NVRAM :

هنگامی که در حال تنظیم در ios و مشغول command نویسی هستیم، در واقع در محیط running-config یا حافظ RAM که در حال پردازش است، هستیم و با ریست شدن دستگاه، تنظیمات پاک می شود. بنابراین برای ریست نشدن تنظیمات، نیاز به حافظه ای برای ذخیره سازی است.

startup-config :

محل ذخیره دائمی تنظیمات یا همان حافظ NVRAM است.
با دستور زیر، تنظیمات به ترتیب نوشتن از running-config حافظه RAM به startup-config حافظه NVRAM منتقل و ذخیره می شوند.

R1#copy running-config startup-config

و البته میتوان از دستور write که معادل دستور ” copy running-config startup-config” است، هم استفاده کرد.

R1#write

برای بررسی و مشاهده تنظیمات ، عیب یابی و … میتوانید از (show) در Privileged Mode استفاده کنید:

مشاهده تنظیمات در حال اجرا در running-config

R1#show running-config

مشاهده تنظیمات ذخیره شده در startup-config

R1#show startup-config

پاک کردن تنظیمات از startup-config یا NVRAM :

R1#erase startup-config

یا

R1#write erase

بعد از اجرای erase سوالی برای تایید اطمینان از درخواست پاک شدن تنظیمات پرسیده میشود

Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]y[OK] Erase of nvram: complete

البته هر command یا دستوری که باید در Privileged Mode نوشته شود را می توان با اضافه کردن کلمه (do) به اول هر command ، در Mode Configuration یا (Global) هم نوشت و اجرا کرد.
مثال:

Router(config)# do show running-config
Router(config)# do write

شما میتوانید با دستور reload ، دستگاه Router را بعد از تایید، ریست کنید.

Router#reload
Proceed with reload? [confirm]

مطالب مرتبط با این مقاله:

آموزش دستورات Show در روترهای سیسکو

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت سوم

آموزش سیسکو Cisco قسمت چهارم

آموزش سیسکو Cisco قسمت پنجم

آموزش پیکربندی VLAN سوئیچ سیسکو

آموزش مفاهیم اولیه پل ها سوئیچ های سیسکو

آموزش بکاپ گرفتن از IOS سیسکو و بازیابی آن

آموزش روتینگ سوئیچ لایه سه سیسکو

 

راه اندازی سامانه کلاه سفید

راه اندازی سامانه کلاه سفید

راه اندازی سامانه کلاه سفید :«سامانه کلاه‌سفید» با هدف برگزاری مسابقات ارزیابی امنیتی و کشف باگ و با همکاری مرکز آپای دانشگاه صنعتی امیرکبیر افتتاح شد.

برگزاری مسابقات ارزیابی امنیتی و کشف آسیب‌پذیری به کوشش مرکز آپای دانشگاه صنعتی امیرکبیر در «سامانه کلاه‌سفید» ممکن شد.

کلاه‌سفید، متخصصان ارزیابی امنیتی و سازمان‌هایی را که خواهان ارزیابی امنیتی سامانه‌های خود هستند به هم مرتبط می‌کند.

در مسابقات کشف آسیب‌پذیری، نرم‌افزار یا سامانه در معرض ارزیابی طیف وسیعی از متخصصان قرار می‌گیرد. در این سامانه برای ارزیابی محصول، پورتال یا سامانه موردنظر به‌عنوان یک کاربر سازمانی با ثبت‌نام در سایت، جزییات مسابقه و مبالغ جوایز را مشخص می کند و مبلغی را به‌عنوان جوایز مسابقه در سایت ودیعه می‌گذارد. در صورتی که باگی در سامانه شما کشف شود پس از ارزیابی و تایید آن توسط داوران (آپای امیرکبیر)، مبلغ آن باگ از ودیعه پرداختی کسر و به متخصص پرداخت خواهدشد. درصورتی‌که سامانه امن باشد، تنها مبلغ جزئی برای برگزاری مسابقه پرداخت می‌شود و ودیعه پرداختی قابل عودت یا استفاده برای مسابقات دیگر است.

متخصصان ارزیابی امنیتی و کشف آسیب‌پذیری می‌توانند با مراجعه به سایت و مشاهده مسابقات فعال، اقدام به کشف باگ/آسیب‌پذیری کنند و با گزارش آن، جایزه مربوطه را دریافت کنند.

سامانه کلاه سفید

امنیت اطلاعات یکی از جنبه‌های مهم کسب و کارهای اینترنتی است؛ اهمیت امنیت اطلاعات آنچنان است که در صورت به خطر افتادن آن در بسیاری از موارد تمام کسب و کار از دست می رود. البته امروزه در دنیا با استفاده از سرویس‌های بیمه‌ای سعی می‌شود تا مشتریان کسب و کارها در حداقل ریسک پذیری قرار گیرند. اما به هر صورت با به خطر افتادن امنیت اطلاعات، سود کسب و کارها دچار افت و کاهش ملموس می‌گردد.

در ایران از زمان پیدایش اینترنت و پس از آن با افزایش فرهنگ امنیت اطلاعات، تست‌های امنیتی نیز رواج یافته‌اند، اما همواره این موضوع با یک مشکل بزرگ روبرو بوده است؛ چالش کارایی در قبال هزینه‌های پرداختی. مشکل از آن جا پیدا می‌شود که پس از انعقاد قرارداد تست امنیتی، به هر صورت درصد زیادی و یا همه هزینه می‌بایست در قبال تست پرداخت شود و این درحالی است که ممکن است هیچ‌گونه آسیب‌پذیری کشف نشود و یا اصلا تست مناسبی صورت نگرفته باشد.

سامانه کلاه سفید با فهم این چالش و یافتن راهی برای حل آن پا به عرصه ارایه سرویس گذاشته است.

دراین سامانه شماپس ازبرگزاری یک مسابقه امنیتی،تنهادرصورتی هزینه پرداخت مینماییدکه آسیب‌پذیری کشف گردد.بااین ساختار،شما حداقل هزینه رابابیشترین کیفیت خواهیدداشت.

داوران سامانه کلاه سفید،ازمتخصصین مرکز آپا دانشگاه صنعتی امیرکبیر هستندکه به عنوان متخصصان بیطرف،مواردامنیتی را بررسی می‌کنند.

در صورتی که صحت این موارد احراز گردد، هزینه به فرد تست کننده پرداخت می‌شود.

 

فایل PDF جزئیات مسابقه را از لینک زیر دریافت نمایید:

جزئیات راه اندازی سامانه مسابقات کلاه سفید

راه اندازی سامانه کلاه سفید

منبع خبر: افتانا (پایگاه خبری امنیت فناوری اطلاعات)

تغییر firmware تلفن های سیسکو

تغییر firmware تلفن های سیسکو

تغییر firmware تلفن های سیسکو

تغییر firmware تلفن های سیسکو سریCisco 7900 به sip
تلفن های سیسکو به واسطه فیلتر های قوی صوتی کیفیت صدای فوق العاده ای را در اختیار کاربران قرار می دهند .

سری تلفن های spa سیسکو که برای کسب و کارهای کوچک طراحی و تولید شده اند از پروتکل محبوب sip پشتیبانی می کنند ولی تلفن های سری تجاری مانند سری cisco 7900 series عمدتا دارای پروتکلSCCP هستند. چند سالی هست که سیسکو firmware هایی برای تلفن های این سری با پروتکل sip روی سایت خود قرار داده است. چون تلفن های سیسکو سری تجاری با کال منیجر سیسکو کانفیگ می شوند و به صورت web config نیستند برای تغییر فریمور آن ها باید از طریق tftp فرمیور جدید روی گوشی فلش شده بار گزاری گردد .

همچنین تنظیمات داخلی در فایل cnf قرار داده شده و همراه فریمور روی گوشی بارگزاری گردد.

تغییر فریمور با پروتکل sip و بار گزاری از طریق tftp

در این بخش تلاش داریم روش تغییر فریمور برای تلفن سیسکو Cisco 7960 را برای پروتکل sip و آموزش تنظیمات و بار گزاری از طریق tftp را آموزش دهیم.

ابتدا sip frimwere تلفن cisco ۷۹۶۰ را دانلود نمایید.
حال نام فایل کانفیگ با پسوند cnf را تغییر داده و “????????????” را با مک آدرس گوشی مورد نظر جایگزین نمایید SEP????????????.cnf, SIP????????????.cnf
نکته❗ مک گوشی مورد نظر را میتوانید از منو network setting گوشی، پشت گوشی و یا اگر DHCP Server دارید مک گوشی را در قسمت Leases پیدا و کپی کنید. مانند شکل زیر:

IP Phone MAC

IP Phone MAC

اکنون باید تنظیمات داخلی را روی فایل cnf انجام دهیم. هر جا آدرسip وجود دارد آن را با آدرس سرور sip خود جایگزین نمایید و شماره داخلی و پسورد را در بخش های مربوطه مانند متن زیر وارد نمایید.

image_version: P0S3-8-12-00

line1_name: 232

line1_authname: “232”

line1_shortname: “232” ; displayed on the phones softkey

line1_password: “gf%$#@HJ”

line1_displayname: “Erjaki”; the caller id

proxy1_port: 5060

proxy1_address: ۱۹۲.۱۶۸.۱.۲۵۲

# Phone Label (Text desired to be displayed in upper right corner)

phone_label: “ITTechnical” ; add a space at the end, looks neater

phone_password: “cisco” ; Limited to 31 characters (Default – cisco)

user_info: none

telnet_level: 2

#logo_url: “http://192.168.1.252/admin/images/IT.png”

نکته❗

توجه کنید که فایلی با پسوند sbn در پوشه فریمور وجود دارد که باید نام این فایل را در مقابل image_version کپی کنید.

نکته ❗

مطابق اطلاعات فوق باید یک extention در PBX با پروتکل sip در سرور الستیکس ایجاد گردد و nat آن مانند شکل زیر no باشد.

تنظیمات tftp در بخشglobal

tftpserver & tftpclient & syslogserver & dhcpserver تیک دار باشد .

تنظیمات tftp در بخشglobal

تنظیمات tftp در بخشglobal

درsetting در بخشtftp درbase directory مسیر فولدر فریمور را انتخاب کنید و درbind tftp آدرسip لن کامپیوتر خود را قرار دهید.

درSetting در بخش dhcp تنظیمات زیر را انجام دهید.

ای پی که میخواهیم به ipphone تعلق بگیرد = ip pool starting

Size pool = 5

آی پی لن کامپیوتر = Default router

Mack=255.255.255.0

آی پی لن کامپیوتر & Additional option =25

bind dhcp = آی پی لن کامپیوتر

pind address = بدون تیک

persistant = بدون تیک

در syslog هر دو گزینه تیک دار باشد.

حال پورت سوییچ تلفن ip را به پورت lan وصل نموده( ip لن ترجیحا ip سرور باشد) و لن های دیگر را غیر فعال نمایید.
اکنون زمان آن رسیده تا فریمور را با tftp به گوشی منتقل کنیم .اول باید گوشی را ریست کنیم بنابراین برق گوشی را قطع کرده و روی تلفن کلید “#” را نگه دارید حال برق گوشی را وصل کنید، وقتی led گوشی شروع به خاموش و روشن شدن نمود کد زیر را به ترتیب از چپ به راست برای فلش شدن گوشی وارد نمایید.

۱۲۳۴۵۶۷۸۹*۰#

پیغام keep network configs -۱=yes, 2=no که شما باید دکمه ۲ را فشار دهید.

خوب اگر این مراحل را به درستی انجام داده باشید گوشی بوت شده و فریمور در حال انتقال به گوشی می باشد، اما دو نکته را مورد توجه قرار دهید.

نکته اول:

اگر DHCP Server ندارید بعد از پایان کار انتقال فریمور sip قبل از قطع ارتباط گوشی با tftp از روی گوشی مود dhcp تلفن را غیر فعال کنید.

نکته دوم:

در داخلی های الستیکس که برای این تلفن ها در نظر گرفته اید گزینه nat را غیر فعال کنید.

حال که فریمور به sip تغییر کرد من بعد دیگر برای کانفیگ داخلی دیگری روی این گوشی دیگر نیازی به انجام این مراحل نیستید و لذا برای تغییر داخلی به منو settings رفته و Unlock config را زده و پسورد cisco را وارد میکنید تا قفل تنظیمات باز شود، بعد از باز کردن قفل در منو به مسیر زیر بروید:

settings> Network Configuration Menu> sip Configuration> Line 1

در اینجا باید داخلی را همراه با پسورد وارد کنید و در قسمت پروکسی سرور باید ip سرور را وارد کنید و در آخر تمام تنظیمات را save کنید به این منوال داخلی جدید ست شد.

 

تغییر firmware تلفن های سیسکو

منبع: نت ست

 

 

خطر نفوذ در گوشی ها و لپ تاپ ها

خطر نفوذ در گوشی ها و لپ تاپ ها

خطر نفوذ در گوشی ها و لپ تاپ ها

خطر نفوذ در گوشی ها و لپ تاپ ها :نقص امنیتی در محصولات پرکاربرد سه شرکت‌ معتبر دنیا، اغلب گوشی‌ها و رایانه‌ها را در معرض خطر نفوذ قرار می‌دهد.

محققان، نقص‌های امنیتی را در پردازنده‌های کامپیوتری که توسط سه طراح بزرگ تراشه‌های جهانی یعنی اینتل، AMD و ARM تولید شده، شناسایی کرده‌اند و این یعنی تقریبا هر گوشی‌ هوشمند و رایانه‌ در جهان می‌تواند با داشتن اطلاعات حساس ازجمله رمز عبور، سرقت شود.

سرورهای ابری که وب‌سایت‌ها و سایر اطلاعات اینترنتی را ذخیره می‌کنند نیز در معرض خطرند.

این یکی از بزرگ‌ترین آسیب‌پذیری‌های امنیت‌ سایبری است که ازنظرتاثیربالقوه برسیستم‌های کامپیوتری شخصی،تجاری و زیربنایی دیده ‌شده‌‌است.

چنین نقصی دربخش اساسی کامپیوتر قرارداردوهیچ راهی برای دانستن اینکه آیا یک دستگاه،هدفمند شده یا نه، وجودندارد.

هردونقصSpecter و Meltdownبه‌وسیله یک تکنیک طراحی دراینتل ایجادشده‌ که به‌منظورارتقای عملکردتراشه‌ها،شناخته‌شده وبه عنوان اجرای احتمالی ایجادشده‌‌است.

این بدان معناست که هکرهامی‌توانندبه بخشی ازحافظه کامپیوتردسترسی پیداکنندکه بایدغیرقابل دسترسی باشد.

داده‌های حساسی نظیرکلمه عبور، ایمیل، اسناد و عکس‌ها که در معرض خطر قرار می‌گیرند.

بیشتر حملات سایبری شامل یافتن نقص در نرم‌افزار رایانه‌ای می‌شود که هکرها اجازه دسترسی به حافظه دستگاه یا سیستم‌عامل را می‌دهند. برای مثال، در سال ۲۰۱۷ یک حمله به نام WannaCry یک عیب در نسخه‌های قدیمی ویندوز، ایجاد کرد که در حدود ۱۵۰هزار کشور و ۳۰۰هزار کامپیوتر را تحت‌تاثیر قرار داده و تأثیرات ویران‌کننده‌ای بر شرکت‌ها و سازمان‌ها داشته‌است.

خطر نفوذ در گوشی ها و لپ تاپ ها

اما هکرها می‌توانند با استفاده از دو نقص مذکور از طریق تمام لایه‌های نرم‌افزاری به تراشه پردازنده‌ مرکزی (cpu) که عملکرد اساسی کامپیوترها را انجام می‌دهد، دست‌ یابند. از آنجا که این طرح‌های مشابه توسط تمام سازندگان عمده تراشه‌ها استفاده می‌شود، تقریبا هر کامپیوتر در جهان، ازجمله اپل، دستگاه‌های اندروید، MacBooks، رایانه‌های رومیزی بزرگ و سرورهای اینترنتی می‌تواند تحت‌تاثیر قرار گیرد.

فرایندهای هکری نیز بسیاراساسی است وهیچ ورودی ازعملیات نرم‌افزارهک ایجادنمی‌شود.

به این معنی که هیچ رکوردی در مورد اینکه آیا یک تراشه خاص هک‌ شده یا نه، وجود ندارد.

این امرشناسایی حملات سایبری رادرمراحل اولیه به منظورجلوگیری ازوقوع دوباره آنهایابررسی اینکه چه اطلاعاتی ممکن است به دست آمده یادزدیده شده باشددشوارترمی‌کند.

خوشبختانه، شرکت‌های فناوری قبلاً شروع به انتشار تکه‌های نرم‌افزاری کرده‌اند که می‌گویند مشکلات را بدون تأثیر قابل توجهی در عملکرد، حل خواهند‌کرد، اما برخی ادعا می‌کنند که هرگونه اصلاح می‌تواند به‌طور چشم‌گیری سرعت کامپیوتر را کاهش دهد. از این‌رو باید صبر کرد تا اثر طولانی‌مدت آن‌ را دید.

خطر نفوذ در گوشی ها و لپ تاپ ها

این داستان همچنین یک مسئله مهم در مورد افشای این نقص امنیتی از سوی مسئولان را مطرح می‌کند. گزارش‌ها حاکی است که صنعت، ماه‌ها این مشکل را شناسایی کرده، اما جزییات محدودی از آن تاکنون منتشر شده‌‌است. این در حالی است که مصرف‌کنندگان حق دارند در مورد چنین نقصی در اسرع وقت مطلع شوند تا بتوانند از داده‌های خود محافظت کنند. البته مشکل این است که این امر می‌تواند باعث لو رفتن حملات سایبری توسط هکرها نیز شود.

درگذشته،این بحث باعث شده که شرکت‌های فناوری ازقانون برای جلوگیری ازمحققان درنحوه تشخیص مشکلات امنیتی به‌کارببرند.

به‌عنوان مثال،دانشمندان دانشگاه بیرمنگام تحت فشارقانونی ازتولیدکننده خودرو فولکس واگن مواجه شدندوآن‌هارابه انتشارجزئیات نقص درسیستم‌های ورودی بدون کلیدخودرو واداشتند.

مسیرپیشنهادی«افشای مسئولیت»است.هنگامی که محققان یک مشکل راکشف می‌کنندبه تعدادکمی ازافرادمرتبط اجازه می‌دهندتابرروی یک راه‌حل کارکنند.

پس ازتهیه راه‌حل،سازنده می‌تواندمشکل رابه عموم مردم نشان دهدتاپتانسیل هک کردن وآسیب به قیمت سهام شرکت رابه حداقل برسانند.

خطر نفوذ در گوشی ها و لپ تاپ ها

منبع خبر : پایگاه خبری امنیت فناوری اطلاعات افتانا

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP :پروتکل Rip از نوع Distance Vector می باشد و به طور کلی از الگوریتم مسیر یابی Bellmanford استفاده می کند. این الگوریتم بسیار سبک است و به همین دلیل Load بسیار کمی روی CPU و RAM روتر می اندازد.

مشخصات پروتکل مسیریابی RIP

Administrative Distance (AD) = 120
Metric = Hop Count
در Routing Table با حرف R نشان داده می شود.
Infinite Metric = 16

دو Version نیز دارد که به RIP V1 و RIPv2 معروف است.

در Routing protocol بین روتر ها بسته های update ارسال می شود که شامل اطلاعات مربوط به شبکه هایی است که آن روتر در اختیار دارد.

در RIP V1 بسته های update با خود Subnet mask حمل نمی کنند در نتیجه نسخه اول RIP از subnetting ، supernetting و VLSM پشتیبانی نمی کند و بسته های update به آدرس ۲۵۵.۲۵۵.۲۵۵.۲۵۵ ارسال می شود.

پیاده سازی پروتکل مسیریابی RIP

در RIPv2 بسته های update با خود Subnet mask حمل می کنند پس بر خلاف نسخه اول ، این نسخه از subnetting ، supernetting و VLSM پشتیبانی می کند و بسته های update به آدرس ۲۲۴.۰.۰.۹ که یک آدرس از نوع multicast است ، ارسال می شود.

Update های RIP هر ۳۰ ثانیه یک باربه صورت Full ارسال می شود.

RIP V1 اهراز هویت (Authentication) ندارد.
RIPv2 اهراز هویت ( Authentication ) دارد.
به طور کلی RIP ، Convergence Time بالایی دارد و دید به Topology Table شبکه ندارند در نتیجه مستعد Loop است به همین دلیل این Routing protocol روش هایی برای جلوگیری از Loop در اختیار دارد.

روش های جلوگیری از Loop

Split Horizon بدین معنااست که روتر حق نداردمسیری راکه ازیک روتر دیگرگرفته است دوباره به آن روتر اعلام کند.
Route Poisoning بدین معنا ست که اگر مسیری قطع شده آن مسیر با Infinite Metric=16 نشان داده شود .
Triggered Update بدین معنا است که روتر نباید صبر کند تا زمان Full update ( که هر ۳۰ ثانیه یک بار است) برسد.بلکه هر موقع نیاز به Route Poisoning شد بسته update را در همان لحظه ارسال کند .

Hold down Timer بدین معنا است که هر زمان بسته Update به روتری رسید ۱۸۰ ثانیه صبر کند و سپس تغییرات را در Routing Table خود اعمال کند.
Split Horizon With Poison Reverse بدین معنا است که روتر حق ندارد مسیری را که از یک روتر دیگر گرفته است دوباره به آن روتر اعلام کند مگر اینکه آن مسیر Route Poison شده باشد.
و بدین صورت و بااستفاده ازاین پنج روش RIP قادراست درصورت به وجودآمدن Loopتا حدی ازبروزفاجعه جلوگیری کند.

برای یادگیری دستورات RIP به بررسی یک سناریو می پردازیم.

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

ما می خواهیم با استفاده از روش RIP ارتباط تمامی روتر ها و سوئیچ ها را با یکدیگر برقرار کنیم.در ابتدا باید وارد هر یک از روتر ها شده و اینترفیس های مربوطه را روشن کرده سپس به آن ها IP های مورد نظر را بدهیم و بعد از این config کردن RIP را آغاز می کنیم.

اختصاص IP Address برای اینترفیس های Fast Ethernet و Serial روتر

با استفاده ازدستورات زیردرقسمت CLI روترها بر اساس سناریو آموزش IP های اینترفیس های روتر رواختصاص میدیم:

Router-1:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-2:
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/1
Router(config-if)#ip address 11.11.11.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-3:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 11.11.11.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit

بعد از اختصاص IP ها بر روی اینترفیس روترها حال نوبت به کانفیگ ارتباط این ۲ شبکه و روترها باهم با استفاده از پروتکل RIP هست که برای انجام این کار نیز دستورات زیر را بر روی روترها انجام میدیم:

Router-1
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 172.16.88.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-2
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 11.11.11.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-3
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 192.168.1.0
Router(config-router)#network 11.11.11.0
Router(config-router)#exit

 

پیاده سازی پروتکل مسیریابی RIP

سایر مطالب مرتبط با یان مقاله:

آشنایی با پروتکل RIP

پروتکل OSPF

آموزش مفاهیم مسیریابی

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش پیکربندی پروتکلهای بردار فاصله

پیدا کردن گوشی گم شده اندروید

پیدا کردن گوشی گم شده اندروید

پیدا کردن گوشی گم شده اندروید

گوگل، گوشی گم‌شده شما را می‌یابد

پیدا کردن گوشی گم شده اندروید :گوگل قابلیتی رابرای کاربران اندرویدایجادکرده تابایک جستجوی ساده اینترنتی،گوشی گم‌شده خودرابیابند.
گوگل یک راه ساده و رایگان برای تمام گوشی‌های اندرویدی ارائه کرده است که طبق آن اگر کاربر گوشی اندرویدی خود را در خانه یا محل کار و یا هر مکان دیگری گم کند با یک جست‌وجوی ساده در اینترنت به‌راحتی می‌تواند آن را پیدا کند.

با این قابلیت اگر کاربر گوشی خود را گم کرده باشد، کافی‌ است عبارت «گوشی مرا پیدا کن”FIND MY PHONE”» را در گوگل جست‌وجو کند که باعث می‌شود گوشی شروع به زنگ زدن کند و اگر گوشی در جایی باشد که نتوان صدای زنگ آن را شنید، محل گوشی در نقشه گوگل نمایش داده می‌شود.

برای استفاده ازاین قابلیت گوگل بایدگوشی ورایانه‌ای که باآن جست‌وجو انجام می‌شودبه یک حساب کاربری گوگل متصل و آنلاین باشند.

 

منبع خبر: پایگاه خبری افتانا

حمله بدافزار VPNFilter به کاربران و شبکه های کامپیوتری

حمله بدافزار VPNFilter به کاربران و شبکه های کامپیوتری

حمله بدافزار VPNFilter به کاربران و شبکه های کامپیوتری

VPNFilter یک بدافزار طراحی شده برای آلوده کردن روترها است. تا تاریخ 24 ماه مه 2018 چنین تخمین زده میشود که این بد افزار حدود 500000 تا 1000000 دستگاه روتر را آلوده کرده باشد. این بد افزار قابلیت سرقت اطلاعات را برای مجریان حمله فراهم کرده، و همچنین با داشتن قابلیت کلید مرگ یا (kill switch) این امکان را به شخص حمله کننده میدهد که دستگاه روتر را از کار انداخته و غیر قابل استفاده نماید. پلیس فدرال آمریکا این احتمال را میدهد که این بدافزار توسط گروه حملات سایبری (Fancy Bear (Pawn Storm ایجاد و گسترش داده شده باشد.

بررسی بدافزار VPNFilter نشان میدهد که قابلیت آلوده سازی روترهای صنعتی و همچنین روترهای خانگی و اداری تولید شده توسط شرکتهای Linksys، MikroTik، Netgear، و TP-Link را دارا میباشد.

حذف بدافزار VPNFilter

FBI به کاربران قربانی VPNFilter پیشنهاد کرد که برای حذف این بدافزار، روترهای خود را ری‌ست کنند.

به گزارش افتانا (پایگاه خبری امنیت فناوری اطلاعات)، در پی تحقیقات در مورد بدافزار VPNFILTER که صدها هزار روتر را در سراسر دنیا آلوده کرده‌است، FBI به همه‌ مشتریان و مدیران شرکت‌ها هشدار داد که روترهای خود را ری‌ست کنند تا این بدافزار حذف شود.

VPNFilter می‌تواند روترهای خانگی و شرکت‌های کوچک را به‌طور کامل از کار بیندازد. درضمن این بدافزار می‌تواند از طریق روتر اطلاعات کاربر را بدزدد. به بیان دیگر این بدافزار می‌تواند جاسوسی شما را بکند و یا به‌طور کامل روتر شما را خراب کند. هنوز معلوم نیست که هدف پشت VPNFilter چیست و یا چه کسی آن را ساخته اما FBI گفته که در حال تلاش برای نابودی آن است.

بدافزار VPNFilter

هنوز چیزهای بسیار زیادی درمورد بدافزار VPNFilter نمی‌دانیم. به گفته تیم امنیتی سیسکو، بیش از 500هزار روتر در 54 کشور دنیا آلوده شده‌اند که بیشتر آنها در اوکراین هستند.

دستگاه‌های آلوده‌ شناسایی شده به شرح زیر هستند:

• Linksys E1200
• Linksys E2500
• Linksys WRVS4400N
• Netgear DGN2200
• Netgear R6400
• Netgear R7000
• Netgear R8000
• Netgear WNR1000
• Netgear WNR2000
• QNAP TS251
• QNAP TS439 Pro
• TP-Link R600VPN

هنوز مشخص نیست که چقدر از این دستگاه‌ها دقیقاً در آمریکا، استرالیا، انگلیس، ایران، اکراین و یا هرجای دیگری هستند، اما FBI توصیه کرد که هرکسی که یک روتر در خانه دارد آن را ریبوت کند. البته این توصیه در هر شرایطی خوب و مهم است درنتیجه ارزش آن را دارد که چند دقیقه در یک روز را برای آن وقت بگذارید.

FBI همچنین توصیه کرد که روتر خود را آپدیت کرده و جدیدترین پچ‌های امنیتی سفت‌افزاری را دریافت کنید و رمز خود را نیز تغییر دهید. حتی اگر روتر شما آلوده نیست نیز این کار را انجام دهید.

 

منبع خبر: افتانا (پایگاه خبری امنیت فناوری اطلاعات)

آشنایی با پروتکل RIP

آشنایی با پروتکل RIP

آشنایی با پروتکل RIP

آشنایی با پروتکل RIP :پروتکل Routing Information Protocol یا RIP یکی از قدیمی ترین پروتکل های مسیریابی Distance Vector است که از پارامتر Hop Count به عنوان Metric استفاده می کند.

RIP برای اینکه بتواندازبه وجود آمدن Loopدرفرآیندروتینگ جلوگیری کندمحدودیت تعدادHopهای مجازازمبدابه مقصدرابه عنوان مکانیزم جلوگیری ازLoop قرارداده است.

حداکثرتعدادHopهای مجازدرRIPعدد۱۵است.این محدودیت تعدادHopباعث محدودشدن اندازه شبکه هایی میشودکهRIPازآنها پشتیبانی میکند.

یعنی RIP را نمی توان در شبکه هایی که بیش از ۱۵ عدد Hop یا روتر دارند استفاده کرد.

Hop Count مقدار۱۶به معنی فاصله بینهایت برایRIPدرنظرگرفته میشودبه زبانی دیگریعنیRouteموردنظرازنظرRIPغیرقابل دسترسی درنظرگرفته میشود.

RIP با استفاده ازمکانیزمهای Split Horizon،Route Poisoning و HoldDown ازانتشاراطلاعات Routingاشتباه وپخش شدن چنین اطلاعاتی جلوگیری میکند.

در اصل روترهای RIP درهر۳۰ثانیه یکباراطلاعات خودرابروزرسانی میکنندو Routing Table رادرشبکه منتقل میکنند.

پروتکل RIP

در پیاده سازی های اولیه حجم Routing Table ها اینقدر کم بود که ترافیکی که ناشی از انتقال آن در شبکه به وجود می آمد بسیار ناچیز و کم بود اما با گسترش روز به روز شبکه ها از نظر اندازه و ترافیک کم کم ترافیک مربوط به همین انتقال در هر ۳۰ ثانیه به حجم قابل توجهی می رسید مخصوصا اینکه ترافیک بصورت تصادفی و در وهله های زمانی متفاوت انجام می شد.

شاید به نظر برسد که اگر Routing Table ها در وحله های زمانی مختلف در شبکه منتقل شوند از نظر ترافیکی کارایی بهتری ایجاد می شود اما در عمل اینکار واقعا امکانپذیر نبود.

Sally Floyd و Van Jacobson در سال ۱۹۹۴ اثبات کردند که تصادفی سازی انتقاد اطلاعات با استفاده از مکانیزم Timer در طول زمان باعث یکسان شدن زمان ها یا Synchronize شدن زمان ها می شود.

در بیشتر شبکه های امروزی از RIP به دلیل داشتن Convergence Time بالا در مقایسه با پروتکلهای EIGRP ، OSPF و IS-IS استفاده نمی شود ، در ضمن محدودیت تعداد Hop های قابل استفاده باعث کاهش اندازه شبکه هایی شد که در آن قابل استفاده است.

اما به هر حال پیاده سازی RIP در میان سایر پروتکل های مسیریابی به نسبت بسیار ساده تر است ، RIP بر خلاف سایر پروتکل های مسیریابی دیگر نیازی به هیچ پارامتر خاصی بر روی روتر ندارد.

پروتکل RIP

RIP از User Datagram Protocol یا UDP به عنوان پروتکل انتقال استفاده می کند و یک شماره پورت شناخته شده ( Well Known Port ) به شماره ۵۲۰ را به خود اختصاص داده است.

RIP معمولادرشبکه های کوچک ازقبیل LANیامجموعه ای ازLANهای کوچک که تشکیل یکCampus Area Networkراداده انداستفاده میشود.

برای مثال اگر ازشرکت سیستم افزار خاورمیانه یک مجموعه ستادی در استان تهران داشته باشد که چندین ساختمان در سطح شهر تهران داشته باشد می تواند از RIP برای این شبکه استفاده کند.

از RIP به عنوان یک پروتکل Interior Routing یا مسیریابی داخلی یاد می شود.

RIP توانایی تشخیص تغییرات را برای ارسال در هر بار انتقال routing Table ندارد و به همین دلیل در هر بار اشتراک گذاری Routing Table همه اطلاعات به یکباره منتقل می شود و قابلیت Incremental Update برای اینکار وجود ندارد.

هر روتر همسایه اطلاعات را برای روتر همسایه دیگر ارسال می کند و به همین ترتیب اطلاعات در همه شبکه و روترها پخش می شود تا همه روترهای مجموعه Network Convergence را تشکیل دهد.

انواع نسخه های RIP :

Version 1 :
Version 2
RIPng (RIP next generation) :

ویژگی های RIP version 1 :

یک پروتکل Classful است و از VLSM پشتیبانی نمی کند.
دارای امکان Authentication ( احراز هویت) نیست.
Advertisement ها را به صورت Broadcast ارسال می کند.

ویژگی های RIP version 2 :

در سال ۱۹۹۳ ارائه شد.
یک پروتکل Classless است و از VLSM پشتیبانی می کند.
امکان Authentication ( احراز هویت) را دارد
Advertisement ها را به جای Broadcast به صورت multicast به آدرس ۲۲۴.۰.۰.۹ ارسال می کند.

ویژگی های RIPng :

پشتیبانی از IPv6
از پروتکل UDP با شماره پورت ۵۲۱ استفاده می کند.

.

 

آشنایی با پروتکل RIP

منبع :جعفر قنبری شوهانی

 

سایر مطالب مرتبط با یان مقاله:

پروتکل OSPF

آموزش مفاهیم مسیریابی

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش پیکربندی پروتکلهای بردار فاصله

iStock-843534370-620x349-min

آسیب‌پذیری پروتکل UPnP در برابر حملات DDOS

آسیب‌پذیری پروتکل UPnP در برابر حملات DDOS

آسیب‌پذیری پروتکل UPnP در برابر حملات DDOS :دانشمندان نوع جدیدی ازحملات اختلال سرویس توزیع شده راشناسایی کرده‌اند که شناسایی پورت‌های منبع راباچالش روبه‌رو می‌کند.

به گزارش پایگاه خبری امنیت فناوری اطلاعات،پژوهشگران نسبت به شیوه جدیدی ازحملات اختلال سرویس توزیع‌شده(DDOS)هشداردادندکه همه شرکت‌های دارای فعالیت‌های آنلاین را تهدیدمی‌کند.

در شیوه جدید یاد شده از آسیب‌پذیری موجود در پروتکل شبکه «UPnP» استفاده شده‌است.

درنتیجه مهاجمان می‌توانندروش‌های معمول شناسایی‌شدن رادوربزنند. حملات از طریق پورت‌های منبع نامنظم انجام می‌شوند، درنتیجه محافظت در مقابل حوادث آینده به‌وسیله شناسایی مبدا و تهیه فهرست سیاه از پورت‌ها سخت‌تر خواهدشد.

محققان شرکت امنیتی IMPERVA، این حمله را شناسایی کردند. تاکنون هکرهای ناشناس دو مرتبه از آن بهره گرفته‌اند.

ازپروتکلUPnPبرای شناسایی دستگاه‌های موجوددرشبکه استفاده می‌شود؛به‌ویژه ابزارهای اینترنت اشیا،ابزارهای اینترنت که ازآن برای یافتن یکدیگروارتباط برقرارکردن دریک شبکه محلی استفاده می‌کنند.

با وجود موارد شناخته‌شده در مورد تنظیمات پیش‌فرض ضعیف، عدم تایید هویت و اجرای از راه دور کدهای مخرب، این پروتکل همچنان مورد استفاده قرار می‌گیرد. همین مسئله باعث آسیب‌پذیر شدن ابزارها می‌شود.

اَویشی زاوزنیک (Avishay zawoznik)، رهبر گروه تحقیقات امنیتی IMPERVA، گفت:

درست مانند بسیاری از مباحث پیرامون ابزارهای اینترنت اشیایی که به‌سادگی از آن سوءاستفاده می‌شود.

بیشتر فروشندگان دستگاه‌های upnp ترجیح می‌دهند به جای امنیت، روی انطباق با پروتکل و تحویل آسان آن تمرکز کنند.

زاوزنیک ادامه داد:بسیاری ازفروشندگان به‌منظور انجام تنظیمات امنیتی بهتر،خودرابه دردسرنمی‌اندازند؛بلکه برای تنظیم مجددآنهاازسرورهای متن‌بازUPnPاستفاده می‌کنند.

با این حال محققان imperva ادعا می‌کنندکشف چگونگی استفاده ازحملات DDOS با بهره‌گیری ازپروتکل بالابه معنی ایجادمشکلات گسترده‌تر است.

وی افزود: ما یک شیوه جدید حمله اختلال سرویس توزیع شده کشف کردیم. در این روش از آسیب‌پذیری‌های شناخته‌شده، بهره گرفته‌می‌شود.

این مسئله همه شرکت‌هایی را که فعالیت آنلاین دارند با خطر مواجه می‌کند.

به گزارش پایگاه خبری امنیت فناوری اطلاعات

محققان در ماه آوریل، هنگام رخ دادن یک حمله به پروتکل «SSDP» متوجه مسئله‌ای جدید شدند.

آنها نوعی بات‌نت را شناسایی که کردند که آدرس آی‌پی ابزارهای قربانی را جعل می‌کند.

این کار به منظور پرس‌و‌جو از دستگاه‌های رایج متصل به اینترنت مانند مسیریاب‌ها ، چاپگرها و نقاط دسترسی صورت می‌گیرد.

در حالی که بیشتر حملات از پورت رایج ۱۹۹۰ SSDP بهره می‌گیرند، ۱۲ درصد آنها از منابع تصادفی انجام می‌شوند. کارشناسان Imperva متوجه شدند به‌منظور مخفی کردن اطلاعات پورت منبع می توان از حملات ادغام شده در UPnP استفاده کرد.

هکرها به‌راحتی می‌توانند ابزارهای مجهز به اینترنت اشیا موردنظر خود را با استفاده از موتور جست‌وجوی «Shodan» پیدا کنند.

پژوهشگران بیش از ۱.۳ میلیون ابزار آسیب‌پذیر را با کمک این موتور شناسایی کردند.

همچنین اگر فردی از اسکریپت‌ها برای شناسایی خودکار تجهیزات یاد شده بهره بگیرد، این عمل سریع‌تر خواهدشد.

رهبر گروه تحقیقات امنیتی IMPERVA توضیح داد: برای اینکه قربانی این موضوع نباشیم، کسب‌و‌کارها نباید به‌منظور محافظت از خود در برابر حملات اختلال سرویس توزیع شده، تنها روی پورت‌های منبع تمرکز کنند؛

بلکه باید شیوه‌ای بر پایه بسته‌های اطلاعاتی بارگذاری شده نیز ایجاد شود.

محققان خاطرنشان کردند برای محافظت از سیستم‌ها در برابر آسیب‌پذیری‌های UNPnP یک شیوه ساده وجود دارد.

تنها کافی است جلوی دسترسی ازراه دوربه دستگاه گرفته شود؛زیرااین ویژگی دربیشترمواردهیچ قابلیت مفیدی رابه کاربران ارائه نمی‌دهد.

منبع : افتنا

آیا اختلال تلگرام کار هکرهای روس است

آیا اختلال تلگرام کار هکرهای روس است

آیا اختلال تلگرام کار هکرهای روس است

آیا اختلال تلگرام کار هکرهای روس است ؟! اختلال در تلگرام حدس و گمان‌هایی درباره دخالت هکرهای دولتی روس در این ماجرا را مطرح کرده‌است.

به گزارش پایگاه خبری امنیت فناوری اطلاعات،برخی کاربران پس ازساعت‌هااختلال به تلگرام وصل شدند،اما قادربه ارسال پیام نیستند.

هنگام ارسال پیام درنسخه موبایل باپیامToo Many Requestsروبرو می‌شویم که این پیام ازسروربه معنای ترافیک غیرعادی وبیش‌ازحداست.

معمولاً این نوع ترافیک غیرعادی با حملات موسوم به DDOS روی سرور رخ می‌دهد و اگر اظهارنظر رسمی دوروف در مورد overheating سرور آمستردام را قبول کنیم، ارسال بیش‌ازحد درخواست به سرورها باعث شده‌است تا سی پی یو کلاسترها در بیراهه درگیر شده و داغ کنند.

بر این اساس ممکن است گیت‌هاب و سایر سرورهای هندل‌کننده نرم‌افزار با یک حمله تعریف‌شده از طریق بات‌های خودکار روبرو شده‌باشند که این قطعی پس از تهدیدهای کرملین و فیلترکردن تلگرام توسط رگلاتور روس، می‌تواند معنای حمله را تداعی کند.

هرچند مقامات روس دوروف را تهدید کرده‌اند، اما بستن ۲۰ میلیون آی‌پی آدرس و اختلال نیمی از ترافیک اینترنت در روسیه باعث نشده‌است که کاربران دست از تلگرام بردارند.

طبق آمار، دسترسی‌ فقط ۳ درصد از کاربران تلگرام در روسیه پس از فیلترشدن این پیام‌رسان، قطع ‌شده‌است.

منبع : افتنا