نوشته‌ها

پروتکل های مسیریابی - Dynamic Routing سیسکو

پروتکل های مسیریابی Dynamic Routing سیسکو

پروتکل های مسیریابی Dynamic Routing سیسکو

پروتکل های مسیریابی Dynamic Routing سیسکو: پروتکل های مسیریابی به سه دسته Distance Vector و Link State و Hybrid تقسیم می‌شوند. ابتدا در قسمت اول مقاله درباره‌ی پروتکل های مسیریابی Distance Vector صحبت خواهیم کرد. سپس به توضیح و بسط دو پروتکل دیگر می‌پردازیم.

پروتکل های مسیریابی Distance Vector

این نوع روتینگ، جزو ساده‌ترین پروتکل های مسیریابی به شمار می‌رود. همان‌طور که از نام آن مشخص است؛ از دو فاکتور Distance یا مسافت و Vector یا جهت، برای پیدا کردن مقصد استفاده می‌کند.

روترهایی که از پروتکل های مسیریابی Distance Vector استفاده می‌کنند، به روترهای همسایه یا Neighbor خود اطلاع رسانی می‌کنند. این داده‌ها شامل اطلاعاتی از قبیل توپولوژی شبکه و تغییراتی که در بازه‌های زمانی متفاوت انجام می‌شود؛ هستند. نحوه‌ی ارتباط با استفاده از Broadcast انجام می‌شود و از آدرس IP به شکل 255.255.255.255 استفاده می‌کند.

پروتکل های مسیریابی Distance Vector از الگوریتم Bellman-Ford برای پیدا کردن بهترین مسیر جهت رسیدن به مقصد استفاده می‌کند. روترهای مورد استفاده در توپولوژی Distance Vector، برای دست‌یابی به اطلاعات موجود در Routing Table های روترهای همسایه، درخواست Broadcast می‌کنند. در نهایت از این اطلاعات برای به روز رسانی Interface خود استفاده می‌کنند. همچنین برای به اشتراک گذاری اطلاعات Routing Protocol خود، از ساختار Broadcasting بهره می‌برند.

نحوه‌ی فعالیت

الگوریتم‌های Distance Vector تغییراتی را که در Routing Table انجام می‌شود، بلافاصله برای روترهای همسایه خود ارسال می کنند. این اطلاعات بر روی تمام Interface ها منتشر می‌شود. با هر تبادلی که انجام می‌شود، روتر Distance Value مربوط به مسیر دریافت شده را افزایش می‌دهد. سپس Distance Value خودش را هم بر روی Route های جدید قرار می‌دهد. روتری که این تغییرات را دریافت می‌کند به همین ترتیب Route های خودش را بر روی این Table قرار می‌دهد. به همین شکل برای روترهای باقی‌مانده نیز ارسال می‌کند و این فرآیند تا آخرین روتر ادامه می‌یابد.

در Distance Vector به این موضوع توجه نمی‌شود که چه کسی به Update هایی که ارسال می‌شود؛ گوش می‌کند. نکته جالب این است که پروتکل های مسیریابی Distance Vector در صورتی که هیچ تغییری در Routing Protocol خود نداشته باشند نیز به صورت متناوب Routing Table خود را Broadcast می‌کنند. یعنی اگر توپولوژی شبکه تغییر نکرده باشد هم Broadcasting انجام می‌شود.

پیاده‌سازی و رفع عیب این نوع پروتکل بسیار ساده است. روتر برای انجام فرآیندهای پردازشی نیاز به منابع بسیار کمتری دارد. منطق کاری Distance Vector ساده است. این پروتکل Routing Update را دریافت می‌کند، مقدار Metric را افزایش می‌دهد، نتایج را با مقادیر موجود در Routing Table خود مقایسه می‌کند و در صورت نیاز Routing Table را Update می‌کند. پروتکل‌هایی مثل Routing Information Protocol یا RIP نسخه یک و Interior Gateway Routing Protocol یا IGRP از مهم‌ترین و معروف‌ترین پروتکل های مسیریابی Dynamic Routing در روترهای امروزی هستند.

پروتکل های مسیریابی Link State

در این بخش، پروتکل های مسیریابی Link state را معرفی می‌کنیم و تفاوت‌های آن را با پروتکل های Distance Vector شرح خواهیم داد. پروتکل های Link State بر خلاف پروتکل های Distance Vector، شبکه‌ها را در قالب Hop Count و تعداد روترهای موجود در آن نمی‌بینند. در عوض یک دیدگاه جامع و کامل در خصوص توپولوژی های مورد استفاده در شبکه ایجاد می‌کنند که همه جزئیات شبکه‌های موجود در توپولوژی را در خود دارد. تمامی روترها با Cost های آن‌ها در این دید جامع و کامل وجود خواهند داشت.

در پروتکل های Link State هر یک از روترهایی که از یکی از این پروتکل‌ها استفاده کند؛ اطلاعات کاملی در خصوص خود روتر، لینک‌های مستقیم متصل شده به آن و وضعیت آن لینک‌ها را در اختیار شبکه قرار می‌دهد. این اطلاعات توسط پیام های Multicast به همه روترهای موجود در شبکه ارسال می‌شود. این عمل بر خلاف پروتکل های مسیریابی Distance Vector است که آن را به وسیله استفاده از فرآیند Broadcast انجام می‌دادند.

فرآیند مسیریابی Link State به گونه ای است که با ایجاد کوچک‌ترین تغییر در توپولوژی شبکه‌های موجود، این تغییرات بلافاصله به صورت Incremental برای سایر روترها هم ارسال می‌شود تا توپولوژی شبکه روی همه روترها همیشه به‌روز باشد.

هر کدام از روترهای موجود در پروتکل های مسیریابی Link state یک کپی از این توپولوژی را در خود دارند و آن را تغییر نمی‌دهند. پس از آن‌که آخرین تغییرات شبکه‌ها را دریافت کردند، هر روتر به صورت مستقل به محاسبه بهترین مسیر برای رسیدن به شبکه‌ی مقصد می‌پردازد.

ویژگی پروتکل های مسیریابی Link State

پروتکل های مسیریابی Link State بر اساس الگوریتمی به نام Shortest Path First یا SPF برای پیدا کردن بهترین مسیر جهت رسیدن به مقصد، پایه‌ریزی شده‌اند. در الگوریتم SPF زمانی که وضعیت یک لینک ارتباطی تغییر می‌کند، یک Routing Update که به عنوان Link-State Advertisement یا LSA شناخته می‌شود ایجاد می‌شود. این به‌روزرسانی بین تمامی روترهای موجود تبادل خواهد شد.

هنگامی که روتری LSA Routing Update را دریافت می‌کند؛ الگوریتم Link-State با استفاده از آن، کوتاه‌ترین مسیر را برای رسیدن به مقصد مورد نظر محاسبه می‌کند. هر روتر برای خود یک نقشه کامل از شبکه‌ها ایجاد می‌کند. نمونه‌ای از پروتکل مسیریابی Link-State پروتکلی به نام Open Shortest Path First یا OSPF است.

کلید واژه‌های مهم در پروتکل های Link State:

  • Link-State Advertisement یا LSA: یک Packet کوچک اطلاعاتی است که اطلاعات مربوط به Routing را بین روترها رد و بدل می‌کند
  • Topological Database: مجموعه اطلاعاتی که از LSAها دریافت می‌شود
  • الگوریتم SPF یا Dijkstra: الگوریتمی است که محاسبات database های موجود در SPF Tree را انجام می‌دهد
  • Routing Table: یک لیست از مسیرها و Interface های شناسایی شده است

مزایا و معایب

پروتکل های مسیریابی Link State در عین حال که به مدت زمان کمتری برای Converge شدن نسبت به پروتکل های مسیریابی Distance Vector برخوردارند؛ در مقابل ایجاد Routing Loop هم نسبت به Distance Vector مقاوم‌تر هستند. به ندرت Routing Loop در Link State ایجاد می‌شود. از طرفی الگوریتم‌های مورد استفاده در پروتکل های Link State به قدرت پردازشی CPU و حافظه RAM بیشتری نسبت به پروتکل های Distance Vector نیاز دارند. پروتکل های Link State از یک ساختار سلسله مراتبی و موروثی استفاده می‌کنند که این ساختار باعث کاهش فاصله‌ها و نیاز کمتر به انتقال LSA می‌شود.

پروتکل های مسیریابی Link State از مکانیسم Multicast برای به اشتراک گذاری اطلاعات استفاده می‌کنند. تنها روترهایی که از پروتکل های مسیریابی Link State استفاده می‌کنند این Routing Update ها را می‌توانند پردازش کنند.

Link State ها فقط زمانی اطلاعات روتر را ارسال می‌کنند که در شبکه تغییری ایجاد شده باشد. در نهایت فقط همان تغییر را برای سایر روترها ارسال می‌کنند. پیاده‌سازی پروتکل های مسیریابی Link State پیچیده‌تر و پر هزینه‌تر از پیاده‌سازی پروتکل‌های Distance Vector است. هزینه‌ی نگهداری آن‌ها نیز به مراتب بیشتر است.

پروتکل های مسیریابی Dynamic Routing سیسکو

منبع: گیک بوی

راه اندازی DHCP بر روی سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو: DHCP یکی از پر کاربرد ترین سرویس های شبکه است که در خفا و پس زمینه مسئول اختصاص آدرس های IP به کلاینت های شبکه است. این سرویس جزء لاینفک شبکه های بزرگ و کوچک بوده و از ابتدایی ترین تراکنش های ارتباطی در شبکه های LAN است.

DHCP سرور

DHCP سرور

هنگامی که شما یک کلاینت را به یک شبکه مرتبط می‌کنید و یا با یک سرور PPP ارتباط برقرار می‌کنید؛ پس از احراز هویت دریافت آدرس IP از ابتدایی ترین واکنش هاست. استفاده از DHCP علاوه بر افزایش کارایی شبکه به افزایش چشمگیر امنیت در شبکه های مبتنی بر سیسکو می انجامد. بدین ترتیب که به عنوان یک مدیر شبکه امکان مدیریت و رصد مشکلات به سادگی امکان پزیر است و همچنین از مشکلاتی نظیر IP Conflict و دسترسی غیر مجاز به آدرس های IP جلوگیری به عمل می آید. پیاده سازی DHCP بر روی روتر ها و سویئچ های سیسکو به سادگی امکان پذیر بوده و ترافیک و لود چندانی را به دستگاه تحمیل نمینماید.

راه اندازی DHCP بر روی سوئیچ سیسکو

شروع کار:

توصیه می‌شود ابتدا یک دیتابیس برای نگهداری واگذاری آدرس های IP ایجاد و دسترسی FTP به آن را میسر نمایید.

Router(config)# ip dhcp database ftp://user:password@172.16.1.1/router-dhcp timeout 80

جلوگیری از اعطای آدرس های 100 تا 103:

Router(config)# ip dhcp excluded-address 172.16.1.100 172.16.1.103
Router(config)# ip dhcp pool 1
Router(dhcp-config)# utilization mark high 80 log
Router(dhcp-config)# network 172.16.0.0 /16
Router(dhcp-config)# domain-name rootlan #domain name
Router(dhcp-config)# dns server 217.218.127.127 217.218.155.155 #dci dns servers
Router(dhcp-config)# default-router 172.16.1.100 172.16.1.101 #this is the Gateway address
Router(dhcp-config)# option 19 hex 01 #additional dhcp option code for example tftp address
Router(dhcp-config)# lease 30 # the lease amount

بدین ترتیب امکان استفاده از امکانات DHCP بر روی روتر و سوئیچ های سیسکو میسر میگردد البته امکانات پیشرفته تری نیز وجود داره که در صورت نیاز میتوانید از آنها استفاده کنید لازم به توضیح است استفاده از سرویس DHCP بر روی شبکه های VLAN که دارای Access Switch و Core Switch هستند بر روی سوئیچ های لایه دسترسی توصیه میشود.

اگر به هر دلیلی مایل به استفاده از دیتابیس جهت ثبت واگذاری IP نبودید میتوانید از این کامند استفاده نمایید:

Router(config)# no ip dhcp conflict logging

توسط این دستور می‌توانید میزان استفاده از منابع IP را مشاهده کنید:

Router(config)# ip dhcp use class

راه اندازی DHCP بر روی سوئیچ سیسکو

شاید این موارد نیز مورد علاقه شما باشد:

پیاده سازی پروتکل مسیریابی RIP

آسیب‌پذیری پروتکل UPnP در برابر حملات DDOS

پروتکل OSPF

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش پیکربندی پروتکلهای بردار فاصله

پروتکل های مسیریابی Classful vs Classless

پروتکل ISL انحصاری شرکت سیسکو

تغییر firmware تلفن های سیسکو

مفهوم SDN

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP :پروتکل Rip از نوع Distance Vector می باشد و به طور کلی از الگوریتم مسیر یابی Bellmanford استفاده می کند. این الگوریتم بسیار سبک است و به همین دلیل Load بسیار کمی روی CPU و RAM روتر می اندازد.

مشخصات پروتکل مسیریابی RIP

Administrative Distance (AD) = 120
Metric = Hop Count
در Routing Table با حرف R نشان داده می شود.
Infinite Metric = 16

دو Version نیز دارد که به RIP V1 و RIPv2 معروف است.

در Routing protocol بین روتر ها بسته های update ارسال می شود که شامل اطلاعات مربوط به شبکه هایی است که آن روتر در اختیار دارد.

در RIP V1 بسته های update با خود Subnet mask حمل نمی کنند در نتیجه نسخه اول RIP از subnetting ، supernetting و VLSM پشتیبانی نمی کند و بسته های update به آدرس ۲۵۵.۲۵۵.۲۵۵.۲۵۵ ارسال می شود.

پیاده سازی پروتکل مسیریابی RIP

در RIPv2 بسته های update با خود Subnet mask حمل می کنند پس بر خلاف نسخه اول ، این نسخه از subnetting ، supernetting و VLSM پشتیبانی می کند و بسته های update به آدرس ۲۲۴.۰.۰.۹ که یک آدرس از نوع multicast است ، ارسال می شود.

Update های RIP هر ۳۰ ثانیه یک باربه صورت Full ارسال می شود.

RIP V1 اهراز هویت (Authentication) ندارد.
RIPv2 اهراز هویت ( Authentication ) دارد.
به طور کلی RIP ، Convergence Time بالایی دارد و دید به Topology Table شبکه ندارند در نتیجه مستعد Loop است به همین دلیل این Routing protocol روش هایی برای جلوگیری از Loop در اختیار دارد.

روش های جلوگیری از Loop

Split Horizon بدین معنااست که روتر حق نداردمسیری راکه ازیک روتر دیگرگرفته است دوباره به آن روتر اعلام کند.
Route Poisoning بدین معنا ست که اگر مسیری قطع شده آن مسیر با Infinite Metric=16 نشان داده شود .
Triggered Update بدین معنا است که روتر نباید صبر کند تا زمان Full update ( که هر ۳۰ ثانیه یک بار است) برسد.بلکه هر موقع نیاز به Route Poisoning شد بسته update را در همان لحظه ارسال کند .

Hold down Timer بدین معنا است که هر زمان بسته Update به روتری رسید ۱۸۰ ثانیه صبر کند و سپس تغییرات را در Routing Table خود اعمال کند.
Split Horizon With Poison Reverse بدین معنا است که روتر حق ندارد مسیری را که از یک روتر دیگر گرفته است دوباره به آن روتر اعلام کند مگر اینکه آن مسیر Route Poison شده باشد.
و بدین صورت و بااستفاده ازاین پنج روش RIP قادراست درصورت به وجودآمدن Loopتا حدی ازبروزفاجعه جلوگیری کند.

برای یادگیری دستورات RIP به بررسی یک سناریو می پردازیم.

پیاده سازی پروتکل مسیریابی RIP

پیاده سازی پروتکل مسیریابی RIP

ما می خواهیم با استفاده از روش RIP ارتباط تمامی روتر ها و سوئیچ ها را با یکدیگر برقرار کنیم.در ابتدا باید وارد هر یک از روتر ها شده و اینترفیس های مربوطه را روشن کرده سپس به آن ها IP های مورد نظر را بدهیم و بعد از این config کردن RIP را آغاز می کنیم.

اختصاص IP Address برای اینترفیس های Fast Ethernet و Serial روتر

با استفاده ازدستورات زیردرقسمت CLI روترها بر اساس سناریو آموزش IP های اینترفیس های روتر رواختصاص میدیم:

Router-1:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-2:
Router(config)#interface serial0/0
Router(config-if)#ip address 10.10.10.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/1
Router(config-if)#ip address 11.11.11.1 255.255.255.0
Router(config-if)#clack rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit

Router-3:
Router(config)#interface fastehernet0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial0/0
Router(config-if)#ip address 11.11.11.2 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#exit

بعد از اختصاص IP ها بر روی اینترفیس روترها حال نوبت به کانفیگ ارتباط این ۲ شبکه و روترها باهم با استفاده از پروتکل RIP هست که برای انجام این کار نیز دستورات زیر را بر روی روترها انجام میدیم:

Router-1
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 172.16.88.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-2
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 11.11.11.0
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

Router-3
Router(config)#router rip 
Router(config-router)#net
Router(config-router)#network 192.168.1.0
Router(config-router)#network 11.11.11.0
Router(config-router)#exit

 

پیاده سازی پروتکل مسیریابی RIP

سایر مطالب مرتبط با یان مقاله:

آشنایی با پروتکل RIP

پروتکل OSPF

آموزش مفاهیم مسیریابی

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش پیکربندی پروتکلهای بردار فاصله

پروتکل OSPF

پروتکل OSPF

پروتکل OSPF

پروتکل OSPF :پروتکل مسیریابی OSPF پروتکل قدرتمند و پرطرفداری است که در RFC 2328 شرح داده شده است. این پروتکل برای پیدا کردن Neighbor یا در واقع روترهای متصل به خود  از Hello Message استفاده میکند. پیام Hello به آدرس Multicast 224.0.0.5)AllSPFRouters) ارسال میگردد اگر در رسانه ای خاص Multicast قابل استفاده نباشد، از Unicast استفاده میکند (در این حالت آدرس همسایه باید از قبل تنظیم شده باشد).

آشنایی با پروتکل OSPF

پروتکل مسیریابی Open Shortest Path First که به اختصار OSPF نامیده می شود یک پروتکل مسیریابی Link state است که میتواند ترافیک های مربوط به پروتکل IP را مدیریت کند. پروتکل OSPF نسخه های مختلفی دارد که در حال حاضر از نسخه ۲ آن بیشتراستفاده می شود.OSPF بصورت انحصاری توسط شرکت ها ارائه میشوند و یک پروتکل کاملا جامع و بدون وابستگی به هیچ برند خاصی است ، تقریبا همه روترهایی که در دنیا وجود دارند از پروتکل OSPF پشتیبانی می کنند.

پروتکل مسیریابی Open Shortest Path First یا پروتکل OSPF از الگوریتم Shortest Path First یا SPF که توسط Dijkstra طراحی شده است برای جلوگیری از به وجود آمدن Routing Loop در توپولوژی شبکه ها استفاده می کند و به نوع یک شبکه Loop Free ایجاد می کند. پروتکل OSPF فرآیند Convergence سریعی دارد و از طرفی قابلیت Incremental Update را نیز با استفاده ازLSA یا Link State Advertisement فراهم می کند. پروتکل مسیریابی OSPF یک پروتکل Classless است و به شما این اجازه را می دهد که برای طراحی یک ساختار سلسله مراتبی شبکه از VLSM و Route Summarization به راحتی استفاده کنید.

معرفی پروتکل OSPF

معرفی پروتکل OSPF

معایب پروتکل OSPF

مهمترین معایبی که در پروتکل OSPF وجود دارد این است که OSPF برای نگهداری لیست OSPF Neighbor ها ، توپوپولوژی شبکه که شامل یک دیتابیس از تمامی روترها و Route های موجود در آنهاست و همچنین Routing Table خود روتر به حافظه RAM نسبتا بیشتری در مقایسه با پروتکل های Distance Vector نیاز دارد.همچنین پروتکل OSPF به قدرت پردازشی یا CPU بیشتری برای اجرا کردن الگوریتم SPF نیاز دارد و همین موارد باعث می شود که OSPF در رده بندی پروتکل های مسیریابی پیچیده یا Complex Protocol قرار بگیرد. دو مفهوم بسیار مهم در مواردی که می خواهید از پروتکل OSPF استفاده کنید وجود دارند که اولین مفهوم Autonomous System و دومین مفهوم Area می باشد.

تنظیمات اولیه در OSPF

Area در OSPF برای ایجادکردن ساختارمسیریابی سلسله مراتبی یا موثری(Hierarchical Routing)در یک Autonomous System استفاده میشود. Area ها تعیین کننده این هستندکه چگونه وبه چه اندازه اطلاعات مربوط بهRoutingبایستی درشبکه به اشتراک گذاشته شود. OSPF دولایه وراثت یاHierarchyدارد،لایهBackboneیاArea 0 ولایه های خارج ازBackboneیاAreaهای بین عدد۱تا۶۵۵۳۵،این دوAreaای متفاوت هستندکه میتوان دربین آنهااطلاعات مسیریابی راSummarizeکرد. RouteSummarizationبه ما کمک میکندکه بتوانیم Routing Tableهای خودرافشرده سازی وکوچکترکنیم.تمامی Areaها بایستی بهArea 0متصل شوندوتمامی روترهادراینAreaازیک توپولوژی یکسان استفاده میکنند.

 

 

سایر مطالب مرتبط با یان مقاله:

آموزش مفاهیم مسیریابی

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش پیکربندی پروتکلهای بردار فاصله

 

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

تا به اینجای کار با نحوه پیکر بندی چندین پروتکل از نوع بردار فاصله (DV) آشنا شدید. حال در این فصل از سری مقاله های آموزش سیسکو به مباحث پیشرفته تری در مورد پروتکل های مسیریابی خواهیم پرداخت.

پروتکل هایی که در این فصل به آنها میپردازیم شامل OSPF و EIGRP است.

لینک دانلود: پیکربندی پروتکل های مسیریابی پیشرفته

فرمت: PDF

حجم: 1.62 MB

 

فصل اول آشنایی با سوئیچ سیسکو

فصل دوم مدیریت سوئیچ و روتر سیسکو

فصل سوم آموزش اولیه مفاهیم پل ها و سوئیچ های سیسکو

فصل چهارم آموزش پیکربندی VLAN سوئیچ سیسکو

فصل پنجم آموزش مفاهیم مسیریابی

فصل ششم آموزش پیکربندی پروتکل های بردار فاصله

مطالب مرتبط:

پروتکل های مسیریابی Classful vs Classless

روش های سوئیچینگ و مسیریابی در شبکه های محلی