کاربردها و انواع فایروال

کاربردها و انواع فایروال

کاربردها و انواع فایروال :فایروال مانع انتقال آتش از قسمتی به قسمت دیگر را firewall میگویند. به ‌طور کلی یک فایروال اطلاعاتی که بین کامپیوترها و اینترنت انتقال پیدا می کند همیشه کنترل می شود.

فایروال چیست؟

فایروال از کامپیوتر شما در مقابل ترافیک و دسترسی افراد دیگر به آن از شما محافظت می‌کند. مناطق اولیه فایروال به این ترتیب است که اجازه می‌دهند ترافیک سالم عبور کند و مقابل ترافیک ناسالم می‌ایستد.

یکی از مهم‌ترین بخش‌های فایروال خصوصیت کنترل دستیابی آن است که ترافیک سالم و ناسالم را از یکدیگر متمایز می‌کند.

فایروال NAT ساده

فایروال‌هایی که برای broadband router ها به وجود آمده‌اند و نرم‌افزارهایی مانند Microsoft ICS فایروال‌های بسیار ساده‌ای هستند.

این فایروال‌ها شبکه را با جلوگیری از ارتباط مستقیم هر کامپیوتر با کامپیوترهای دیگر محافظت می‌کنند.

در این نوع فایروال‌ها تقریبا هیچ هکری نمی‌تواند به آن‌ها آسیب بزند.

هکرهای حرفه‌ای امکان دارد موفق شوند از این فایروال‌ها عبور کنند، اما تعداد آن‌ها کم و احتمال آن ضعیف است.

فایروال‌هایی با ویژگی stateful packet inspection

نسل جدید فایروال‌های خانگی stateful packet inspection نامیده می‌شوند.

این‌ یک نوع پیشرفته از فایروال است که هر پاکت اطلاعاتی را که از فایروال عبور می‌کند بررسی می کند.

فایروال هر پکت اطلاعاتی را برای ردیابی هر نوعی از هک اسکن می‌کند.

بسیاری از افراد هیچ‌وقت با این نوع حمله‌ها برخورد نمی‌کنند اما مناطقی در اینترنت هست که بیشتر موردحمله هکرهای حرفه‌ای هستند.

کاربردهای پراهمیت یک فایروال قوی و مناسب

توانایی ثبت و اخطار :

ثبت وقایع یکی از مشخصه‌های بسیار مهم یک فایروال به‌حساب می‌آید و به مدیران شبکه این امکان را می‌دهد که انجام حملات را زیر نظر داشته باشند.

همین‌طور مدیر شبکه قادر است با کمک اطلاعات ثبت‌شده به کنترل ترافیک ایجادشده توسط کاربران مجاز بپردازد.

در یک روش ثبت مناسب، مدیر می‌تواند به‌آسانی به بخش‌های مهم از مطالب ثبت‌شده دسترسی پیدا کند.

همین‌طور یک فایروال خوب علاوه بر ثبت وقایع، باید بتواند در شرایط بحرانی، مدیر شبکه را از اتفاقات مهم باخبر و برای او اخطار ارسال نماید.

بازدید حجم بالایی از بسته‌های اطلاعات:

از آزمودن‌های یک فایروال، قادر بودن آن در بازدید حجم بالایی از بسته‌های اطلاعاتی بدون کم شدن قابل‌توجه از کارایی شبکه است. حجم داده‌ای که یک فایروال قادر است کنترل کند برای شبکه‌های مختلف متفاوت است ولی یک فایروال قطعا نباید به گلوگاه شبکه تحت محافظتش تبدیل شود.

دلایل مختلفی در سرعت پردازش اطلاعات توسط فایروال نقش دارند. بیشترین محدودیت‌ها از طرف سرعت پردازنده و بهینه‌سازی کد نرم‌افزار بر کارایی فایروال تحمیل می‌شوند.

از عوامل محدودکننده دیگر می‌تواند کارت‌های واسطی باشد که بر روی فایروال نصب می‌شوند.

فایروالی که بعضی کارها مانند صدور اخطار، کنترل دسترسی مبنی بر URL و بررسی وقایع ثبت‌شده را به نرم‌افزارهای دیگر می‌دهد از سرعت و کارایی بیشتر و بهتری برخوردار است.

سادگی پیکربندی:

سادگی پیکربندی مانند امکان راه‌اندازی سریع فایروال و مشاهده سریع خطاها و مشکلات است.

در حقیقت خیلی از مشکلات امنیتی که دامن‌گیر کامپیوترها می‌شود به پیکربندی اشتباه فایروال مربوط است.

پس پیکربندی سریع و آسان یک فایروال ، امکان به وجود آمدن خطا را کم می‌کند.

مثلا امکان نمایش گرافیکی معماری شبکه و یا ابزاری که قادر باشد سیاست‌های امنیتی را به پیکربندی ترجمه کند ، برای یک فایروال بسیار اهمیت دارد.

 

کاربردها و انواع فایروال

منبع: نت ست

 

شاید این موارد نیز مورد علاقه شما باشد:

بررسی فایروال Cisco ASA (قسمت اول)

بررسی فایروال Cisco ASA (قسمت دوم)

کتاب آموزش ISA Server

کتاب مانیتورینگ و مدیریت شبکه

مدل های مختلف سیستم عامل سیسکو

دستورات پیکربندی سوئیچ سیسکو

معرفی SSH Tunneling

تکنولوژی TrustSec Cisco

کاربردها و انواع فایروال

 

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو :همانطور که گفته شد پروتکل های مسیریابی به سه دسته Distance Vector و Link State و Hybrid تقسیم بندی می شوند ، در این نکته قصد داریم پروتکل های مسیریابی یا روتینگ Distance Vector که ساده ترین نوع پروتکل های مسیریابی هستند را برای شما تشریح کنیم. همانطور که از نام اینگونه پروتکل ها نیز پیداست از دو فاکتور Distance یا مسافت و Vector یا جهت برای پیدا کردن مقصد استفاده می کنند. روترهایی که از پروتکل های مسیریابی Distance Vector استفاده می کنند به روترهای همسایه یا Neighbor های خود در خصوص توپولوژی شبکه و تغییراتی که در وهله های زمانی متفاوت انجام می شود اطلاع رسانی می کنند ، این اطلاع رسانی با استفاده از Broadcast انجام می شود و از آدرس IP ای به شکل 255.255.255.255 برای اینکار استفاده می کند.

پروتکل های Distance Vector از الگوریتم Bellman-Ford برای پیدا کردن بهترین مسیر برای رسیدن به مقصد استفاده می کنند.

روترهای مورداستفاده درتوپولوژی های Distance Vector برای اینکه ازاطلاعات موجوددرRouting Tableهای روترهای همسایه خودمطلع شوندبررویInterfaceهای خوددرخواست راBroadcastمیکنند.

همچنین این پروتکل ها برای Share کردن اطلاعات Routing Protocol خود نیز از ساختار Broadcasting استفاده می کنند.

معرفی پروتکل های مسیریابی Distance Vector

الگوریتم های Distance Vector تغییراتی که در Routing Table انجام می شود را بلافاصله برای روترهای همسایه خود در همه جهات ( روی همه Interface ) ارسال می کنند. با هر تبادلی که انجام می شود ، روتر Distance Value مربوط به Route دریافت شده را افزایش می دهد و Distance Value خودش را نیز بر روی Route های جدید قرار می دهد. روتری که این تغییرات یا Update ها را دریافت می کند نیز به همین ترتیب Route های خودشان را بر روی این Table قرار می دهند و برای روترهای باقی مانده ارسال می کنند ، این فرآیند به همین شکل ادامه پیدا می کند.

پروتکل های مسیریابی Distance Vector

پروتکل های Distance Vector به این موضوع توجه نمی کنند که چه کسی به Update هایی که ارسال می شوند گوش می کند ، جالب اینجاست بدانید پروتکل های Distance Vector حتی در صورتیکه هیچ تغییری در Routing Protocol خود نداشته باشند نیز بصورت متناوب Routing Table خود را Broadcast می کنند ، یعنی حتی اگر توپولوژی شبکه شما تغییر هم نکرده باشد Broadcasting انجام می شود.

پروتکل های Distance Vector ساده ترین نوع از پروتکل های مسیریابی یا Dynamic Routing هستند که در مجموعه سه تایی که عنوان شد قرار می گیرند. پیاده سازی و رفع ایراد این نوع از پروتکل ها بسیار ساده است ، همچنین روتر برای انجام فرآیند های پردازشی نیاز به منابع بسیار کمتری دارد. منطق کاری Distance Vector ها ساده است ، آنها Routing Update ها را دریافت می کنند ، مقدار Metric را افزایش می دهند ، نتایج را با مقدادیر موجود در Routing Table خود مقایسه می کنند و در صورت نیاز Routing Table را Update می کنند. پروتکل هایی مثل Routing Information Protocol یا RIP نسخه یک و Interior Gateway Routing Protocol یا IGRP از مهمترین و معروف ترین پروتکل های Dynamic Routing موجود در روترهای امروزی می باشند.

معرفی پروتکل های مسیریابی Link State

در اینجا قصد داریم به شما پروتکل های مسیریابی Link state را معرفی کنیم و تفاوت های آن با پروتکل های Distance Vector را نیز عنوان کنیم. پروتکل های Link State بر خلاف پروتکل های Distance Vector شبکه ها را در قالب Hop Count و تعداد روترهای موجود در آن نمی بینند در عوض یک دیدگاه جامع و کامل در خصوص توپولوژی های مورد استفاده در شبکه ایجاد می کنند که همه جزئیات شبکه های موجود در توپولوژی را در خود دارد ، تمامی روترها با Cost های آنها در این دید جامع و کامل وجود خواهند داشت.

در پروتکل های Link State هر یک از روترهایی که از یکی از پروتکل های Link State استفاده می کند اطلاعات کاملی در خصوص خود روتر ، لینک های مستقیم متصل شده به آن و وضعیت آن لینک ها را در اختیار شبکه قرار می دهد. این اطلاعات توسط پیام های Multicast به همه روترهای موجود در شبکه ارسال می شود دقیقا بر خلاف پروتکل های مسیریابی Distance Vector که اینکار را به وسیله استفاده از فرآیند Broadcast انجام می دادند. فرآیند مسیریابی Link State به گونه ای است که با ایجاد شدن کوچکترین تغییری در توپولوژی شبکه های موجود بلافاصله این تغییر بصورت Incremental برای سایر روترها هم ارسال می شود تا توپولوژی شبکه روی همه روترها همیشه بروز باشد.

هر کدام از روترهای موجود در شبکه های Link State یک کپی از این توپولوژی شبکه را در خود دارند و آن را تغییر نمی دهند ، بعد از اینکه آخرین تغییرات شبکه ها را دریافت کردند هر روتر بصورت کاملا مستقل به محاسبه بهترین مسیرها برای رسیدن به شبکه های مقصد می پردازد.

معرفی پروتکل های مسیریابی Link State

پروتکل های مسیریابی Link State بر اساس الگوریتمی به نام Shortest Path First یا SFP برای پیدا کردن بهترین مسیر برای رسیدن به مقصد پایه ریزی شده اند. نام دیگر این الگوریتم Dijkstra است. در الگوریتم Shortest Path First یا SPF زمانیکه وضعیت یک لینک ارتباطی تغییر می کند ، یک Routing Update که به عنوان Link-State Advertisement یا LSA شناخته می شود ایجاد می شود و بین تمامی روترهای موجود تبادل می شود.

زمانیکه یک روتر LSA Routing Update را دریافت می کند ، الگوریتم Link-State با استفاده از آن کوتاه ترین مسیر را برای رسیدن به مقصد مورد نظر محاسبه می کند. هر روتر برای خود یک نقشه کامل از شبکه ها ایجاد می کند. نمونه ای از پروتکل مسیریابی Link-State پروتکل ای به نام Open Shortest Path First یا OSPF است.

چند واژه مهم در خصوص پروتکل های Link State وجود دارد که بد نیست با آنها آشنا شوید:

Link-State Advertisement یا LSA :

یک Packet کوچک اطلاعاتی است که در آن اطلاعات مربوط به Routing بین روترها رد و بدل می شود

Topological Database :

مجموعه اطلاعاتی که از LSA ها دریافت می شود

الگوریتم SPF یا Dijkstra :

الگوریتمی است که محاسبات بر روی database های موجود در SPF Tree را انجام می دهد

Routing Table :

یک لیست از مسیرها و Interface های شناسایی شده است.

پروتکل های مسیریابی Link State در عین اینکه به مدت زمان کمتری برای Converge شدن نسبت به پروتکل های مسیریابی Distance Vector برخوردارند در مقابل بوجود آمدن Routing Loop هم نسبت به Distance Vector ها مقاوم تر هستند و کمتر موردی پیش می آید که Routing Loop در پروتکل های Link State ایجاد شود. اما از طرفی دیگر الگوریتم های مورد استفاده در پروتکل های Link State به قدرت پردازشی CPU و حافظه RAM به نسبت پروتکل های Distance Vector نیاز دارند. پروتکل های Link State از یک ساختار سلسله مراتبی و موروثی استفاده می کنند که این ساختار باعث کاهش فاصله ها و نیاز کمتر به انتقال LSA ها می شود.

پروتکل های Link State ازمکانیزم Multicast برای اشتراک گذاری اطلاعات مسیریابی استفاده می کنند.

فقط روترهایی که از پروتکل های مسیریابی Link State استفاده می کنند این Routing Update ها را پردازش می کنند.

Link State ها فقط زمانی اطلاعات روتر را ارسال می کنند که در شبکه تغییری ایجاد شده باشد و صرفا همان تغییر را برای سایر روترها ارسال می کنند ، پیاده سازی پروتکل های مسیریابی Link-State پیچیده تر و پر هزینه تر از پیاده سازی پروتکل های Distance Vector می باشد و هزینه نگهداری آنها نیز به نسبت بیشتر است.

 

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

منبع: گیک بوی

 

شاید این موارد نیز مورد علاقه شما باشد:

مفهوم Dynamic Routing در روتر سیسکو

پیاده سازی پروتکل مسیریابی RIP

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش مفاهیم مسیریابی

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پروتکل های مسیریابی Classful vs Classless

آموزش تنظیم IP روتر و سوئیچ سیسکو

پیاده سازی Protected Port در سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو

آموزش SNMP در روتر و سوئیچ های سیسکو

آشنایی با پروتکل RIP

پروتکل OSPF

معرفی پروتکل های مسیریابی Dynamic Routing سیسکو

مفهوم Dynamic Routing در روتر سیسکو

مفهوم Dynamic Routing در روتر سیسکو

مفهوم Dynamic Routing در روتر سیسکو :Static routingاین قابلیت رابه مدیریت شبکه میدهدکه بتواندبصورت دستی یک سریRouteهای خاص رادرRouting Tableروترایجادکند.

Dynamic Routing از پروتکل های مسیریابی یا Routing Protocol برای شناسایی شبکه ها و مقصدها و همچنین پیدا کردن بهترین مسیر برای رساندن بسته اطلاعاتی به مقصد استفاده می کنند.

مفهوم Dynamic Routing در روتر سیسکو

Dynamic Routing این قابلیت را به Routing Table می دهد که بتواند زمانیکه یک Router خاموش است یا در دسترس نیست یا اینکه یک شبکه جدید به مجموعه اضافه می شود این تغییرات را در Routing Table ها اضافه کند. Dynamic Routing با استفاده از Routing Protocol ها این قابلیت را دارند که بصورت مستمر با شبکه تبادل اطلاعات داشته باشند و وضعیت هر یک از Router های شبکه را بررسی کنند و با استفاده از Broadcast و یا Multicast با هم ارتباط برقرار کنند و اطلاعات Routing Table را بروز کنند. با این روش همیشه توپولوژی شبکه بروز باقی می ماند و همگی دستگاه های روتر شبکه از آخرین Routing Table بروز استفاده می کنند. از پروتکل های Dynamic Routing می توان به Routing Information Protocol یا RIP ، Enhanced Interior Gateway Routing Protocol یا EIGRP و Open Shortest Path First یا OSPF اشاره کرد.

 

 

Dynamic Routing

Dynamic Routing

اما بصورت کلی ما Routing Protocol ها ره به سه دسته کلی تقسیم بندی می کنیم:

Routing Protocol های Distance-Vector :

پروتکل های Distance Vector از معیار Hop Count یا تعداد روترهای مسیر برای Metric در Routing Table های خود استفاده می کنند. الگوریتم مورد استفاده در اینگونه از پروتکل ها بسیار ساده است و Routing Table با محاسبات ساده ریاضی ایجاد می شود. پروتکل های Distance Vector معمولا برای شبکه های کوچکی که کمتر از 16 عدد Router در آنها وجود دارد مورد استفاده قرار می گیرند در واقع این نوع پروتکل ها با کم کردن تعداد Router های مسیر از به وجود آمدن Loop در شبکه یا بهتر بگوییم Routing Loop در شبکه جلوگیری می کنند.

این پروتکل ها در وهله های زمانی معین Routing Table های خود را با یکدیگر یکسان سازی می کنند ، یکی از مشکلات الگوریتم های Distance Vector در این است که کلیه اطلاعات موجود در Routing Table را حتی با کوچکترین تغییر برای سایر روترهای مجموعه ارسال می کنند و Incremental Update را در واقع پشتیبانی نمی کردند که در نسخه های جدید الگوریتم های Distance Vector این مشکل حل شد. الگوریتم های مسیریابی مثل RIPv1 و IGRP از این نوع Routing protocol ها هستند.

Routing Protocol های Link-State :

در پروتکل های Routing ای که بصورت Link State کار می کنند تفاوت محسوسی با حالت Distanced Vector وجود دارد. الگوریتم های مورد استفاده در این نوع پروتکل ها نسبت به Distanced Vector ها کاملا متفاوت عمل می کند و دارای پیچیدگی های خاص خود می باشد، در این الگوریتم ها از فاکتورهایی مثل Hop Count ، فاصله ، سرعت لینک و ترافیک بصورت همزمان برای تعیین بهترین مسیر و بهترین cost برای انجام عملیات Routing استفاده می شود. آنها از الگوریتمی به نام Dijkstra برای تعیین پایینترین cost برای Route ها استفاده می کنند.

روترهایی که از پروتکل های Link State استفاده می کنند فقط زمانی Routing Table های همدیگر را یکسان سازی می کنند که چیز جدیدی به Routing Table یکی از Router ها اضافه شده باشد. به همین دلیل هم کمترین ترافیک را در هنگام یکسان سازی Routing Table با همدیگر ایجاد می کنند. الگوریتم های مسیریابی مثل OSPF و IS-IS از این نوع پروتکل های Link State هستند.

Routing Protocol های Hybrid :

همانطور که از نام این نوع پروتکل Routing نیز پیداست این نوع پروتکل ترکیبی از پروتکل های Distance Vector و Link State است و در واقع مزایای هر یک از این نوع پروتکل ها را در خود جای داده است. زمانیکه صحبت از قدرت پردازشی روترها می شود از قابلیت های Distance Vector ها (به دلیل پردازش کمتر) و زمانیکه صحبت از تبادل Routing Table ها در شبکه می باشد از قابلیت های Link State ها استفاده می کند. امروزه تقریبا همه شبکه های بزرگ در دنیا از پروتکل های Hybrid استفاده می کنند ، الگوریتم مسیریابی مثل EIGRP از انواع پروتکل های Hybrid Routing هستند.

 

مفهوم Dynamic Routing در روتر سیسکو

منبع: گیک بوی

 

شاید این موارد نیز مورد علاقه شما باشد:

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

آموزش روتینگ سوئیچ لایه سه سیسکو

روش های سوئیچینگ و مسیریابی در شبکه های محلیش

پیاده سازی پروتکل مسیریابی RIP

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش مفاهیم مسیریابی

پروتکل های مسیریابی Classful vs Classless

آموزش تنظیم IP روتر و سوئیچ سیسکو

مفهوم Dynamic Routing در روتر سیسکو

آموزش ساختن Sub Interface در روتر سیسکو

آموزش ساختن Sub Interface در روتر سیسکو

آموزش ساختن Sub Interface در روتر سیسکو :sub interface در واقع همان vlan هائیست که ما بر روی یک پورت روتر سیسکو متصل به ترانک تعریف میکنیم. به بیان دیگر برای دسترسی به vlan های تعریف شده روی یک سوئیچ سیسکو و استفاده از inter vlan Routing توسط روتر میبایست یک اینترفیس روتر به یک پورت ترانک trunk از سوئیچ متصل شده و ساب اینترفیس ها با شماره متناظر vlan ها روی آن تعریف شود.

روتر های سیسکو

روتر های سیسکو برای ارتباطات trunk از 2 پروتکل که یکی مختص تجهیزات سیسکو و دیگری استاندارد جهانی است پشنیبانی میکنند.

اولی ISL یا همان Cisco Inter-Switch Link است که پروپایوتری سیسکو است در واقع پروتکل ‌vlan Encapsulation مختص سیسکو است که فقط توسط دستگاه های خود سیسکو و شاید بعضی دیوایس های دیگر پشتیبانی شود.

البته ISL با اقبال عمومی روبرو نشد و در حال حاضر اکثرا از پروتکل دوم به نام 802.1Q که استاندارد جهانی است استفاده میکنند. اصولا در صنعت کامپیوتر معدود استاندارهای proprietary شرکت های خاص به موفقیت نایل شد از جمله شرکت apple که سرسختانه بر سر مواضع خود ایستاد و توانست یک استاندارد اختصاصی برای خود داشته باشد و هیچ الزامی با سازگاری با دیگر تولید کنندگان نرم افزار و سخت افزار ندارد! و این خود سیاستی است بس خطر ناک برای وابسته کردن مشتری!

برای مثال پروتکل EIGRP – IGRP سیسکو که بسیار قوی تر از OSPF است باز هم به دلیل اینکه فقط توسط خود روتر های و سوئیچ های سیسکو پشتیبانی میشود در اسکیل های بزرگ استفاده نمیشود برای مثال روتینگ داخلی شبکه ایران به دلیل استفاده از دیوایس های مختلف مثلا سیسکو، هواوی، جونیپر و … و یک دست نبودن در حال حاضر بر روی OSPF قرار دارد که به نظر من از EIGRP ضعیف تر عمل میکند! که البته این خود باعث عدم وابستگی به یک سکوی خاص و برند خاص میشود.

آموزش ساختن Sub Interface در روتر سیسکو

خب با توجه به مطالب بالا dot1Q یا همان 802.1q پروتکل رایج برای vlan encapsulation است. برای کانفیگ vlan ها بر روی روتر سیسکو ابتدا یک اینترفیس را به یک پورت ترانک از سوئیچی که میخواهیم از vlan های تعریف شده روی آن استفاده کنیم متصل کرده و بدین ترتیب عمل میکنیم:

router(config)#int gig 0/0
router(config-if)#description Trunk interface
router(config-if)#exit
router(config)#int gig 0/0.10 # 10 is vlan number that determine in switch
router(config-if)#encapsulation dot1Q 10
router(config-if)#ip add 192.168.1.1 255.255.255.0
router(config-if)#exit
router(config)#int gig 0/0.20
router(config-if)#encapsulation dot1Q 20
router(config-if)#ip add 192.168.2.0 255.255.255.0
router-sub-interface
router sub interface

کافیست پورت gig 0/0 روتر به یک پورت ترانک از سوئیچ مربوطه متصل و vlan های 10-20 و .. روی آن تعریف شده باشد، هر کلاینت میباید gateway خود را IP روی اینترفیس روتر ست کند که ترافیک خارج از subnet برای route شدن به سمت روتر ارسال شود.

آموزش ساختن Sub Interface در روتر سیسکو

 

منبع : گیک بوی

 

شاید این موارد نیز مورد علاقه شما باشد:

تعویض پورت پیش فرض تلنت در روتر سیسکو

دسترسی Telnet به روتر سیسکو

مدیریت سوئیچ روتر سیسکو

مراحل بوت شدن روتر سیسکو

آموزش تنظیم IP روتر و سوئیچ سیسکو

آموزش SNMP در روتر و سوئیچ های سیسکو

مراحل Boot کردن روتر های سیسکو

برگرداندن روتر یا سوئیچ سیسکو به تنظیمات کارخانه

اینترفیس های روتر و سوئیچ سیسکو

آموزش دستورات Show در روترهای سیسکو

راه اندازی SSH در سوئیچ ها و روتر های سیسکو

دستورات تنظیمات روتر و سوئیچ سیسکو

آموزش ساختن Sub Interface در روتر سیسکو

آموزش روش های ایمن سازی تجهیزات سیسکو

آموزش روش های ایمن سازی تجهیزات سیسکو

آموزش روش های ایمن سازی تجهیزات سیسکو :میخواهیم در این مقاله 10 دستور کارردی جهت ایمن سازی تجهیزات سیسکو معرفی کنیم.

آموزش روش های ایمن سازی تجهیزات سیسکو

۱- تعیین طول پسورد

با استفاده از دستور زیر شما می توانید طول پسوردهای ورودی در سیسکو را مدیریت کنید. این نکته لازم به ذکر است که سعی کنید حداقل از طول 8 کارکتر جهت بالا بردن امنیت تجهیزات خود استفاده نمایید.

(Router (config) #security passwords min-length 8 ( Minimum length of all user/enable passwords

✅طول پسورد را می توان از صفر تا 16 کاراکتر مشخص کرد.

۲- استفاده از دستور Enable Secret

همانظور که می دانید یکی از دستوراتی که خیلی در پیکربندی تجهیزات سیسکو استفاده می شود دستور enable password است اما به علت مشکل امنیتی و عدم کد گذاری پسورد پیشنهاد می شود از دستور Enable Secret استفاده کنید.

*Router (config) #enable secret cisco123

۳- قراردادن پسورد درراه های دسترسی به تجهیزات

ما جهت دسترسی به تجهیزات سیسکو روش های مختلفی از قبیل vty , Comsole , aux … داریم که برای بالا بردن امنیت تجهیزات سیسکو خود می بایست پسورد مناسبی جهت دسترسی به آن ها قرار دهیم تا از دسترسی افراد سودجو به تجهیزات جلوگیری کنیم.

۴- فعال سازی سرویس کدگذاری پسوردها

با استفاده از سرویس password encryption به صورت خودکار تمام رمزهای مشخص شده کد گذاری می شوند.

Router (config) #service password-encryption

۵- غیرفعال کردن Password Recovery

همانطور که می دانید امکان Password Recovery در محیط Rommon در تجهیزات سیسکو وجود دارد که این قابلیت در محیط های که تجهیزات در محیط های امنی از لحاظ فیزیکی وجود ندارند می تواند بسیار خطرناک باشد زیرا هکر به راحتی می تواند با استفاده از این قابلیت به تجهیزات ما دسترسی پیدا کند. با استفاده از دستور زیر می توانید این قابلیت را غیر فعال کنید.

Router (config) # no Service Password Recovery

۶- محدودیت در تعداد دفعات وارد کردن پسورد

یکی از روشهای هک استفاده از حملات کرکینگ است که در این روش هکر به صورت مکرر از یک دیکشنری جهت وارد کردن پسورد استفاده می کنند از این رو ما باید برای ورود پسوردها محدودیت ایجاد کنیم برای این امر از دستور زیر استفاده می کنیم.

Router (config) # Security authentication failure rate 5

با توجه به دستور بالا اگر 5 بار پسورد اشتباه زده شود 15 ثانیه وقفه در دادن پسورد ایجاد می شود.

۷- محدودیت زمان کار نکردن کاربر با تجهیزات

(Router (config) #line console 0 (Vty or Aux
(Router (config-line) #exec-timeout 2 (Min) 30 (Sec

با توجه به دستور بالا در صورتی که کاربر 2 دقیقه 30 ثانیه کانفیگی انجام ندهد ارتباط قطع می شود و باید مجددا متصل شویم.

۸- محدودیت تعداد دفعات لاگین اشتباه در یه بازده زمانی خاص

Router (config) #login block-for 30 attempts 5 within 10

در کد بالا اگر کاربری در 10 ثانیه 5 بار اشتباه پسورد را وارد کند به مدت 30 ثانیه بلاک می شود.

۹- مخفی کردن فایل Boot

جهت بالابردن امنیت تجهیزات سیسکو ، فایل boot خود را با استفاده از دستور بالا می توانید مخفی کنید.

Router(config)#secure boot-image

۱۰- ایجاد پشتیبان مخفی از کانفیگ تجهیزات

Router(config)#secure boot-config

منبع: گیک بوی

آموزش روش های ایمن سازی تجهیزات سیسکو

 

 

شاید این موارد نیز مورد علاقه شما باشد

آموزش روش های ایمن سازی تجهیزات سیسکو

دستورات پیکربندی سوئیچ سیسکو

دستورات تنظیمات روتر و سوئیچ سیسکو

آموزش تنظیم IP روتر و سوئیچ سیسکو

بازنشانی پیکربندی سوئیچ های سیسکو به پیش فرض کارخانه

آموزش SNMP در روتر و سوئیچ های سیسکو

دسترسی Telnet به روتر سیسکو

راه اندازی SSH در سوئیچ ها و روتر های سیسکو

آموزش روش های ایمن سازی تجهیزات سیسکو

آموزش تنظیم IP روتر و سوئیچ سیسکو

آموزش تنظیم IP روتر و سوئیچ سیسکو

آموزش تنظیم IP روترو سوئیچ سیسکو  :تنظیم IP روتر سیسکو و یا ست کردن IP روتر و یا اختصاص IP به روتر سیسکو و یا سوئیچ سیسکو اولین گام در راه اندازی قابلیت های مسیریابی routing و دسترسی از طریق آدرس دهی IP به روتر سیسکو و یا سوئیچ سیسکو است.

تنظیم IP Address مختص تجهیزات سیسکو که در لایه سه کار میکنند از قبیل سوئیچ لایه سه سیسکو و یا روتر سیسکو ، الزاما نیست، چراکه برای دسترسی های مدیریتی میبایست اقدام به ست کردن IP بر روی سوئیچ لایه دو سیسکو نیز نمود کما اینکه سوئیچ های لایه 2 سیسکو فاقد امکان مسیریابی IP هستند.

تنظیم IP روتر سیسکو، اولین گام در عملیاتی نمودن روتر سیسکو و یا سوئیچ سیسکو است چرا که ما در شبکه های IP با Subnet ها سر و کار داریم و در واقع هر شبکه محدود به یک سابنت (اصلی) است بدین مفهوم که هر اینترفیس محدود به Broadcast Domain همان Network که در آن آدرس دهی شده است میباشد و پکت های میبایست برای رسیدن به مقصد مسیریابی شوند که این نکته فرق اصلی روتینگ و بریجینگ است. در Bridging ما محدود به یک مدیا که همچنین محدود به یک تکنولوژی لایه دو که همه در یک Broadcast Domain هستند میشویم لکن در شبکه لایه سه یا یک Routed Network ، ما با Subnet ها سر و کار داریم و همچنین یک پکت ممکن است برای رسیدن به مقصد از انواع رسانه ها و تکنولوژی های لایه 2 با MTU های مختلف و مدیوم های متفاوت عبور کند.

در حقیقت روتر جدول مسیریابی یا همان دید خود از شبکه را از سه طریق میسازد:

1. شبکه های متصل به اینترفیس هایش Prefix – Subnet هایی که در وضعیت Connected یعنی تعریف شده روی اینترفیس های حقیقی و یا مجازی روتر (همین بحث ما که مربوط به تنظیم IP روی اینترفیس های روتر سیسکو) است.

2. Static Route ها.

3. Route هایی که از طریق کارکرد Routing Protocol ها بدست می آورد نظیر OSPF – EIGRP BGP و …

آموزش تنظیم IP روتر و سوئیچ سیسکو

بنابراین تعریف IP بر روی اینترفیس روتر سیسکو اولین و مهمترین قدم برای عملیاتی کردن یک روتر سیسکو است. کمی از بحث اصلی دور شدیم منتها پرداختن به مفهوم و تفاوت های اصلی شبکه های لایه 2 و شبکه های لایه سه و فرق عملیات Routing – روتینگ و Bridging – بریجینگ و همچنین تاثیر مهم شبکه های Connected بر روی صحت عملکرد روتر میتواند دید شفاف تری نسبت به این امر را حاصل نماید برای مثال اگر شما یک Prefix معروف مثل 8.8.8.0/24 که یکی از DNS های معروف و پر استفاده عمومی ست را روی یکی از اینترفیس های روتر خود ست کنید (مثلا 8.8.8.1/24)

زمانی که از پشت روتر سعی کنید 8.8.8.8 را پینگ کنید به RTO برخواهید خورد چرا که روتر در جدول مسیریابی میبیند که این سابنت به شکل Connected است لذا درخواست را به سمت Gateway خود نمیفرستد حتی اگر این Prefix توسط یک Routing Protocol در جدول مسیریابی نوشته شده باشد به دلیل اینکه Connected Route ها بالاترین ارزش و کمترین Metric را دارند باز هم Packet ها به سمت مقصد هدایت نخواهد شد.

روتر سیسکو و یا سوئیچ سیسکو و کلا هر دیوایس لایه 3 با پروتکل های لایه 3 قابل آدرس دهی (در اینجا IP) سر و کار دارند لذا همانطور که ابتدا اشاره شد قدم اول برای راه اندازی روتر سیسکو اختصاص آدرس IP به اینترفیس روتر سیسکو – اینترفیس سوئیچ سیسکو است در واقع پس از آدرس دهی ست که روتر سیسکو موقعیت خود را تشخیص و شبکه متصل به اینترفیس خود را شناسایی کرده و سپس میتواند به تبادل Packet و انجام عملیات مسیریابی و تشکیل جدول مسیریابی Routing table بپردازد.

دراین مقاله برای جلوگیری ازپیچیدگی مابه روش اختصاص IP به چند اینترفیس متداول روتر و سوئیچ سیسکو میپردازیم.

اختصاص IP به اینترفیس اترنت روتر سیسکو:

روتر سیسکو اغلب به شکل پیشفرص دارای یک یا چند اینترفیس اترنت Ethernet یا فست اترنت Fast Ethernet و یا Gigabit Ethernet هستند شما میتوانید برای آگاهی از اینترفیس های روتر سیسکو از این دستور استفاده کنید:

show interface summary

همانگونه که از خروجی دستور show interface sum پیداست لیست انواع اینترفیس های روتر اعم از اینترفیس های فیزیکی از قبیل Serial – OC3 – Ethernet و مجازی از قبیل Sub Interface و Tunnel و loopback نمایش داده میشوند.

برای تنظیم IP روتر سیسکو برای اینترفیس های فیزیکی نظیر FastEthernet – Ethernet – GigabitEthernet بدین ترتیب عمل مینماییم:

R1>en
Password: 
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z
R1(config)#int gi 0/1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit

برای انواع دیگراینترفیس های اترنت نیزروال به همین صورت است فقط میبایست نام آنهاراپس ازدستورinterfaceواردنموده وسپسIP Addressبه همراه Subnet راواردکنید.

در صورتی که مایل باشید به اینترفیس روتر سیسکو بیش از یک IP اختصاص دهید لازم است که پس از وارد نمودن IP و Subnet Mask از عبارت Secondary استفاده کنید این عبارت برای آدرس های سوم الی آخر فرقی نخواهد کرد برای مثال برای کانفیگ سومین آدرس بر روی یک اینترفیس روتر سیسکو نیز همانند IP دوم عمل کنید.

برای پاک کردن یکIP ازروی اینترفیس روترسیسکودرصورتی که همان یک IP برروی آن باشدویابخواهیدهمه IP Address هاراحذف نماییدکافی است ازدستور:

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int gi 0/1
R1(config-if)#no ip address

xIP-config.jpg.pagespeed.ic.1koFWnQnFJ

استفاده نمایید.

تنظیم IP Address بر روی اینترفیس سریال روتر سیسکو

اینترفیس های سریال روتر سابق بر این استفاده های گسترده ای در اتصالات wan در ارتباط روتر سیسکو با dsu/csu ها مثل مودم های G.SHDSL – ATM – E1 و … داشتند که با پیشرفت تکنولوژی و افزایش نیاز به سرعت های بالاتر استفاده از این نوع اینترفیس به علت منسوخ شدن تکنولوژی های مرتبط آنچنان مرسوم نیست و دیگر کمتر روتری را میبینیم که مجهز به wic 1t یا wic 2t باشد معذالک ذکر روش تنظیم آدرس IP بر روی اینترفیس های سریال که البته به ندرت اتفاق میافتاد خالی از لطف و مرور خاطرات نیست:

R1(config)# interface serial 0/0/0
R1(config-if)# description Link to R2
R1(config-if)# ip address 209.165.200.225 255.255.255.252
R1(config-if)# clock rate 128000
R1(config-if)# no shutdown
R1(config-if)# exit

تنظیم IP Address بر روی پورت سوئیچ لایه سه سیسکو

سوئیچ های لایه سه سیسکو امکان مسیریابی رادارامیباشندبنابراین میتوانیدبرروی اینترفیس های سوئیچ لایه سه سیسکونظیرسوئیچ سیسکو3560وسوئیچ سیسکو3750 IP ست کنید.

برای تنظیم آدرس IP روی سوئیچ سیسکو ، بدین ترتیب عمل کنید:

R1-3750#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1-3750(config)#int gi 1/0/16
R1-3750(config-if)#no switchport
R1-3750(config-if)#ip address 192.168.57.1 255.255.255.0
R1-3750(config-if)#exit
R1-3750(config)#do sh run int gi 1/0/16
Building configuration…
Current configuration : 93 bytes
!
interface GigabitEthernet1/0/16
no switchport
ip address 192.168.57.1 255.255.255.0
end

ست کردن IP روی اینترفیس های مجازی روتر و سوئیچ سیسکو

vlan ها، تانل ها ( tunnel )، لوپ بک ( loopback )، ساب اینترفیس ها ( sub interface ), … جزء اینترفیس های غیر فیزیکی که به آنها میتوان اینترفیس های مجازی از لحاظ ابعاد وجودی البته اطلاق کرد برای مثال شما میتوانید بر روی یک Vlan حتی در یک سوئیچ لایه 2 سیسکو IP ست کنید لکن این IP تنها به جهت دسترسی به سوئیچ قابل استفاده خواهد بود و استفاده های لایه سه ای نخواهد داشت:

R1-3750#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1-3750(config)#int vlan 301
R1-3750(config-if)#ip address 192.168.65.1 255.255.255.0
R1-3750(config-if)#exit
R1-3750(config)#do sh run int vlan 301
Building configuration…
Current configuration : 64 bytes
!
interface Vlan301
ip address 192.168.65.1 255.255.255.0
end

همچنین در مواردی که یک سوئیچ سیسکو را با یک روتر سیسکو به جهت استفاده از intervlan routing ترانک کرده و یا به هر دلیل نیازمند استفاده از VLAN ها بر روی روتر سیسکو هستید به سادگی میتوانید از sub interface ها IP ست کنید:

R1-Core#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1-Core(config)#int gi 0/1.312
R1-Core(config-subif)#encapsulation dot1Q 312
R1-Core(config-subif)#ip address 192.168.66.1 255.255.255.0
R1-Core(config-subif)#exit
R1-Core(config)#do sh run int gi 0/1.312
Building configuration…
Current configuration : 119 bytes
!
interface GigabitEthernet0/1.312
encapsulation dot1Q 312
ip address 192.168.66.1 255.255.255.0
no cdp enable
end

تنظیم IP Address روی اینترفیس loopback روتر سیسکو

اینترفیس های LOOPBACK یک عضو بی بدیل بر روی روتر های سیسکو هستند آنها مجازی هستند و به هیچ جا متصل نیستند لکن به دلیل اینکه هیچ وقت Down نمیشوند در عمل امکانات مدیریتی مهمی در تنظیم روتر سیسکو به ارمغان می آورند اینترفیس های لوپ بک این اطمینان را به شما میدهند که یک اینترفیس حداقل روی روتر سیسکو همیشه UP و دارای یک IP مشخص است اغلب IP Address تنظیم شده بر روی اینترفیس loopback روتر سیسکو به عنوان IP اصلی روتر در مواقع مختلف مورد استفاده قرار میگیرد.

R1(config)#interface loopback 0
R1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 192.169.1.1 255.255.255.0

آموزش تنظیم IP روتر و سوئیچ سیسکو

درمجموع درشبکه های لایه سه مبتنی برIPاولین وبنیادی ترین بخش آدرس هایIPهستنداین آدرس هاهستندکهRouting Tableروتر هارامیسازندوامکان کارکردشبکه جهانی اینترنت رامیسرمیکنند.

البته در سالهای اخیر IP Version 4 به دلیل محدودیت تعداد تقریبا به اتمام رسید و تمامی Valid IP های version 4 در دنیا توسط سازمانهای جهانی Ripe Iana Arin واگذار Allocate شدند و همکنون دنیا به سمت استفاده از IP Version 6 میرود.

آموزش تنظیم IP روتر و سوئیچ سیسکو

 

منبع : گیک بوی

 

آموزش تنظیمات اولیه سوئیچ های سیسکو

دستورات تنظیمات روتر و سوئیچ سیسکو

چگونگی اتصال به سوئیچ سیسکو

تعویض پورت پیش فرض تلنت در روتر سیسکو

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

دسترسی Telnet به روتر سیسکو

اینترفیس های روتر و سوئیچ سیسکو

تکنولوژی Cisco StackWise چیست

آموزش مفاهیم مسیریابی

آموزش دستورات Show در روترهای سیسکو

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

روش های سوئیچینگ و مسیریابی در شبکه های محلی

پیاده سازی Protected Port در سوئیچ سیسکو

آموزش تنظیم IP روتر و سوئیچ سیسکو

 

تعویض پورت پیش فرض تلنت در روتر سیسکو

تعویض پورت پیش فرض تلنت در روتر سیسکو

تعویض پورت پیش فرض تلنت در روتر سیسکو :یکی از مسائلی که ممکن است باعث به خطر افتادن امنیت روتر های مرزی که دارای IP Valid روی پورت های خود میباشند عملیات Burst Force برای پیدا کردن دسترسی Telnet میباشد.

در درجه اول توصیه میشود که به جای تلنت از SSH استفاده کنید ولی اگر به هر دلیلی میخواهید از روش تلنت استفاده کنید بهتر است این چند توصیه را جهت Secure کردن Line های VTY اعمال نمائید.

در درجه اول چند کامند:

login on-failure log
login on-success log
login delay 3
aaa authentication attempts login 1
aaa authentication fail-message c یک پیغام تهدید آمیز c
aaa authentication login default local-case
  • دو کامند اول یک trap برای ورود یا عدم ورود موفق به syslog ارسال میکند.
  • کامند سوم بعد از ورود 3 ثانیه تاخیر ایجاد میکند.
  • کامند چهارم تنها 1 بار اجازه authenticate به جای 3 بار Default میدهد.
  • کامند پنجم جهت ایجاد رعب و وحشت در شخصی است که به هر دلیلی میخواهد وارد روتر شما شود! شما میتوانید بنویسید که IP شما ثبت خواهد شد و مورد پیگیرد قانونی قرار خواهد گرفت.
  • و کامند آخر باعث میشودکه روتربه حروف بزرگ وکوچک در Username حساس شود،پس ازحروف بزرگ هم استفاده کنید.

تعویض پورت پیش فرض تلنت در روتر سیسکو

تعویض پورت پیشفرض تلنت یعنی 23 به مثلا 3001 یا هر چیز دیگر است.

R1-VG#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1-VG(config)#ip acce e telnet
R1-VG(config-ext-nacl)#permit tcp any any eq 3001
R1-VG(config-ext-nacl)#deny ip any any
R1-VG(config-ext-nacl)#exit
R1-VG(config)#line vty ?
<0-988> First Line number
R1-VG(config)#line vty 0 988
R1-VG(config-line)#rotary 1
R1-VG(config-line)#access-class telnet in
R1-VG(config-line)#^Z

توضیح اینکه ابتدامایک access-list به نام telnet ایجاد میکنیم ودرآن تمامی ارتباطات به جز پورت 3001 را deny میکنیم.

سپس وارد تنظیمات line vty که همان telnet و ssh خودمان است میشویم که بسته به مدل روتر و IOS تعداد آن متفاوت است.

سپس rotary group 1 را اعمال میکنیم که همان پورت 3001 است یا هرچیز دیگر.

سپس access-list telnet را که در آن تمامی ارتباطات به جز پورت 3001 (یا هرچیز دیگر) deny شده را اعمال میکنیم و save و تمام.

حالا تست میکنیم:

R2#1.1.1.1
Trying 1.1.1.1 …
% Connection refused by remote host

R2#1.1.1.1 3001
Trying 1.1.1.1, 3001 … Open
R1
User Access Verification
Username: GEEKBOY.IR

میبینید که ابتدا با پورت دیفالت 23 کانکشن refused شد ولی با پرت 3001 ، ارتباط برقرار شد !!

اگر یک acl همراه با logging بر روی پورت ورودی روتر خود قرار دهید بسته به تعداد IP های موجود تعداد زیادی تلاش جهت ارتباط بر روی پورت 23 خواهید دید!

منبع: گیک بوی

 

شاید این موارد نیز مورد علاقه شما باشد:

دسترسی Telnet به روتر سیسکو

تعریف SSH

راه اندازی SSH در Cisco

بازنشانی پیکربندی سوئیچ های سیسکو به پیش فرض کارخانه

آموزش SNMP در روتر و سوئیچ های سیسکو

آموزش سیسکو Cisco قسمت اول

آموزش سیسکو Cisco قسمت دوم

آموزش سیسکو Cisco قسمت سوم

تعویض پورت پیش فرض تلنت در روتر سیسکو

 

پیاده سازی Protected Port در سوئیچ سیسکو

پیاده سازی Protected Port در سوئیچ سیسکو

پیاده سازی Protected Port در سوئیچ سیسکو :Protected Port یکی از قالبیت های ساده ولی هیجان انگیز و کارا در سوئیچ سیسکو ست، که امکان افزایش ضریب امنیتی و مدیریتی را در سوئیچ سیسکو فراهم می آورد.

Cisco-Protected-Port-624x403

به زبان ساده Protected Port قابلیتی است که از ارتباط پورت های یک VLAN یا Broadcast Domain با یکدیگر در سوئیچ کاتالیست سیسکو جلوگیری مینماید به بیان دیگر مثلا یک سوئیچ 2960 سیسکو را در نظر بگیرید که همه پورت های آن به صورت دیفالت در یک vlan قرار دارند پس همگی آنها میتوانند با هم در ارتباط باشند و مثلا از منابع و فایل های کامپیوتر هایی که به آن پورت ها متصل اند استفاده کنند. فرضا شما میخواهید پورت fast0/1 که متصل به کامپیوتر آقای X است با پورت fast0/12 که مربوط به کامپیوتر خانوم xx است (که با هم فولدر آهنگ ها و …. را share کرده اند)، ارتباط نداشته باشند ولی به شبکه که به مابقی پورت های سوئیچ سیسکو 2960 متصل است دسترسی و امکان تبادل اطلاعات را داشته باشد خب چه باید کرد؟!

unProtected-Port

راه حل استفاده از قابلیت Protected Port است، بدین ترتیب که ما پورت های fast0/1 و fast0/12 را Protected میکنیم. بدین ترتیب این دو پورت با یکدیگر (و دیگر پورت های protected) نمیتوانند تبادل اطلاعات نموده ولی به مابقی شبکه دسترسی دارند.

پیاده سازی Protected Port در سوئیچ سیسکو

به شکل کلی در یک Broadcast Domain سوئیچ سیسکو هر پورت Protected نمیتواند با هیچ پورت Protected دیگری ارتباط داشته باشه ولی میتواند با پورت های Unprotected ارتباط داشته باشد.

همانطور که در تصویر بالا مشاهده میکنید پورت های مربوط به کلاینت A و کلاینت B به شکل Protected در آمده و نمیتوانند با یکدیگر ارتباط داشته باشند ولی میتوانند با Server که به یک پورت Unprotected متصل است ارتباط داشته باشند.

برای قراردادن یک پورت سوئیچ سیسکو در حالت Protected کافیست از این کامند استفاده کنید:

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface GigabitEthernet1/0/5
R1(config-if)#switchport protected
R1(config-if)#^Z

R1#sh int gi 1/0/5 switchport
Name: Gi1/0/5
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 807 (cisco asa dmz1)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: true
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

همانطور که مشاهده کردید در پایان خروجی دستور:

sh int gi 1/0/5 switchport

قید شده است Protected true

 

پیاده سازی Protected Port در سوئیچ سیسکو

منبع : گیک بوی

 

شاید این موارد نیز مورد علاقه شما باشد:

آموزش پیکربندی VLAN سوئیچ سیسکو

Inter Vlan Routing از طریق روتر

کاربرد ها و پروتکل های VLAN قسمت اول

کاربرد هاوپروتکل های VLAN قسمت دوم

مفهوم VLAN Trunking در سوئیچ های سیسکو

پورت Trunk چیست

راه اندازی DHCP بر روی سوئیچ سیسکو

تکنولوژی TrustSec Cisco

آموزش سیسکو استفاده از علامت سوال در CLI

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

پیاده سازی Protected Port در سوئیچ سیسکو

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

فعال سازی روتیگ در سوئیچ لایه سه سیسکو :روتینگ امکان جالب و هیجان انگیزی برای یک سوئیج است به تعبیری روتینگ حدفاصل بین سوئیچ و روتر را کمتر میکند در واقع محصولات جدید سیسکو را نه میتوان روتر نامید نه سوئیچ چون مثلا سری 6500 امکانات لایه یک تا هفت را در حد عالی به شما ارائه میکند که این باعث میشود تصویر ذهنی کاربران نسبت به این محصولات عوض شود.

روتینگ قابلیتی است که ما منحصرا آن را در اختیار روتر های در محصولات سیسکو می دانستیم اما با ارائه سوئیچ کاتالیست سیسکو 3550 و امکانات فوق العاده لایه 3 آن نظر ها عوض شد. در نگاه یک کارشناس شبکه سوئیچ لایه سه سیسکو ابزاری همه فن حریف است که پاسخگوی گستره وسیعی از نیازهای شبکه است محدودیت تعداد پورت روتر را نداشته و همچنین از فناوری ASIC برای پردازش استفاده میکند که این باعث load کمتر و سرعت بیشتر است البته نباید این نکته را فراموش کرد که سوئیچ ها اساسا سوئیچ هستند.

برای این کار بهینه سازی شده اند برای مثال RAM سوئیچ ها قابل ارتقاء نبوده و از ماژول های WIC و NM و همچنین ارتباطات WAN و تکنولوژی های مربوط به آن پشتیبانی نمیکنند در واقع سوئیچ ها با VLAN ها کاردارند و این امکانات روتینگی لایه سه این مزیت را به سوئیچ های سیسکو میبخشد که بتوانند ترافیک این VLAN ها را هم Route کنند.

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

روتینگ قابلیت بسیار مهمی بود که سیسکو از سری 3550 به سوئیچ های میان رده خود اضافه نمود که پس از آن 3560 با بهبود های فراوان و سپس سوئیچ سیسکو 3750 پادشاه سوئیچ های سیسکو با قابلیت های فراوان و قدرت بالا حلال مشکلات شبکه ها و مطلوب متخصصان شبکه گردید بدین ترتیب که در اکثر پیاده سازی ها حضور سوئیچ سیسکو 3750 به عنوان جزئی بی بدیل از شبکه مشاهده میشود.

البته محدودیت های و تفاوت های زیادی بین یک روتر و یک سوئیچ لایه سه وجود دارد که نمی توان از آن چشم پوشی کرد و همیشه نیاز به یک روتر صرف در شبکه های حتی کوچک هم حس میشود برای مثال امکانات NAT کردن در سوئیچ های لایه سه وجود ندارد ولی با تمام این احوال امکانات dynamic routing و پشتیبانی از پروتکل های روتینگی مهمی مثل EIGRP – OSPF – BGP و همچنین استاتیک روتینگ Policy Based Routing امکانات ACL حرفه ای و QOS و خیل کثیری از امکانات روتر ها در سوئیچ های لایه 3 وجود داشته که با توجه به تعدد پورت ها استفاده از آنها در بسیاری از ماموریت ها راه گشا خواهد بود.

فعال کردن روتینگ در سوئیچ لایه سه:

برای فعال کردن امکانات روتینگ در سوئیچ لایه سه مثل سوئیچ سیسکو 3750 و تبدیل آن به یک روتر کار چندانی لازم نیست که انجام دهید کافیست ابتدا با دستور IP Routing امکانات روتینگ را فعال کرده و پس از آن میتوانید به هر پورت IP اختصاص دهید و یا پورت ها را در لایه 2 قرار داده و به vlan ها IP دهید از دیگر قابلیت ها امکان فعال سازی DHCP برای اختصاص IP به کلاینت ها و همچنین فعال سازی dynamic routing protocol است.

نکته جالب اینکه پس از فعال کردن امکانات روتینگ سوئیچ لایه سه سیسکو خللی در کارکرد لایه دو آن ایجاد نمیشود بلکه میتوانید تنظیمات لایه دو خود را نظیر vlan ها و پورت های trunk و همچنین stp – vtp – etherchannel را نیز داشته باشید.

فعال کردن امکانات روتینگ:

R1(config)#ip routing

اختصاص IP به یک پورت خاص

R1(config)#int gi 1/0/20
R1(config-if)#no switchport
R1(config-if)#ip add 217.218.1.1 255.255.255.0

کانفیگ پورت به صورت لایه 2 و اختصاص IP به vlan مربوطه :

R1(config-if)#switchport
R1(config-if)#switchport mode access
R1(config-if)#sw acce vlan 303

R1(config)#int vlan 303
R1(config-if)#ip add 217.218.1.1 255.255.255.0

فعال کردن eigrp:

R1(config)#router eigrp 1
R1(config-router)#network 217.218.1.0 0.0.0.255
R1(config-router)#redistribute connected
R1(config-router)#no auto-summary

نوشتن یک استاتیک روت:

R1(config)#ip route 8.8.8.8 255.255.255.255 172.16.64.1

نوشتن یک ACL و اختصاص آن:

R1(config)#ip acce e 110
R1(config-ext-nacl)#per ip 217.218.1.0 0.0.0.255 any
R1(config-ext-nacl)#per icmp an any
R1(config-ext-nacl)#per tcp an an eq 80
R1(config-ext-nacl)#deny ip any any

R1(config)#int vlan 301
R1(config-if)#ip access-group 110 in

اینهامثالهایی بودازگوشه ای ازامکانات لایه سه سوئیچ لایه سه سیسکو که بافعال کردن قابلیت روتینگ دری جدیدازامکانات وقابلیتهابه روی شماگشوده خواهدشد.

در کل با تمام کارامدی سوئیچ های لایه سه سیسکو نباید ماموریت ذاتی و اصلی این تجهیزات که همانا سوئیچینگ است را از خاطر برد این سوئیچ ها با بهبود های نرم افزاری صورت گرفته امکانات روتینگ را نیز برای بهبود عملکرد دارا بوده ولی نباید از آنها قابلیت های یک روتر تمام عیار را انتظار داشت همانطور که با اضافه کردن یک ماژول سوئیچ NME-X-23ES-1G به یک روتر ISR نمیتوان قابلیت ها و پرفورمنس کامل یک سوئیچ را از آن انتظار داشت چون یک روتر است !!

ولی درمواردی مثلایکpop siteویادرمقاطعی که نیازبه تعددپورت وهمچنین روتینگ باشدبه جای استفاده ازیک سوئیچ درکنارروتروinter vlan routingمیتوان ازامکانات ویژه یک سوئیچ لایه سه بهره مندگردید.

منبع: گیک بوی

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

شاید این موارد نیز مورد علاقه شما باشد:

آموزش روتینگ سوئیچ لایه سه سیسکو

لایه بندی شبکه فصل اول

لایه بندی شبکه فصل دوم

آموزش سیسکو استفاده از علامت سوال در CLI

آشنایی با پروتکل RIP

تکنولوژی Cisco StackWise چیست

آموزش دستورات Show در روترهای سیسکو

لایه بندی شبکه فصل دوم

مدل های مختلف سیستم عامل سیسکو

مدل های مختلف IOS های سوئیچ های سیسکو

مدل سه لایه ای سیسکو برای طراحی شبکه

فعال سازی روتینگ در سوئیچ لایه سه سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو

راه اندازی DHCP بر روی سوئیچ سیسکو :DHCP یکی از پر کاربرد ترین سرویس های شبکه است که در خفا و پس ضمینه مسئول اختصاص آدرس های IP به کلاینت های شبکه است این سرویس جزء لاینفک شبکه های بزرگ کوچک بوده و از ابتدایی ترین تراکنش های ارتباطی در شبکه های LAN است.

DHCP سرور

DHCP سرور

هنگامی که شما یک کلاینت را به یک شبکه مرتبط میکنید و یا با یک سرور PPP ارتباط برقرار میکنید پس از احراز هویت دریافت آدرس IP از ابتدایی ترین واکنش هاست. استفاده از DHCP علاوه بر افزایش کارایی شبکه به افزایش چشمگیر امنیت در شبکه های مبتنی بر سیسکو می انجامد. بدین ترتیب که به عنوان یک مدیر شبکه امکان مدیریت و رصد مشکلات به سادگی امکان پزیر است و همچنین از مشکلاتی نظیر IP Conflict و دسترسی غیر مجاز به آدرس های IP جلوگیری به عمل می آید. پیاده سازی DHCP بر روی روتر ها و سویئچ های سیسکو به سادگی امکان پذیر بوده و ترافیک و لود چندانی را به دستگاه تحمیل نمینماید.

راه اندازی DHCP بر روی سوئیچ سیسکو

شروع کار:

توصیه میشود ابتدا یک دیتابیس برای نگهداری واگذاری آدرس های IP ایجاد و دسترسی FTP به آن را میسر نمایید:

Router(config)# ip dhcp database ftp://user:password@172.16.1.1/router-dhcp timeout 80

جلوگیری از اعطای آدرس های 100 تا 103:

Router(config)# ip dhcp excluded-address 172.16.1.100 172.16.1.103
Router(config)# ip dhcp pool 1
Router(dhcp-config)# utilization mark high 80 log
Router(dhcp-config)# network 172.16.0.0 /16
Router(dhcp-config)# domain-name rootlan #domain name
Router(dhcp-config)# dns server 217.218.127.127 217.218.155.155 #dci dns servers
Router(dhcp-config)# default-router 172.16.1.100 172.16.1.101 #this is the Gateway address
Router(dhcp-config)# option 19 hex 01 #additional dhcp option code for example tftp address
Router(dhcp-config)# lease 30 # the lease amount

بدین ترتیب امکان استفاده از امکانات DHCP بر روی روتر و سوئیچ های سیسکو میسر میگردد البته امکانات پیشرفته تری نیز وجود داره که در صورت نیاز میتوانید از آنها استفاده کنید لازم به توضیح است استفاده از سرویس DHCP بر روی شبکه های VLAN که دارای Access Switch و Core Switch هستند بر روی سوئیچ های لایه دسترسی توصیه میشود.

اگر به هر دلیلی مایل به استفاده از دیتابیس جهت ثبت واگذاری IP نبودید میتوانید از این کامند استفاده نمایید:

Router(config)# no ip dhcp conflict logging

توسط این دستور میتوانید میزان استفاده از منابع IP را مشاهده کنید:

Router(config)# ip dhcp use class

راه اندازی DHCP بر روی سوئیچ سیسکو

شاید این موارد نیز مورد علاقه شما باشد:

پیاده سازی پروتکل مسیریابی RIP

آسیب‌پذیری پروتکل UPnP در برابر حملات DDOS

پروتکل OSPF

آموزش پیکربندی پروتکل های مسیریابی پیشرفته

آموزش پیکربندی پروتکلهای بردار فاصله

پروتکل های مسیریابی Classful vs Classless

پروتکل ISL انحصاری شرکت سیسکو

تغییر firmware تلفن های سیسکو

مفهوم SDN

راه اندازی DHCP بر روی سوئیچ سیسکو